×

INDI Library v1.8.9 Released (01 Mar 2021)

INDI monthly update. In addition to driver improvements, major code refactoring is in progress by @pawel-soja to modernize and improve INDI aging code.

New forum users, please go here first: indilib.org/forum/new-forum-users.html

New Pentax Driver Testing

  • Posts: 42
  • Thank you received: 6

Replied by karlrees on topic New Pentax Driver Testing

Were you using a lens, or doing prime focus? For the K-70 at least, the SDK provided by Ricoh does not expose certain settings unless it detects a lens on the camera that supports those settings. I'm sure whoever decided on this limitation thought they were doing the user a favor by only exposing settings supported by the lens, but obviously they were not thinking about prime focus. Anyway, this means that PTP mode is severely handicapped if you're doing prime focus. Much to my frustration, I did not discover this until after I had already developed the PTP driver, as I probably would have started with MSC mode only had I been aware of the limitation.

The Ricoh SDK does not support bulb mode for PTP with the K-70 (or any camera, I suspect).
7 months 1 week ago #59391

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 1

karlrees wrote: (Hmmm, I did just have an idea though--I wonder if I can could add an option for the driver to downsample or clip the original image before FITs conversion, to speed things up. I'll add that to my list of things to look into).


Than the polar alignment tool in ekos would maybe also be possible using the K70 and a refresh rate around 1 - 2 seconds. Am i right?.
7 months 1 week ago #59393

Please Log in or Create an account to join the conversation.

  • Posts: 74
  • Thank you received: 6

karlrees wrote: Were you using a lens, or doing prime focus? For the K-70 at least, the SDK provided by Ricoh does not expose certain settings unless it detects a lens on the camera that supports those settings. I'm sure whoever decided on this limitation thought they were doing the user a favor by only exposing settings supported by the lens, but obviously they were not thinking about prime focus. Anyway, this means that PTP mode is severely handicapped if you're doing prime focus. Much to my frustration, I did not discover this until after I had already developed the PTP driver, as I probably would have started with MSC mode only had I been aware of the limitation.

The Ricoh SDK does not support bulb mode for PTP with the K-70 (or any camera, I suspect).


I use my M200 f4 lens, manual prime.
For me, ISO is not that important, I tend to stick to ISO800.
@Noideadoeaname, you should be able to use your K-70 for proper polar alignment, I don’t know if 1-2sec exposure time is sufficient, if not, it will be difficult to control.
7 months 1 week ago #59400

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 1
That was just a flash of thought ;)

I managed to get 1 arcminute error on the K70 while using my guiding cam to do the polar alignment. Think that's okay for 750mm focal length while guiding.
7 months 1 week ago #59402

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 1
Anything new about the driver?
6 months 3 days ago #61429

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 6

Replied by karlrees on topic New Pentax Driver Testing

No. There are not enough hours in the day, unfortunately. I did respond to the pixel size issue on GitHub. I think it's technically a KStars/Ekos issue, not a driver issue, but the driver could probably be enhanced to supply the values for the K70 so as to avoid the issue in the future.

I had done some initial profiling a while back to see how much time FITs conversion was taking on the Pi4. I was surprised to find it taking less than a second, which is a big improvement over the Pi3 and probably attributable to having more memory available. Unfortunately, this means that clipping and/or downsampling before FITs conversion is unlikely to help much--the bottleneck right now appears to be the transfer from the camera to the Pi4. I'm going to look into it one more time just to double check, though.

Were there any other loose ends?
6 months 2 days ago #61456

Please Log in or Create an account to join the conversation.

  • Posts: 74
  • Thank you received: 6
Since you are asking Karl :-)
If we could have an exposure start pulse and an exposure stop pulse, that would make the day for K-70 users. It should be a feature you can activate/deactivate in case you use a camera like the KP or K-1 which is supposed to be working with the Pentax SDK.
Last edit: 6 months 2 days ago by DrawsACircle.
6 months 2 days ago #61459

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 1
My K70 was broken and i received it last week again... with a new shutter (under warranty). 50.000 pictures where maybe too much in 20 months :whistle:

Everything works fine now using the latest Kstars release. Pixelpitch etc. is reported as it should.

I even got my problem solved with the external power source. I cable i bought on AliExpress did it. Now i can power my K70 using an USB port on a powerbank.

Meanwhile i bought a K3 II in good condition while my K70 was at service.

The camera is recognized while using your Native Driver in PTP and MFT mode. I can change ISO, Aparture, exposure compensation, etc...

I was able to take exposures longer (?) than 30 seconds while in manual mode... but no file is transfered. Bulb is not working (or no second press is send to stop exposure?!?!?)

Any idea on this issue using the k3 II?
4 months 3 weeks ago #63335

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 6

Replied by karlrees on topic New Pentax Driver Testing

I don't have a K3-II for testing. I wouldn't object to having one, of course, but my wife thinks the money would be better spent elsewhere :)

I think someone else was having some issues with the K3-II as well. I can't recall where that conversation ended up, but I think the issue was related to this thread: github.com/asalamon74/pktriggercord/issues/25. So perhaps try astrotracer mode instead of bulb, and make sure that bulb mode is in press-hold mode? Oh, and just in case, make sure you're in MSC/MFT, because I suspect PTP does not support bulb on any camera.
4 months 3 weeks ago #63344

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 1
It didn't work... i tried different combinations of the settings in camera and KStars/Ekos.

My conclusion is now not to sell the K70 and keep both cameras.

Fortunately i got no wife to discuss this ;)
4 months 2 weeks ago #63408

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 1
I don't know what happend, but after i updated KStars i stumbled upon an update for "Pentax cameras in MSC Mode" and the K3 II is working :cheer:

1. MSC Mode
2. Bulb Mode with turned on GPS and Astrotracer

The shutter releases two times before the exposure starts, but i think this is related to the LiveView which was turned on.

Great work :woohoo:
Last edit: 3 months 3 days ago by Noideaforaname.
3 months 3 days ago #65772

Please Log in or Create an account to join the conversation.

  • Posts: 74
  • Thank you received: 6

Noideaforaname wrote: I don't know what happend, but after i updated KStars i stumbled upon an update for "Pentax cameras in MSC Mode" and the K3 II is working :cheer:

1. MSC Mode
2. Bulb Mode with turned on GPS and Astrotracer

The shutter releases two times before the exposure starts, but i think this is related to the LiveView which was turned on.

Great work :woohoo:


Just testing SM OS 1.5.6 with my setup, I guess I'll have to include my K-70 in the test :-)
From previous testing, I've also noticed the K-70 releases the shutter a couple of times when shooting.
Last edit: 3 months 3 days ago by DrawsACircle.
3 months 3 days ago #65775

Please Log in or Create an account to join the conversation.

Time to create page: 0.470 seconds