×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

indi_celestron_aux

  • Posts: 17
  • Thank you received: 4

Replied by Jack on topic indi_celestron_aux

Thanks Fabrizio, good to know it's sorted out in the next version.

I'm using the drivers through a stellarmate OS install, so won't touch the specific driver and wait for an update through that (and in the meantime enable the subsystem).

Happy to have an answer after a few days of testing though.. so thanks for the pointers! (Of course its now cloudy haha).

Cheers,
Jack
1 year 10 months ago #65917
The topic has been locked.

Replied by Jasem Mutlaq on topic indi_celestron_aux


Hmmm why was it green then? This needs investigation.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 10 months ago #65921
The topic has been locked.
  • Posts: 33
  • Thank you received: 3

Replied by Ken Kelso on topic indi_celestron_aux


CordWrap is the same, green light stays on all the time no matter what the state.

BTW I still have no issues to report using the driver in Alt/Az mode on my NexStar 6SE.

Ken
1 year 10 months ago #65937
The topic has been locked.
  • Posts: 36
  • Thank you received: 0

Replied by Maciek on topic indi_celestron_aux

I believe that green light indicate that value (on/off/any) of param (align subsystem/cord wrap/any) is valid/fresh. Not state of param itself.
1 year 10 months ago #65946
The topic has been locked.
  • Posts: 17
  • Thank you received: 4

Replied by Jack on topic indi_celestron_aux

Hey Gents,

While it's likely more a user error on my side, @Fabrizio i did compile the new version of the driver and am having an issue ( www.indilib.org/forum/general/8632-inver...kstars-movement.html ). Likely something non driver related.. but just in case!

Jack
1 year 10 months ago #65996
The topic has been locked.
  • Posts: 2
  • Thank you received: 0

Replied by Thomas Götz on topic indi_celestron_aux

Hi,

made a bugreport "indi-celestronaux does'nt work on USB PC Port of CGX" in github.com/indilib/indi-3rdparty/issues/298, one answer was to report here, so :

Hello,

hoped the driver would work when I attach the RPI to the USB PC Port of my CGX, but it does'nt .
Did I misunderstand the usage?
On the other hand, when i connect this port it to my PC, a serial port appears and I can watch the communication with my written program, it displays the traffic between HC, GPS and so on when scope powered on.
Using the USB Serial on Handcontroller it works as expected.


And here further details:

Gelestron CGX, EQ-N mode. Homebrew GPS Module at AUX2, Handcontroller (short HC correct?) at AUX1
RPI 4, Astroberry like setup.


built indi & 3rd party drivers from github.com/indilib/indi and github.com/indilib/indi-3rdparty

Indi works with Celestron CGX driver (INDI Web Manager), USB via HC Port connected to RPI, Driver appears in indi control panel as Celestron GPS.

this setup doesnt work when connected to PC USB Port of Mount

lsusb shows the device: Bus 001 Device 006: ID 15a2:a50f Freescale Semiconductor, Inc.

Listening with my java app shows the traffic on PC USB Port, example:

Received: 9
0x00000000 3B 06 0D 10 04 40 00 00 99 ;....@...
Received: <HDR 3b len 6 Src HCP Dst AZM Cmd MC_SET_POSITION Data <40 00 00 >
Received: 6
0x00000000 3B 03 10 0D 04 DC ;.....
Received: <HDR 3b len 3 Src AZM Dst HCP Cmd MC_SET_POSITION Data <>
Received: 9
0x00000000 3B 06 0D 11 04 40 00 00 98 ;....@...
Received: <HDR 3b len 6 Src HCP Dst ALT Cmd MC_SET_POSITION Data <40 00 00 >
Received: 6
0x00000000 3B 03 11 0D 04 DB ;.....
Received: <HDR 3b len 3 Src ALT Dst HCP Cmd MC_SET_POSITION Data <>
Received: 9
0x00000000 3B 06 0D 10 3A C0 00 00 E3 ;...:....
Received: <HDR 3b len 6 Src HCP Dst AZM Cmd 3A Data <C0 00 00 >
Received: 6
0x00000000 3B 03 10 0D 3A A6 ;...:.
Received: <HDR 3b len 3 Src AZM Dst HCP Cmd 3A Data <>
Received: 6
0x00000000 3B 03 0D 10 38 A8 ;...8.
Received: <HDR 3b len 3 Src HCP Dst AZM Cmd 38 Data <>
Received: 6
0x00000000 3B 03 10 0D 38 A8 ;...8.
Received: <HDR 3b len 3 Src AZM Dst HCP Cmd 38 Data <>
Received: 9
0x00000000 3B 06 0D 11 3A C0 00 00 E2 ;...:....
Received: <HDR 3b len 6 Src HCP Dst ALT Cmd 3A Data <C0 00 00 >
Received: 6
0x00000000 3B 03 11 0D 3A A5 ;...:.
Received: <HDR 3b len 3 Src ALT Dst HCP Cmd 3A Data <>
Received: 6
0x00000000 3B 03 0D 11 38 A7 ;...8.
Received: <HDR 3b len 3 Src HCP Dst ALT Cmd 38 Data <>
Received: 6
0x00000000 3B 03 11 0D 38 A7 ;...8.
Received: <HDR 3b len 3 Src ALT Dst HCP Cmd 38 Data <>

Sending Data to the port works:
You select : APP
Sent:
0x00000000 3B 03 20 11 FE CE ;.....
<HDR 3b len 3 Src APP Dst ALT Cmd GET_VER Data <>

You select : ALT
Received: 10
0x00000000 3B 07 11 20 FE 07 11 00 19 99 ;.........
Received: <HDR 3b len 7 Src ALT Dst APP Cmd GET_VER Data <07 11 00 19 >


Next Step: selecting the Celestron Aux driver in indi web manager.
In indi control panel it displays version 0.7

Connection fails with:

20:35:48.285: [DEBUG] Connecting to /dev/ttyACM0 @ 19200
20:35:48.285: [DEBUG] Port FD 3
20:35:48.285: [DEBUG] Connection successful, attempting handshake...
20:35:48.285: [DEBUG] CAUX: connect 3 (serial)
20:35:48.285: [INFO] Detected AUX or PC port connection.
20:35:48.285: [INFO] Setting serial speed to 19200 baud.
20:35:48.285: [INFO] Trying to contact telescope motor controllers.
20:35:48.285: [ERROR] Got no response from target ALT or AZM.
20:35:48.285: [ERROR] Cannot continue without connection to motor controllers.
20:35:48.285: [DEBUG] Handshake failed.

Hope this helps.
Celestron CGX, ASI2600, Homebrew GPS Module
1 year 10 months ago #66289
The topic has been locked.
  • Posts: 213
  • Thank you received: 118

Replied by Rick Bassham on topic indi_celestron_aux

Götz, I don't think this driver will work with the USB port on the CGX as is. It uses the same protocol as this driver, but doesn't use the RTS/CTS signalling this driver uses.

I wrote a custom CGX USB driver you can try out (I've been using it myself for a while and it seems to work fine). It probably won't work in the southern hemisphere though.

github.com/rickbassham/indi-celestron-cgx/
Gayle H Riggsbee Observatory - Charlotte Amateur Astronomers Club
CEM120 - TMB 100/800 - AT72EDII w/Homemade Moonlite Compatible Arduino Focuser - AT8RC w/Moonlite CSL 2.5" w/Moonlite Stepper v3
ZWO ASI2600MC-Pro - ZWO ASI2600MM-Pro - ZWO ASI174MM-Mini - ZWO OAG - ZWO EFW
AT2FF - CCDT67 - RIRED-M63
1 year 10 months ago #66291
The topic has been locked.
  • Posts: 2
  • Thank you received: 0

Replied by Thomas Götz on topic indi_celestron_aux


Hi, built your driver both on RPI and PC (Ubuntu 20), confirmed to connect and interact with the CGX.

But anything goes wrong, goto's result in pointing to anywhere, not to the target.

Is there a howto for this driver ?
Celestron CGX, ASI2600, Homebrew GPS Module
1 year 10 months ago #66424
The topic has been locked.
  • Posts: 213
  • Thank you received: 118

Replied by Rick Bassham on topic indi_celestron_aux

Hey Götz, I just got the driver out under the stars for the first time in a while (clouds) and had some issues as well. I'm going to debug my latest changes to see what's wrong. If you watch the github repo (top right) you'll get a notification when an update is released.
Gayle H Riggsbee Observatory - Charlotte Amateur Astronomers Club
CEM120 - TMB 100/800 - AT72EDII w/Homemade Moonlite Compatible Arduino Focuser - AT8RC w/Moonlite CSL 2.5" w/Moonlite Stepper v3
ZWO ASI2600MC-Pro - ZWO ASI2600MM-Pro - ZWO ASI174MM-Mini - ZWO OAG - ZWO EFW
AT2FF - CCDT67 - RIRED-M63
1 year 10 months ago #66442
The topic has been locked.
  • Posts: 238
  • Thank you received: 49

Replied by Gene N on topic indi_celestron_aux

Anyone have any info on the AUX command 0x05 ?
Just wondering, I do not see it enumerated in the auxproto.h nor in the doc from paquettefamily.ca/nexstar/NexStar_AUX_Commands_10.pdf

This is what I see from the HC towards the ALT/AZ on startup
0x3b 0x03 0x0d 0x11 0x05 0xda To ALT, CMD = 5 ???
0x3b 0x05 0x11 0x0d 0x05 0x0c 0x82 0x4a
0x3b 0x03 0x0d 0x10 0x05 0xdb To AZ, CMD = 5 ???
0x3b 0x05 0x10 0x0d 0x05 0x0c 0x82 0x4b

Just wondering about AUX command and not specifically about the indi aux driver
1 year 10 months ago #66522
The topic has been locked.
  • Posts: 64
  • Thank you received: 9

Replied by Fabrizio on topic indi_celestron_aux

Hi,
I have added some features to the indi_celestron_aux driver.
1. direct mount USB connection.
2. cordwrap position computed by alignment subsystem.
3. autoguide: the code is roughly copied from Rick's driver indi_celestron_cgx.
Unfortunately, I haven't any checking setup, so they compile and run without fatal errors but the functionality is completely untested.
If someone brave and patient wants to try them, the code is here github.com/fabriziop/indi-3rdparty/tree/celestronaux_eqtrack
Last edit: 1 year 10 months ago by Fabrizio.
1 year 10 months ago #66698
The topic has been locked.
  • Posts: 238
  • Thank you received: 49

Replied by Gene N on topic indi_celestron_aux

Quick question please,

Is this a valid command?
indi_setprop "Celestron AUX.ALIGNMENT_SUBSYSTEM_ACTIVE.ALIGNMENT SUBSYSTEM ACTIVE=On"

I am trying to do a scripted startup of a Celestron and this is throwing an error

Thank you for your time,

Gene
1 year 9 months ago #67428
The topic has been locked.
Time to create page: 1.245 seconds