´╗┐
×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

New KStars 3.5.2 DMG to test

  • Posts: 2826
  • Thank you received: 792

Oh very good. So there wasn't an issue with QHY??
1 year 9 months ago #67824

Please Log in or Create an account to join the conversation.

  • Posts: 2826
  • Thank you received: 792

Ok I will try doing this this evening with my ZWO, and if I can get it to work, I will send you a list of files to copy so you can see if you get the same issue.
1 year 9 months ago #67825

Please Log in or Create an account to join the conversation.

  • Posts: 206
  • Thank you received: 31
Hy + Rob,

I did some test guiding this evening with KStars 350 and KStars 352
As usual I could guide with KStars 350 but not with KStars 352
My guiding camera was a ZWO CCD ASI174MM
The sky was really not good (even to find a guide star)
The two logs (KStars 350.txt and KStars 352.txt) are in the compressed folder at : dl.free.fr/rCADOFLpd

Best regards
Celestron EdgeHD 11 on Celestron CGE Pro
Celestron OAG and MicroTouch Autofocuser
ASI2600MC Pro + ASI174MM
HyperStar
MaxDome II
1 year 9 months ago #67828

Please Log in or Create an account to join the conversation.

  • Posts: 918
  • Thank you received: 431
Jean Claude, Not really sure what going on.
Can you please try SEP MultiStar and see if things are better with that?
To turn that on (see screenshot below) go to the guider tab, options on lower right, guide section (2nd from top on left), and for algorithm choose SEP MultiStar.
What guiding scheme are you currently using?
Hy
AP1100 & Orion Atlas Pro, WO/ZS105 w/Moonlight V2 focus, GSO RC10 w/RSF focus
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Greedy Scheduler, Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
1 year 9 months ago #67831
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 2826
  • Thank you received: 792

Ok, it turns out that this is much simpler than it sounded. The only file that was missing from 3.5.1 that made it not work was one of the libraries, I copied that in and the camera worked right away.
As I had said before, it was just a broken link in my build folder that made 3.5.1 not work with ZWO. But it turns out that most of the files in there were good, it was just that one file.

Just copy this file into 3.5.1 from 3.5.2 and see if 3.5.1 works with ZWO for you.
/Applications/KStars.app/Contents/Frameworks/libASICamera2.dylib

Then if you can guide with 3.5.1, we can narrow down what is causing your guiding issue.
1 year 9 months ago #67832

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Thank you received: 0
Seems to be working good. What I discovered so far:

Dialog boxes for covering the shutter are popping up behind the Ekos tab and Fits Viewer (when open).
1 year 9 months ago #67864

Please Log in or Create an account to join the conversation.

  • Posts: 1944
  • Thank you received: 419
The Mount Control popup, that can be opened with the Mount Control button in the mount tab, is too narrow and needs to be resized everytime it gets opened.
Wouter van Reeven

ASI6200MM and 7 slot 2" filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and 5 slot 1.25" filter wheel with an 8" TS Ritchey-Chr├ętien on a SkyWatcher EQ6-R
1 year 9 months ago #67876

Please Log in or Create an account to join the conversation.

  • Posts: 2826
  • Thank you received: 792

So I don't think there is anything we can really do about this. This issue has been there since I first ported KStars to Mac in 2016. Basically, on Linux, there is a concept of parent and child windows and that works very nicely where the child windows will be on top of their parent windows so that the KStars skymap will pretty much always be in the background and the other things will appear in front of it. But on Mac, windows are pretty much independent of one another unless they are like modal dialog boxes requesting user feedback. So, when I first got KStars building on my Mac, I found it very annoying that many windows would go behind the skymap when I would click on the skymap. The best solution that I found was to make all the other windows "always on top" and for the most part this works well. The unfortunate side effect of that is that sometimes a few dialogs will end up behind those windows. But I think that is much better than them disappearing behind the whole skymap which is usually a much larger window, so thats why I did it that way. Its not perfect, but I think it is the best option
1 year 9 months ago #67878

Please Log in or Create an account to join the conversation.

  • Posts: 2826
  • Thank you received: 792

Is this a Mac specific issue? I don't think it is related to the Mac build, or related to my build script, this seems to be a more general issue. I can bring it to the attention of others, certainly.
1 year 9 months ago #67879

Please Log in or Create an account to join the conversation.

  • Posts: 206
  • Thank you received: 31
Hy & Rob,
I've done some further guide testing with KStars 351 and KStars 352.
Rob : I added the missing library libASICamera2.dylib to KStars 351 for the ZWO compatibility
Hy : I used both guide algorithms Smart and SEP Multi Star : this is not the origin of the guiding bug. No difference.
Result : you will find the logs at dl.free.fr/mVWNquxeq
- KStars 351 : guiding is no problem
- KStars 352 : guiding is not possible : see the screenshot "scope cannot reach the start point after 21 iterations"
Celestron EdgeHD 11 on Celestron CGE Pro
Celestron OAG and MicroTouch Autofocuser
ASI2600MC Pro + ASI174MM
HyperStar
MaxDome II
1 year 9 months ago #67881

Please Log in or Create an account to join the conversation.

  • Posts: 206
  • Thank you received: 31
Hy & Rob,
I've done some further guide testing with KStars 351 and KStars 352.
Rob : I added the missing library libASICamera2.dylib to KStars 351 for the ZWO compatibility
Hy : I used both guide algorithms Smart and SEP Multi Star : this is not the origin of the guiding bug. No difference.
Result : you will find the logs at dl.free.fr/mVWNquxeq
- KStars 351 : guiding is no problem
- KStars 352 : guiding is not possible : see the screenshot "scope cannot reach the start point after 21 iterations"
Celestron EdgeHD 11 on Celestron CGE Pro
Celestron OAG and MicroTouch Autofocuser
ASI2600MC Pro + ASI174MM
HyperStar
MaxDome II
1 year 9 months ago #67882

Please Log in or Create an account to join the conversation.

  • Posts: 28
  • Thank you received: 0
No issues at all - it worked flawlessly. I did notice the filter window being in the background and the narrow mount control dialog as mentioned by other users, but these are very minor issues in my view. Thanks for all the hard work.
1 year 9 months ago #67884

Please Log in or Create an account to join the conversation.

Time to create page: 1.043 seconds