×

INDI Library v1.9.5 Released (08 Mar 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Ekos won't connect to Nexdome rotator system (SOLVED)

  • Posts: 678
  • Thank you received: 82
I just installed a Nexdome rotator motor and it uses a USB cable to connect to the computer. I am using a MacBook with the OS X version of KStars (3.4.3).
INDI recognizes the rotator firmware, but then the handshake fails.

s.indi] - NexDome : "[DEBUG] Connecting to /dev/cu.usbmodem14101 @ 9600 "
[2020-09-17T08:35:26.991 MDT DEBG ][ org.kde.kstars.indi] - NexDome : "[DEBUG] Port FD 3 "
[2020-09-17T08:35:26.991 MDT DEBG ][ org.kde.kstars.indi] - NexDome : "[DEBUG] Connection successful, attempting handshake... "
[2020-09-17T08:35:26.993 MDT DEBG ][ org.kde.kstars.indi] - NexDome : "[DEBUG] CMD <@FRR> "
[2020-09-17T08:35:26.993 MDT DEBG ][ org.kde.kstars.indi] - INDI Server: "2020-09-17T14:35:26: Driver indi_nexdome: Handshake lines currently set to 6"
[2020-09-17T08:35:26.993 MDT DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2020-09-17T08:35:27.049 MDT DEBG ][ org.kde.kstars.indi] - NexDome : "[DEBUG] RES <:FR3.3.0> "
[2020-09-17T08:35:27.050 MDT INFO ][ org.kde.kstars.indi] - NexDome : "[INFO] Detected rotator firmware version 3.3.0 "
[2020-09-17T08:35:27.051 MDT DEBG ][ org.kde.kstars.indi] - NexDome : "[DEBUG] CMD <@FRS> "
[2020-09-17T08:35:30.057 MDT INFO ][ org.kde.kstars.indi] - NexDome : "[ERROR] Serial read error: Timeout error. "
[2020-09-17T08:35:30.057 MDT DEBG ][ org.kde.kstars.indi] - NexDome : "[DEBUG] Handshake failed. "
[2020-09-17T08:35:30.058 MDT DEBG ][ org.kde.kstars.ekos] - "NexDome" is disconnected.
[2020-09-17T08:35:30.058 MDT INFO ][ org.kde.kstars.ekos] - "NexDome is disconnected."

I can use the manual buttons on the motor itself to move it, so It works. The issue is just the USB connection to INDI.

iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD
William Optics Star71
ASI 1600Mm Pro, ASI 462MC
Moonlight motorfocus & Esatto focuser
LodeStar X2 and ZWO OAG
DewBuster
NANO PC-T4
1 year 8 months ago #60146

Please Log in or Create an account to join the conversation.

  • Posts: 678
  • Thank you received: 82
I found out that I must have the shutter motor system up and running in addition to the rotation system in order for this to work. The system was hanging while waiting for the shutter.

iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD
William Optics Star71
ASI 1600Mm Pro, ASI 462MC
Moonlight motorfocus & Esatto focuser
LodeStar X2 and ZWO OAG
DewBuster
NANO PC-T4
The following user(s) said Thank You: Sonny Cavazos
1 year 8 months ago #60163

Please Log in or Create an account to join the conversation.

  • Posts: 183
  • Thank you received: 23
Perhaps not - I am getting the same error and the Shutter is clearly connected. I can't slew the dome or open teh shutter - despite the driver connecting and reporting the right firmware version.

I've recently tried to get back into kstars after a spell of using Voyager as my daily (because I needed to get imaging done during variable weather conditions and Ekos doesn't handle that too well and I don't have the coding skills to add the new functionality I need!) - a little sad that it's not working.
GSO Ritchey Chretien 12" Truss | SkyWatcher ED72
ZWO ASI 2600MC Pro, 1600MM Pro, ASI290MM and ASI224MC all-sky | ZEO EFW | ZWO OAG
Moonlite V2.5 CSL | DeepSkyDad AF3
EQ8-R | Paramount ME & MX
Nexdome | SQM LE | AAG CloudWatcher and Solo | Ultimate Power Box V2 | Spike-a-Flat
Angry missus
4 months 6 days ago #79344

Please Log in or Create an account to join the conversation.

  • Posts: 678
  • Thank you received: 82
Be sure the SLAVE and Rotation settings are correct. I have found many times INDI wouldn’t load the settings back and so the speeds were reset back to zero. Thus the dome and shutter wouldn’t move.

iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD
William Optics Star71
ASI 1600Mm Pro, ASI 462MC
Moonlight motorfocus & Esatto focuser
LodeStar X2 and ZWO OAG
DewBuster
NANO PC-T4
4 months 6 days ago #79348

Please Log in or Create an account to join the conversation.

Time to create page: 0.198 seconds