×

INDI Library v1.9.3 Released (11 Nov 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

optimizing plate solver

  • Posts: 39
  • Thank you received: 0
I was happy to get remote plate solving to work on my setup. However, each iteration of plate solving took between 50 and 60 seconds.

Is this to be expected? Or should it be faster? The illustration on the "Alignment Module" page shows 2 seconds.

There doesn't seem to be very much to change in the solver options window since the telescope coordinates and sensor size get read into the command line automatically. I tried reducing the size of the search field since the possible error seems to be far less than 30 degrees, but that had no effect.

Any suggestions would be appreciated.

Thanks.
2 months 1 week ago #75866

Please Log in or Create an account to join the conversation.

  • Posts: 728
  • Thank you received: 336

Replied by Hy Murveit on topic optimizing plate solver

Yes, my plate solving is typically under 10s, usually much faster. though occasionally I too fall into plate solving weirdness.
Point us to a fts file taken from capture but with the same parameters as your align, e.g. a target that takes 50s, perhaps a 5-10s exposure time (e.g. put it on Google Drive and share a link) and I and others can try and solve it and let you know how it ran. I usually play with the solver by running the command-line astap, and stellarsolver also has a tool to test solving -- StellarSolver_Tester, or something like that.

What you can play with is:
- make sure you're in focus
- make sure your focal length
- exposure time to make sure you have enough stars
- use/disable use position & use scale, though I usually have those disabled.
- downsampling
- stellarsolver profile and the profile's (many) star-detection and solver parameters, if you're using the internal solver and not ASTAP. ASTAP doesn't really have many parameters that are used, but also seems to work well.

Hy

-
Orion Atlas Pro, William Optics ZS105, Moonlight V2 focuser, GSO RC10 w/RSF focuser
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm guidecam.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
2 months 1 week ago #75875

Please Log in or Create an account to join the conversation.

  • Posts: 39
  • Thank you received: 0

Replied by Mark Copper on topic optimizing plate solver

Thank you. Cloudy here tonight. I'll work through suggestions at first clearing.
2 months 1 week ago #75884

Please Log in or Create an account to join the conversation.

  • Posts: 92
  • Thank you received: 2

Hello Hy,

I haven’t changed anything in my settings or my setup and after the upgrade I get this and it’s just not platesolving at all. My numbers seems to be ok. Where I have to look?


Sent from my iPhone using Tapatalk
2 months 1 week ago #75902

Please Log in or Create an account to join the conversation.

  • Posts: 728
  • Thank you received: 336
It''s hard to tell from your description, but at least from the rough picture, I only see one star in the image. Could that be the problem? Does the image look OK to you in person? E.g. wait till darker, use longer exposure or gain, ...? If you capture an image with the same settings and upload it to astrometry.net, does it solve there?

I don't think anything changed with respect to plate solving / polar alignment in this release.

I don't have much experience with such a wide field of view, but as you say, it worked before.

Hy

Hy
Orion Atlas Pro, William Optics ZS105, Moonlight V2 focuser, GSO RC10 w/RSF focuser
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm guidecam.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
The following user(s) said Thank You: Euripides
2 months 1 week ago #75903

Please Log in or Create an account to join the conversation.

  • Posts: 92
  • Thank you received: 2
Yes practically you can see only Polaris, because is much brighter than the others (and also from my bad iPhone pic).

Folowing your tips from precious posts, those settings worked like a charm before without a single issue. Platesolving between 2-4 sec maximum. But now always fails.

I've switched to online astrometry and worked - of course extremely slower ..

In addition to that - and probably that causes the issue - now a message appears (Polar Alignment tab):

"DISABLED: FOV must be 10 arcmins or wider. 60+arcminutes is recommended."

What is that? Where do I have to look for that? Cause all my numbers are the same wherever I look.

Also, the direction option is disabled.
Last edit: 2 months 1 week ago by Euripides.
2 months 1 week ago #75904

Please Log in or Create an account to join the conversation.

  • Posts: 80
  • Thank you received: 6
Hy,

I'm experiencing the same thing. As I mentioned in my post about testing SM 1.6.0, I could not get the internal plate solver to work (I attached the logs). I changed to Astrometry and it all worked fine. I've had no problems with the internal solver until KStars 3.5.5.

Ron
Mounts: Sky-Watcher EQ6-R Pro, Meade LX85, Celestron NexStar Evolution Alt/Az
OTAs: Celestron 8" Edge HD w/Celestron Focus Motor, Meade 80mm APO Triplet Refractor w/ZWO EAF
Cameras: ASI533MC Pro, ASI183MC Pro, ASI224MC, ASI120MC-S, ZWO ASI290MM
Raspberry Pi 4 with Stellarmate OS, MacBook Pro
2 months 1 week ago #75908

Please Log in or Create an account to join the conversation.

  • Posts: 617
  • Thank you received: 61
I also had "DISABLED: FOV must be 10 arcmins or wider. 60+arcminutes is recommended." several times after updating to 1.6.0.
Only on one of my two setups, however.
Reboot helped.
I blamed a flaky USB cable connection.
Max S.

RPI 4 B (4Gb) with SMate
Nikon D5500 H-a modified. Nikon D5500 stock
Askar FRA400, TPO RC6
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
2 months 1 week ago #75911

Please Log in or Create an account to join the conversation.

  • Posts: 728
  • Thank you received: 336
Ron, @Euripides: I'm no expert on plate solving, but am willing to work with you to figure this out.

First, the message "DISABLED: FOV must be 10 arcmins or wider. 60+arcminutes is recommended." is worrysome.
I looked at the code, and that's output when, just as it says, it calculates the FOV too small. It calculates the FOV from this formula:

    fov_x = (206264.8 * ccd_width * (ccd_hor_pixel / 1000.0) / focal_length) / 60

where 
- fov_x is in arc-minutes, 
- ccd_width is the # of pixels along the width of your imager, 
- cc_hor_pixel is the width, in microns, of your pixels,
- focal_length in mm.

So, for instance, in my setup with FL=2000, px=3.8, ccd_width=4656 I get fov_x = 30 arc-minutes.

Check the Indi window for your imager to make sure the value is good.
Here's mine, for my ASI1600, correctly set at 3.8 microns and 4656 pixels
 

Next, assuming there's no issue there, we can go into testing the plate solving itself.
Ekos could definitely use an easy way to debug plate solving, offline, during the daytime, etc.
Here's one way to do it, not as easy as it should be, but a start.

- Capture an image (in the capture tab) with the same exposure/gain/etc as you're using with Align. This will be out test file for further investigation.

- Switch to the simulator

- Jasem introduced an interesting feature in the simulator a while back, where it can replay images from a directory, instead of creating images.
You can find that if you run the simulator profile, and start up Ekos. Go to the indi tab labeled 'CCD Simulator' and inside there go to the tab labelled 'Simulator Config'.
At the bottom you will find ''Use Dir". Enable that. Note the directory location on the above line, and put your test fits file in that directory (and temporarily remove any other files 
that might be in that directory--you probably won't have any there). Now, when you run the simulator, it should always "replay" that fits file as the new capture. Remember to uncheck that 'Use dir" button later, or just don't save this configuration.

- For sanity's sake, capture a few images with the simulator. You should always see your test image.

- Go to the align tab, Use 'Capture and Solve' with Action = 'Nothing'. It should try to solve your image, and now you can play with parameters to get it to solve.

Note, you probably will also need to configure the simulator to have the focal length and ccd parameters for your real system where the image was captured. 
Enter the CCD stats on that same 'Simulator Config' page as above, and the Focal Length on the mount tab.
I think you're safe that changing these things on the simulator won't affect you when you go back to your "real profile", but please double check.

If you can't get a fits file to solve, please upload it somewhere and let me (and any others) have a crack at it too.
Of course, if you do that, send the relevant image parameters (focal length, pixel size, num pixels).

Good luck,
Hy
 
Orion Atlas Pro, William Optics ZS105, Moonlight V2 focuser, GSO RC10 w/RSF focuser
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm guidecam.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
The following user(s) said Thank You: Euripides
2 months 1 week ago #75912
Attachments:

Please Log in or Create an account to join the conversation.

The FOV message is quite odd given what FOV on the left appears to be OK. I couldn't reproduce this message thus far using a variety of profile. If you delete and create a new profile, same issue?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 months 1 week ago #75919

Please Log in or Create an account to join the conversation.

  • Posts: 92
  • Thank you received: 2
Thank you Hy,

Done all that, no luck with the internal solver. ASTAP and online solves ok.
2 months 1 week ago #75920

Please Log in or Create an account to join the conversation.

  • Posts: 92
  • Thank you received: 2
Hello Jasem, 

I've just erased completely the profile and create a new one. Same issue with the FOV and now I can see the error message on the bottom.


PS. Those numbers are correct.


 

 
Last edit: 2 months 1 week ago by Euripides.
2 months 1 week ago #75921
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 1.444 seconds