×

INDI Library v1.9.5 Released (08 Mar 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

QHY driver crashes on 3.5.7 beta for Mac

  • Posts: 128
  • Thank you received: 11
Thank you for clarifying the version-issue. Yes, I remember reading in another thread that something had gone wrong with the numbering. So I should assume I have the proper 3.5.6 installed then. Agreed, it seems then an issue with QHY in general, further proven with the same issue on the Ubuntu computer on (the real) 3.5.7beta. That's the nightly build I had to install to test a new mount driver.
@Jasem, would you have an idea what could cause this QHY issue under the latest version(s)?
On Ubuntu I could solve the issue with the following commands (had made a note on this based on a tip from someone else some time ago):
`sudo apt-get remove indi-full indi-qhy libqhy`
`sudo apt-get install indi-full indi-qhy libqhy`
I guess this installs back the QHY libraries from the nightly build to the currently released version of KStars?
@Jasem, does this give a clue on what could go wrong in 3.5.7 beta?
@Rob, are there similar commands on the Mac I could try to fix this? Or should I just altogether delete this version of KStars and do a fresh install of 3.5.5 instead? Is there a link still somewhere to 3.5.5?
The strange thing is that on a Mac running Monterey where both 3.5.5 and 3.5.7beta are installed, the camera can be connected well.
Willem Jan Drijfhout
astroworldcreations.com
5 months 2 weeks ago #78126

Please Log in or Create an account to join the conversation.

  • Posts: 2702
  • Thank you received: 742
it isn’t really that something went wrong with the numbering so much as the timing of the build.  It took me a few days to sort out some build issues I was having.  The 3.5.7 beta was basically identical to the 3.5.6 version when I built it on Mac so it is basically the same as the Linux 3.5.6 one, but 3.5.7 is changing more and more by the day so it is possible that it is different now on Linux.

The drivers are inside the app bundle on Mac.  And you can have different versions of KStars on the same Mac if you like.  The 3.5.5 version is still available as well.  You can’t run a command to build new INDI drivers on your Mac because you would need the whole development environment to be set up first and that’s complex.  I can build a new dmg if there was a significant fix.  If there was an issue with qhy And it has since been fixed, I can rebuild it.
5 months 2 weeks ago #78129

Please Log in or Create an account to join the conversation.

  • Posts: 128
  • Thank you received: 11
Thanks for clarifying, Rob. You say 3.5.5 is still available. Could you share a link where I could find that version? Most places link to edu.kde.org/kstars/, where I can only see the 3.5.6/7beta. Would like to try and see if I can get the camera to work on this Mac on 3.5.5
Willem Jan Drijfhout
astroworldcreations.com
5 months 2 weeks ago #78135

Please Log in or Create an account to join the conversation.

  • Posts: 2702
  • Thank you received: 742
Good question.  I am not sure if Jasem put links to them anywhere.  But it is still on the server in the same spot it has been.  I think if you just try the current link location and edit it, that should work
5 months 2 weeks ago #78145

Please Log in or Create an account to join the conversation.

  • Posts: 128
  • Thank you received: 11
Found it!. Thank you. Installed 3.5.5, but it would not start. Deleted the data files from Application Support/Kstars. Then it did work, so I have now a working 3.5.5 next to 3.5.7beta. However... the indi_qhy_ccd driver still crashes. So it looks like somewhere along the line I'm doing something wrong. But where....? Would love to hear any ideas from anyone.
Willem Jan Drijfhout
astroworldcreations.com
5 months 2 weeks ago #78147

Please Log in or Create an account to join the conversation.

  • Posts: 2702
  • Thank you received: 742
Oh right, I bet that all those changes there were made recently to the DSO libraries made the current data directory not compatible with an older version.  Or maybe some other change.  But yes you did the right thing.  You can of course backup the old data directory if there is something important there before deleting it.  Yeah if that wasn't the issue then I am not sure why your QHY is crashing.  Maybe try asking Jasem, he builds libqhy.
5 months 2 weeks ago #78149

Please Log in or Create an account to join the conversation.

  • Posts: 2702
  • Thank you received: 742
Jasem said that the camera works on his system with no issues with the latest version.  I just tried it on mine, but of course I have no QHY camera so I won't know much.

So a couple of ways you can get information about the issue would be to either:

1. In the Ekos Logging options click "verbose", then select INDI and the CCD options and see what prints out when you try to connect the camera
2. Use the "Device Manager in the KStars Menu to Select the QHY driver and then try to connect the camera.

Either one of those methods might get some relevant information about why it crashes on your system (either Linux or Mac or Both).

If this doesn't give enough good information I have another idea of a way you could test it.
5 months 2 weeks ago #78172

Please Log in or Create an account to join the conversation.

  • Posts: 128
  • Thank you received: 11
Thanks Rob. Got a little bit further. The Verbose logging in Ekos did not say anything other than that the driver crashed. But the Device Manager gave some clues. It said that libusb-1.0.0.dylib was not loaded, because libqhyccd.21.dylib requires version 4.0.0 and the version installed is libusb-1.0.0.dylib. See attached the log-file.

Based on that, I tried the following:
Updating libusb-1.0.0 with 'brew install libusb': no success (probably because the in-app embedded version is used anyway?)
Copied a libusb-1.0.0 from another Mac that has a working version: no success
Fresh install from KStars 3.5.5.img (again): no success

Would this give you any clues of what is wrong, and how to solve it?

Many thanks, Willem Jan.
 



 

File Attachment:

File Name: QHY_Devicemanager.rtf
File Size:4 KB
Willem Jan Drijfhout
astroworldcreations.com
5 months 2 weeks ago #78181
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 2702
  • Thank you received: 742
Is this on the 3.5.5 version or the most recent version? 

Yes this is very useful information and tells me precisely why it crashed.  Yes it will be looking inside the app for the file not in homebrew since it is a fully packaged up app.   If it is the most recent version then I can certainly look into what happened and fix it.  If it is 3.5.5, then Please try the newer version and see if it also has the same linking issue.
5 months 2 weeks ago #78182

Please Log in or Create an account to join the conversation.

  • Posts: 128
  • Thank you received: 11
Progress made! Since it seemed like it was a version-issue, I have tried to install other older versions. Your information that older version were still available by simple changing the url was very helpful with this. These were the results:
3.5.1: QHY worked
3.5.4: QHY worked
3.5.5: QHY crashed
3.5.7b: QHY crashed

Both cases that had the crashes were showing the identical messages of a version issue with libusb-1.0.0.dylib in the device manager.
So the good news, we're closing in on the issue and I now have a fully working KStars, albeit it being 3.5.4.
Would this give you some clues of what could go wrong with 3.5.5/3.5.7b, either in general, or the DMG image? And most importantly: how to correct it?
Willem Jan Drijfhout
astroworldcreations.com
5 months 2 weeks ago #78183

Please Log in or Create an account to join the conversation.

  • Posts: 2702
  • Thank you received: 742
So I think what likely happened is that I had more than one version of the Libusb dylib on my Mac when I was building the last DMG and maybe QHY linked to a different one than the one that got packaged up.  I will see what I can do about it.
5 months 2 weeks ago #78191

Please Log in or Create an account to join the conversation.

  • Posts: 2702
  • Thank you received: 742
Yep, I just confirmed it, the libqhyccd dylib is linked to my home-brew libusb which apparently is a different version number than the one in craft.  One easy way to fix that is to delete libusb from home-brew and rebuild the dmg.  Then all it would see is the one in craft.
5 months 2 weeks ago #78199

Please Log in or Create an account to join the conversation.

Time to create page: 0.507 seconds