×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Suspend guiding while focus not working

  • Posts: 86
  • Thank you received: 9
So yesterday, I test older versions of KStars. 3.5.6 didn't suspend guiding but when I tried 3.5.5. It worked. Hopefully this helps someone out there.
The following user(s) said Thank You: Eivind
10 months 1 week ago #80167

Please Log in or Create an account to join the conversation.

  • Posts: 1014
  • Thank you received: 302
With the latest versions guiding will only be suspended for OAG guiding, i.e. if the main scope is also used as guiding scope.
TSA-120 + FSQ-85 + ONTC 10"F4 Newton (+ epsilon-160 on Japan trip) | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
10 months 2 days ago #80334

Please Log in or Create an account to join the conversation.

  • Posts: 86
  • Thank you received: 9
Thanks. I do have the Main Scope the same as the Guide Scope because I'm using OAG. I tried deleting all of the KStars data files I could find and re-installing. It brought back suspended guiding but after using it for a night, it's back to not suspending again.
10 months 1 day ago #80343

Please Log in or Create an account to join the conversation.

In Guide module, the selected scope is the primary scope?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
10 months 1 day ago #80345

Please Log in or Create an account to join the conversation.

  • Posts: 86
  • Thank you received: 9
Yes, I just tested it and it suspends when Guide Scope is selected in the Guide Module and doesn't suspend when Primary Scope is selected. I'm thinking they got swapped somehow.
10 months 1 day ago #80346

Please Log in or Create an account to join the conversation.

  • Posts: 161
  • Thank you received: 25
I had the same issue tonight with PHD2 guiding not being suspended during focus. At the end of my session, I checked that the profile is correct, and it is:
 
I started Ekos back up, and the Scope dropdown says Guide Scope, but it is greyed out and cannot be changed. This is not while not guiding is active, it is immediately upon starting Ekos.
 
10 months 1 day ago #80359
Attachments:

Please Log in or Create an account to join the conversation.

Oh I see how this can be an issue.. it uses the last setting. Start Simulators profile and change that to primary scope and then start your profile, does this work?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
10 months 1 day ago #80365

Please Log in or Create an account to join the conversation.

  • Posts: 86
  • Thank you received: 9
Yes, that worked. Found it out by switching to internal guider changing the guide scope and then going back to phd. This time for some reason the suspend guide command worked with primary scope selected. Weird because when I tested with simulators it worked with guide scope selected. Either way, we now know where to look for this issue. Thank you.
Last edit: 10 months 19 hours ago by Wes Creech.
10 months 19 hours ago #80377

Please Log in or Create an account to join the conversation.

  • Posts: 161
  • Thank you received: 25
Yes, that fixed it for me, also. I was able to change to Primary scope, and now PHD2 guiding pauses during focus. Thank you, Jasem.
The following user(s) said Thank You: Jasem Mutlaq
10 months 7 hours ago #80391

Please Log in or Create an account to join the conversation.

  • Posts: 94
  • Thank you received: 3
I ran into the same problem with the latest stable build (3.6.0 Stable) The guide scope appeared as primary scope but it does not suspend phd2 guiding.
2 months 3 weeks ago #86387

Please Log in or Create an account to join the conversation.

  • Posts: 25
  • Thank you received: 7
While we are on the topic of suspended guiding, is there a simple way to delay the first image of a sequence after autofocus to allow the guider to stabilize - say 10 or 15 seconds? My first image is not usable after autofocus with suspended autoguiding.
Takahashi FSQ 106EDX4
Sesto Sento 2 focuser
Paramount ME via TSX on RPi4
ZWO ASI6200 MM Pro
Chroma 3nm NB filters
Chroma LRGB filters
ZWO EFW filter wheel
Raspberry Pi 4 StellarMate OS at telescope
KStars/Ekos on linux desktop
2 months 3 weeks ago #86395

Please Log in or Create an account to join the conversation.

  • Posts: 94
  • Thank you received: 3
I believe you can set the guiding deviation under a threshold which the sequence starts (i.e: if the guiding RMS above 1 arcsec then the sequence won't start). See it in the capture tab.
2 months 3 weeks ago #86397

Please Log in or Create an account to join the conversation.

Time to create page: 1.256 seconds