×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Mac KStars 3.5.7 beta new build -- please test

  • Posts: 2706
  • Thank you received: 742
Hey fellow KStars Mac Users, I have been working hard over the last couple of weeks to rewrite my build scripts and update the craft recipes with the ultimate goal of getting things working on KDE Binary Factory so we can get daily builds of KStars and INDI for MacOS like exist for Windows and Linux.  I am getting pretty close, but note that a bunch of changes had to be made to make this possible.  Please check this DMG thoroughly to make sure there were not any issues with all the changes.  The most important things to check are the following:

1. INDI drivers.  I had to move the directory for INDI in the bundle from /Contents/MacOS/indi/ to /Contents/MacOs/.  As far as I can tell, that seems to be working just fine, but please let me know if a driver cannot be found or if the driver can't find its firmware or CCD Simulator cannot find GSC or something like that.  So far it seems good, but please check just in case.  Also I was having an issue with the ZWO and GPhoto drivers due to changes in the recipes.  I think they are fixed and working now, but please test them.  Please test with any equipment you might have.  Thanks!

2.  DBus Scripting.   Several years ago I had written a bunch of code to get DBus working for KStars on MacOS and I needed custom build recipes and files.  When I did this overhaul, it looks like the higher-ups integrated some of my changes and made some improvements of their own so that it seems to be working without my custom build now.  Please test to make sure the Scheduler Works and Scripting works since those rely heavily on DBus.  If it doesn't work, I can always go back to the other way I used to do it.

3.  XPlanet.  I had to change the directory for XPlanet from /Contents/MacOS/indi/xplanet to /Contents/MacOS/ and I moved the data for xplanet into the Resources folder and then wrote some code to copy it into the data directory so that it gets preserved when a person upgrades kstars.  Please test this since it really was a bunch of changes.  Note that I still don't have maps in there for all the planets and I plan to fix that before the release, but make sure it is working properly.

4.  Anything you know to be newly added to KStars or INDI.  I have been really busy recently (particularly with getting KStars to work on Binary Factory) and I haven't kept up with all the changes in KStars and INDI, but I know there were some, please make sure anything new works well.

Please report below with any Mac Specific issues so that we can fix them before the 3.5.7 release.

Here is the DMG: www.indilib.org/jdownloads/kstars/beta/kstars-3.5.7-beta.dmg

Thanks,

Rob
The following user(s) said Thank You: Jasem Mutlaq, Rick Bassham, Gonzothegreat, Jean-Claude JESIOR
4 months 1 week ago #79341

Please Log in or Create an account to join the conversation.

  • Posts: 2706
  • Thank you received: 742
Anyone get a chance to test it yet?
4 months 1 week ago #79385

Please Log in or Create an account to join the conversation.

  • Posts: 74
  • Thank you received: 10
Hi Rob,

Using it on flats. Connected fine to my equipment. 1 issue... in Capture the gain/offset is not getting populated in the table.

Will try out some more stuff later.

Regards,
John.Hi Rob,

Using it on flats. Connected fine to my equipment. 1 issue... in Capture the gain/offset is not getting populated in the table.
Hi Rob,

Using it on flats. Connected fine to my equipment. 1 issue... in Capture the gain/offset is not getting populated in the table.

Will try out some more stuff later.

Regards,
John.Hi Rob,

Using it on flats. Connected fine to my equipment. 1 issue... in Capture the gain/offset is not getting populated in the table.

Will try out some more stuff later.



Regards,
John.
4 months 1 week ago #79390
Attachments:

Please Log in or Create an account to join the conversation.

Thank you for the report, it's fixed now in GIT (and should be available when we release the stable version). Any other issues?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
4 months 1 week ago #79391

Please Log in or Create an account to join the conversation.

  • Posts: 74
  • Thank you received: 10
Hi, just finished playing around (in daylight). All looks good. Will use it for my next imaging session (forecast for Sunday night is clear but obviously that may change).
4 months 1 week ago #79395

Please Log in or Create an account to join the conversation.

  • Posts: 178
  • Thank you received: 28
Testing KStars 3.5.7 on MacBook Pro Mojave.
All INDI drivers crash (scope, dome, focuser, ASI cameras )
If I use a profile containing only the ASI cameras : crash again
 

This browser does not support PDFs. Please download the PDF to view it: Download PDF


 

This browser does not support PDFs. Please download the PDF to view it: Download PDF

4 months 1 week ago #79424
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 178
  • Thank you received: 28
I forgot to say that the "INDI Driver Reducer" is referring to my custom scope driver . In fact the driver is Celestron NexStar
4 months 1 week ago #79425

Please Log in or Create an account to join the conversation.

Thank you for the report, I tested with Altair + ASI and cannot reproduce a crash on connection. However, KStars shuts down on disconnection.

 
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
4 months 1 week ago #79427
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 178
  • Thank you received: 28
Hi Rob & Jasem,
KStars 357 seems to have produced a mess on my computer : I cannot run KStars 356 or 355 anymore. The app keeps bouncing on the dock.
A re-install of KStars 356 doesn't help
Any suggestions ?
4 months 1 week ago #79428

Please Log in or Create an account to join the conversation.

  • Posts: 2706
  • Thank you received: 742
Jean, Claude,

So there are a couple of things you can do.  First, if you want to see why it is bouncing like that, please open a terminal window, copy and paste this code and see what it prints in the terminal window:

/Applications/KStars.app/Contents/MacOS/kstars

(if you put Kstars.app someplace else or renamed it, you will have to change this path.)

Second, if there is a problem opening kstars, I would bet there is an issue with either your data directory or preferences file.  Please try renaming the data directory and preferences files and then try to start whichever kstars you want.

~/Library/Application Support/kstars~/Library/Preferences/kstarsrc

I recommend renaming the file and folder to kstars_backup and kstarsrc_backup just in case you have some settings or files in there you don't want to lose.

See if these suggestions help please,

Thanks for helping,

Rob
4 months 1 week ago #79433

Please Log in or Create an account to join the conversation.

  • Posts: 2706
  • Thank you received: 742
Also Jean Clause, for your post before saying there was a crash when the indi drivers started up, was this just a crash of indi drivers like the little dialog shown in your image or was this a crash of kstars when starting the indi drivers?  Because those would be two very different issues.

Did it just crash when using ASI drivers, or did it also crash when you tried simulators?

Thanks for your help,

Rob
4 months 1 week ago #79434

Please Log in or Create an account to join the conversation.

  • Posts: 178
  • Thank you received: 28
Rob, it was "like the little dialog shown". KStars didn't crash but the little dialog shows again and again
The simulators also showed the same dialog
Thanks for your help with the Terminal but ... I restored already my disk from a backup
4 months 1 week ago #79437

Please Log in or Create an account to join the conversation.

Time to create page: 0.827 seconds