×

INDI Library v2.0.7 is Released (01 Apr 2024)

Bi-monthly release with minor bug fixes and improvements

Object name is Unknown in FITS header

  • Posts: 437
  • Thank you received: 31
When I slew to a named object for imaging the object name gets included in the FITS header.
I was not happy with the framing so I decided to reposition it slightly.
I found that the image name was recorded as UNKNOWN.
The same thing happened the next night when I loaded and slewed, to get the same framing.
Does anyone have a suggestion on how to get the correct name in the FITS header when capturing the images?

Paul
2 years 2 months ago #80809

Please Log in or Create an account to join the conversation.

This makes sense, it's moved from the central object position it turns to unknown by KStars. Perhaps you can set it manually.
2 years 2 months ago #80811

Please Log in or Create an account to join the conversation.

  • Posts: 437
  • Thank you received: 31
Jasem,

I agree it makes sense, but how do you set it manually?

Paul
2 years 2 months ago #80835

Please Log in or Create an account to join the conversation.

In Ekos, above sequence queue there is an icon you click to set such values. Or Directly in INDI Control Panel --> Options
2 years 2 months ago #80843

Please Log in or Create an account to join the conversation.

  • Posts: 437
  • Thank you received: 31
Jasem Mutlaq post=80843 userid=1In Ekos, above sequence queue there is an icon you click to set such values. Or Directly in INDI Control Panel --> Options

Jasem,

I am unable to find the icon you mentioned in click above the sequence queue. The nearest thing I can see is where you set the observer.

Setting from the INDI Control Panel seems impractical as I would not be able to set it for multiple objects.

Paul
2 years 1 month ago #80910

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 4
I have a similar problem. The object is selected in KStars, the Target field is filled automaticaly with the name of the selected object, but in FITS-file the OBJECT header is Unknown. This behavior begun after compiling and installing newer version of KStars (3.5.8 Stable)
1 year 11 months ago #82951

Please Log in or Create an account to join the conversation.

  • Posts: 357
  • Thank you received: 113
Use scheduler tab where you fill "Target" field that is then put into OBJECT FITS header.
1 year 11 months ago #82956

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 4
Before update it worked on CCD-tab. Using sequence on this tab is more comfortable for me.
1 year 11 months ago #82957

Please Log in or Create an account to join the conversation.

I just pushed a fix for this, should be in v3.5.9
The following user(s) said Thank You: Vladimir
1 year 11 months ago #82966

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 4
Thank You very much!
1 year 11 months ago #82968

Please Log in or Create an account to join the conversation.

  • Posts: 437
  • Thank you received: 31
Now that this has been addressed can someone suggest a Mac or Unix program that can bulk edit the existing FITS header to add an object name.

Paul
1 year 11 months ago #82985

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 4

I use ASTAP
The following user(s) said Thank You: Paul
1 year 11 months ago #82987

Please Log in or Create an account to join the conversation.

Time to create page: 1.470 seconds