×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

"Mount aborted" when trying to run Polar Alignment Assistant

  • Posts: 316
  • Thank you received: 78
Running latest KStars built from source, as of a couple days ago.

When I run the PAA, it takes a picture and solves, and tries to move the mount. About 1 second later I get an error that says "Mount aborted. Please restart the process and reduce the speed." I did what it said and reduced the speed, but no difference.

Looking in the log, it starts out saying "First mount rotation remaining degrees: 30". Then about 1 second later it says "First mount rotation remaining degrees: 150.582". I'm guessing that's the cause of the problem.

Log attached.

I am going to try doing a "git bisect" to find out when this stopped working.

-- Kevin

 
3 months 2 weeks ago #81235
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
Hi,
I had the same issue before with the new build. I think it has something to do with the MF being check. Once I uncheck it, PAA was working again.
Last edit: 3 months 2 weeks ago by Oliver Montoya.
3 months 2 weeks ago #81236

Please Log in or Create an account to join the conversation.

There is a mismatch.
[2022-03-08T20:27:42.104 EST DEBG ][           org.kde.kstars.indi] - EQMod Mount : "[DEBUG] Scope RA (12:51:49) DE (90:00:00) Aligned RA (12:51:49) DE (90:00:00) AZ (360:00:00) ALT (44:45:00), PierSide (West) "
[2022-03-08T20:27:42.177 EST INFO ][     org.kde.kstars.ekos.align] - "+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++"
[2022-03-08T20:27:42.184 EST INFO ][     org.kde.kstars.ekos.align] - "Solve Log Odds:  149.218"
[2022-03-08T20:27:42.186 EST INFO ][     org.kde.kstars.ekos.align] - "Number of Matches:  33"
[2022-03-08T20:27:42.187 EST INFO ][     org.kde.kstars.ekos.align] - "Solved with index:  4208"
[2022-03-08T20:27:42.188 EST INFO ][     org.kde.kstars.ekos.align] - "Field center: (RA,Dec) = (34.8366, 89.7196) deg."
[2022-03-08T20:27:42.190 EST INFO ][     org.kde.kstars.ekos.align] - "Field center: (RA H:M:S, Dec D:M:S) = (02:19:20.791, +89:43:10.468)."
[2022-03-08T20:27:42.191 EST INFO ][     org.kde.kstars.ekos.align] - "Field is: (-78692.3, 1009.53) deg from search coords."
[2022-03-08T20:27:42.193 EST INFO ][     org.kde.kstars.ekos.align] - "Field size: 76.1955 x 57.6617 arcminutes"
[2022-03-08T20:27:42.194 EST INFO ][     org.kde.kstars.ekos.align] - "Pixel Scale: 1.96483\""
[2022-03-08T20:27:42.196 EST INFO ][     org.kde.kstars.ekos.align] - "Field rotation angle: up is -62.8797 degrees E of N"
[2022-03-08T20:27:42.197 EST INFO ][     org.kde.kstars.ekos.align] - "Field parity: negative\n"
[2022-03-08T20:27:42.199 EST INFO ][     org.kde.kstars.ekos.align] - "Solver completed after 0.38 seconds."
[2022-03-08T20:27:42.200 EST INFO ][     org.kde.kstars.ekos.align] - "Solver RA (34.83663) DEC (89.71957) Orientation (-62.87965) Pixel Scale (1.96483) Parity (neg)"
[2022-03-08T20:27:42.201 EST INFO ][     org.kde.kstars.ekos.align] - "Effective telescope focal length is updated to 797.835 mm."
[2022-03-08T20:27:42.223 EST INFO ][     org.kde.kstars.ekos.align] - "Solution coordinates: RA (03h 41m 54s) DEC ( 89° 48' 46\") Telescope Coordinates: RA (00h 51m 55s) DEC ( 90° 00' 00\")"
[2022-03-08T20:27:42.235 EST INFO ][     org.kde.kstars.ekos.align] - "Please wait while WCS data is processed..."
[2022-03-08T20:27:42.265 EST INFO ][     org.kde.kstars.ekos.align] - "WCS data processing is complete."
[2022-03-08T20:27:42.267 EST DEBG ][     org.kde.kstars.ekos.align] - "PAA: addPoint ra0 34.8366 dec0 89.7196 ra 55.4749 dec 89.8127 az 359.805 alt 44.8764"
[2022-03-08T20:27:42.290 EST INFO ][     org.kde.kstars.ekos.align] - "Please wait until mount completes rotating to RA (22h 51m 56s) DE ( 90° 00' 00\")"

EQMod reports RA 12 but Ekos reports it as 0?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
3 months 2 weeks ago #81238

Please Log in or Create an account to join the conversation.

  • Posts: 316
  • Thank you received: 78
Okay, I believe I found the offending commit in INDI (not KStars). Reverting this change fixes the problem for me.

kevin@rockpi-4b:~/indi/build$ git show 0afce1ce518aebc9233442344be4d01cedaac9a4
commit 0afce1ce518aebc9233442344be4d01cedaac9a4 (HEAD, refs/bisect/bad)
Author: Jasem Mutlaq <mutlaqja@ikarustech.com>
Date:   Sat Feb 19 13:21:48 2022 +0300
 
    Introduce 100 milli-arc-seconds threshold for sending updated coordinates to clients. This is safer than double comparisions
 
diff --git a/libs/indibase/inditelescope.cpp b/libs/indibase/inditelescope.cpp
index 9d69a823f..cf0dfa636 100644
--- a/libs/indibase/inditelescope.cpp
+++ b/libs/indibase/inditelescope.cpp
@@ -708,7 +708,9 @@ void Telescope::NewRaDec(double ra, double dec)
         IDSetSwitch(&TrackStateSP, nullptr);
     }
 
-    if (EqN[AXIS_RA].value != ra || EqN[AXIS_DE].value != dec || EqNP.s != lastEqState)
+    if (std::abs(EqN[AXIS_RA].value - ra) > EQ_NOTIFY_THRESHOLD ||
+            std::abs(EqN[AXIS_DE].value - dec) > EQ_NOTIFY_THRESHOLD ||
+            EqNP.s != lastEqState)
     {
         EqN[AXIS_RA].value = ra;
         EqN[AXIS_DE].value = dec;
diff --git a/libs/indibase/inditelescope.h b/libs/indibase/inditelescope.h
index 8931bf914..d59c8ec2a 100644
--- a/libs/indibase/inditelescope.h
+++ b/libs/indibase/inditelescope.h
@@ -931,6 +931,9 @@ class Telescope : public DefaultDevice
         float motionDirWEValue {0};
 
         bool m_simulatePierSide;    // use setSimulatePierSide and getSimulatePierSide for public access
+
+        // 100 millisecond of arc or time.
+        static constexpr double EQ_NOTIFY_THRESHOLD {1.0/(60*60*10)};
 };
 
 }
 
3 months 2 weeks ago #81239

Please Log in or Create an account to join the conversation.

  • Posts: 1
  • Thank you received: 0
I believe I have the very same problem with my Sky-Watcher AZ-GTi mount and the polar alignment routine. Is there any possibility to fix this myself?

@JASEM MUTLAQ Is there any possibility to downgrade to the 1.9.4 release on Stellar Mate? It was working for me in the older version.
3 months 2 weeks ago #81317

Please Log in or Create an account to join the conversation.

Kevin, are you running latest KStars 3.5.8 beta? because it was resolved there. The INDI driver behavior is correct. At any rate, I will try to test as soon as I can get a clear night.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
3 months 2 weeks ago #81318

Please Log in or Create an account to join the conversation.

I found the issue, it's in KStars due to processing of HORIZONTAL_COORD while results in odd results near the poles. Push fixed, can you please test with latest KStars?

I shared a document with you regarding INDI mount state machine as well. One pending issue is that currently Ekos capture&solve only work internally, but if you use an external program to issue a GOTO (i.e. SkySafari), it wouldn't capture and solve to this coordinate and would instead capture and solve to the last target set in Ekos.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
3 months 2 weeks ago #81321

Please Log in or Create an account to join the conversation.

  • Posts: 316
  • Thank you received: 78
I will try out the latest KStars when the weather clears, nothing but clouds for weeks on end at this time of the year. Don't know when the next clear night will be.
3 months 2 weeks ago #81348

Please Log in or Create an account to join the conversation.

  • Posts: 316
  • Thank you received: 78
Finally a clear night. Tested out the latest, PAA now works properly.

Thanks Jasem!

-- Kevin
3 months 1 week ago #81470

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 1
Hi,

I did the update on beta channel last Wednesday and still got the message:
"Mount aborted. Please restart the process and reduce the speed."

Best Regards
Sven
HEQ5
TS-Optics 480/80 + 0.79 Reducer
Sony SLT58
50 mm Guidesope
QHY 5L II mono
R-Pi 4B 4 GB
Stellarmate
2 months 4 weeks ago #81788

Please Log in or Create an account to join the conversation.

Time to create page: 0.836 seconds