×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Bug? Crash when starting scheduler with a profile set

  • Posts: 14
  • Thank you received: 1
According to the user guide:
Profile: Select which equipment profile to utilize when starting Ekos. If Ekos & INDI are already started and online, this selection is ignored.

Tonight I had 2 crashes in a row starting a Scheduler job that had the profile set to my usual profile by name instead of Default. Ekos was already connected and I saw the log window reporting an attempt to connect devices for the profile nevertheless. After that, KStars crashed. This happened twice.

Only setting the profile in the job to Default I could start. Looks like the selection might not be ignored when ekos is already connected?
3 months 2 weeks ago #85594

Please Log in or Create an account to join the conversation.

  • Posts: 1014
  • Thank you received: 302
I tried to reproduce it with simulators, but at least with those it works fine. Could you please post your scheduler and sequence file and ideally also the log files?
TSA-120 + FSQ-85 + ONTC 10"F4 Newton (+ epsilon-160 on Japan trip) | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
3 months 1 week ago #85711

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 1
Sorry for the delay. The issue appears intermittent, as previous sessions had the profile explicitly selected and did not crash. Here are the scheduler and sequence files. I did not have file logging enabled unfortunately.

File Attachment:

File Name: schedfiles.zip
File Size:1 KB
3 months 4 days ago #86052
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.391 seconds