×

INDI Library v2.0.7 is Released (01 Apr 2024)

Bi-monthly release with minor bug fixes and improvements

i'm not anymore able to take flats files

I can confirm this issue. Discussing it with Wolfgang now.
The following user(s) said Thank You: Frederick Ruegsegger
10 months 3 weeks ago #93735

Please Log in or Create an account to join the conversation.

  • Posts: 619
  • Thank you received: 282
Hi Fred,

Thanks for the reply. I've had a look at the log you posted. It looks to me that the problem you have may be different from the AP's problem (not sure though). In AP's case, the log messages are different and Capture gets stuck on the flats in the "Preparation..." stage. This may be the same for you, I'm not sure, although in the screenshot you posted, Capture has "aborted" although you may have manually "aborted" the capture after waiting a while?

Looking at the log there are a lot of messages back and forth to the NiteCrawler until the log stops. This appears to be different to AP's issue (although it may just be different logging levels, of course).

If you are able to run again I'd suggest checking that you are able to move the focuser in the Focus module and take a flat preview before scheduling a flat sequence. Also, check that you have "sensible" values in the Filter Settings popup for "Last AF Solution" for the filters you are taking flats for. For logging make sure the following are all checked: verbose Indi, Capture, Focus, CCD Driver, Focuser Driver.

Be worth confirming that you only get the issue when "take flats at same position as lights" is enabled and that all works fine when this option is unchecked.

Happy to take a look at other log files to get to the bottom of this issue(s).

Thanks.
10 months 3 weeks ago #93739

Please Log in or Create an account to join the conversation.

  • Posts: 22
  • Thank you received: 0
Hi
i tried using a new profile without filter and without focuser
I still had the same problem when " capture flats at the same focus as lights" is checked
and no problem when is unchecked
10 months 3 weeks ago #93741
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 619
  • Thank you received: 282
Thanks so I can reproduce the problem is you take filter wheel and focuser out of the optical train but leave "capture flats at the same focus as lights" checked. Its getting confused trying to get the last autofocus solution to move the focuser to.

When the full optical train with filter wheel and focuser are connected it works fine for me. Is this what you have?
10 months 3 weeks ago #93745

Please Log in or Create an account to join the conversation.

  • Posts: 211
  • Thank you received: 30
John,

Thanks for your reply. Re the screenshot, I had aborted that sequence in order to capture the shot. In all the other cases where I didn't abort the process of taking flats, KStars would report that it was 'preparing' and eventually I got the spinning beach ball of death (on a Mac). I couldn't quit the application because it was completely unresponsive so I had to force quit.

This morning I was able to capture flats only after turning off 'Capture flats at the same focus as lights' feature.
10 months 3 weeks ago #93754

Please Log in or Create an account to join the conversation.

  • Posts: 619
  • Thank you received: 282
Hi Fred,

Thanks for the confirmation. I can reproduce this on my Mac by running an Optical Train in Capture without a Filter Wheel or by creating a profile without a Filter Wheel.. Basically the code gets into a fairly tight loop which you may be able to abort or it may go to the spinning beachball.

So does this match your configuration? I see you have a ZWO EAF. Are you not connecting it when you tried to take flats? And if you connect everything as you would for an imaging session, do flats work as you'd expect?

Thanks again!
10 months 3 weeks ago #93759

Please Log in or Create an account to join the conversation.

  • Posts: 211
  • Thank you received: 30
Hi John,

First, just to make sure there's no misunderstanding, I do have a ZWO filter wheel but not an EAF. For focusing I have a Moonlite LiteCrawler.

I have always taken my flats with the exact same configuration as my imaging sessions. So, the issue I'm having is with the same connections as I have for an imaging session.

Thanks for looking into this!
10 months 3 weeks ago #93771

Please Log in or Create an account to join the conversation.

  • Posts: 619
  • Thank you received: 282
Thanks for the clarification Fred. I can't reproduce the problem exactly as you have it using the Simulators. When I have everything connected as it should be and "Capture flats at same focus as lights" checked it works fine.

However, I can reproduce the issue slightly differently and have make a fix for this. In addition, Wolfgang has put a more general fix in to make things more robust. These changes have just been merged.

These changes will fix "a" problem but I can't say whether they will fix "your" problem. I think you'll just have to try and see. If you still get the problem we'll take another look.

If you build from source the changes are in this MR: invent.kde.org/education/kstars/-/merge_...99f7441279f56451c47f
So you can either pull this MR on top of 3.6.5 or just pull the latest master.

If you take nightlies then the change will be incorporated in the next cycle.

If you just take the official releases then these changes will be in 3.6.6 when its released.
The following user(s) said Thank You: Frederick Ruegsegger
10 months 3 weeks ago #93773

Please Log in or Create an account to join the conversation.

  • Posts: 211
  • Thank you received: 30
Hi John,

I wanted to update you. I had a chance to download the latest nightly build (1940 dated July 2) before running my flats this morning. This version exhibits the same properties as before. I change nothing about my image train and set up except that I adjust the camera settings to take flats. If the 'Capture flats as the same focus as lights' box is checked KStars just shows processing and nothing happens. The app eventually becomes unresponsive. If I uncheck the box, everything works.

I have attached the log file that shows both the run that failed and the one that succeeded.

Thanks!

File Attachment:

File Name: log_08-24-30.txt
File Size:1,603 KB
10 months 3 weeks ago #93806
Attachments:

Please Log in or Create an account to join the conversation.

I also just had an issue and pushed a fix to GIT. If you can recompile, please do it and let me know how it goes. If not, wait for next nightly.
The following user(s) said Thank You: Frederick Ruegsegger
10 months 3 weeks ago #93807

Please Log in or Create an account to join the conversation.

  • Posts: 619
  • Thank you received: 282
Hi Fred,

Thanks very much for the update. Hopefully, Jasem's fix will solve the issue you're having.

I had a look at the latest log you posted, but unfortunately it doesn't give a clue as to why the system got stuck. It shows 25x1s Flats on Blue being setup and then aborted (presumably by you after it got stuck). Then it shows 25x1s Lights on Blue being setup and running successfully.

Hopefully, Jasem's change will fix your issue. As Jasem commented, let us know how it goes.

If it doesn't fix the issue we can add some more logging to pinpoint the issue. With these type of issues, once they are reproducible in a test environment, fixing them becomes relatively easy.
10 months 3 weeks ago #93819

Please Log in or Create an account to join the conversation.

  • Posts: 211
  • Thank you received: 30
John and Jasem,

Success! I downloaded the latest nightly build (1941, July 3) and flats now run with the checkbox checked - everything as I would expect. Thank you!

I have a trivia question - I set my sessions to refocus every hour. Because of temperature changes overnight the focus can change by a fair amount. How does the process of taking flats work in this case? From what I could see this morning, the focuser stayed in its last position from the night before.

Thanks again!
10 months 3 weeks ago #93826

Please Log in or Create an account to join the conversation.

Time to create page: 0.400 seconds