×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

EKOS / Rasberry Pi2 and V4l2 CCD

  • Posts: 8
  • Thank you received: 1
After much head scratching, it's time to der to the experts :)

I have a HEQ5 Pro mount, connected via EQMod and Rasberry Pi which I control remotely via Kstars / Ekos.
I also have 2 x CCD's, one is dedicated to Autoguiding, the other for astrophotography.

The issue, when I run:
indiserver -vv -m 100 indi_eqmod_telescope indi_v4l2_ccd V4l2 only grabs the first video port (/dev/video0) and ignores the second CCD.

When I try locally, EKOS detects both V4l2 cameras and Ekos shows both the Photo and Guiding windows.

How can I get the V4L2 driver to detect both /dev/video0 as well as /dev/video1?
5 years 7 months ago #12009

Please Log in or Create an account to join the conversation.

  • Posts: 226
  • Thank you received: 88
Hi,
Actually the V4L2 driver can only manage one device. So you have to start two instances of the indi_v4l2_ccd executables and use a different name for each one.
As I don't think it is possible to fix names of devices in the command line, you may use the FIFO capability of the indiserver:
mkfifo /tmp/indififo
indiserver -v -f /tmp/indififo
echo start indi_v4l2_ccd -n \"CCD1\"  > /tmp/indififo
echo start indi_v4l2_ccd -n \"CCD2\"  > /tmp/indififo
Beware of the \", the backslash should be there for it to work. In kstars you should see two tabs CCD1 and CCD2, and you can now assign CCD2 to /dev/video1 in the port settings option. I didn't try as I don't have two cams here, but think that should work.
The following user(s) said Thank You: Jasem Mutlaq
5 years 7 months ago #12121

Please Log in or Create an account to join the conversation.

Time to create page: 0.453 seconds