×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

EQMod in EKOS INDI Profile?

  • Posts: 45
  • Thank you received: 6
Maybe this has popped up before, but I can't find anything with a search...
When I create an INDI profile in the EKOS control window, and want to select a mount, EQMod is not in the list. So all I put in the profile is (e.g.) a local guider CCD.

EKOS runs on a Pi3, and connects to chained indi servers on localhost and on a second Pi2. The EQMod mount is on the (remote) Pi2, a joystick on the (local) Pi3. A GPhoto CCD is also on the Pi2, but no camera connected.

Everything starts up nicely, but when I slew to a target after unparking, the connection to the localhost indiserver is lost. What I see in KStars is an erratic behaviour of the Mount pointer, until the moment of connection loss.

What can be the case, could it have to do with the unability to select the right mount in the INDI Profile?

Thanks,
Arjan
5 years 4 months ago #14308

Please Log in or Create an account to join the conversation.

You can do two things:

1. Install indi-eqmod on the Pi3 running Ekos so you can see it in the list.
2. Put EQMod Mount in the Ekos mount drop down.

However, since you already have it up and running, the problem is probably somewhere else. Perhaps you need to recompile or reinstall indi-eqmod as it could be crashing.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
5 years 4 months ago #14313

Please Log in or Create an account to join the conversation.

  • Posts: 45
  • Thank you received: 6

Replied by Arjan on topic EQMod in EKOS INDI Profile?

This triggers a point I have not checked: whether EQMod is still running in the Pi2...
Anyway, maybe it is good to upgrade the indi lib in there anyway, I think it is about half a year old now.

So the EKOS profile dropdown list is filled with the indi drivers that were actually installed? It is already quite long...
What I don't understand is whether it matters at all if you choose one or not.

I'll try the update when the next brief moment of clear sky passes by. Thanks so far.
5 years 4 months ago #14331

Please Log in or Create an account to join the conversation.

  • Posts: 45
  • Thank you received: 6

Replied by Arjan on topic EQMod in EKOS INDI Profile?

OK, I did install indi_full on the Pi3, but there are still only 3CCD to choose from, and a whole list of mounts, but not EQMod...

Also, after starting indi_server, the drivers don't start (no such file or directory) and after that the unix shell cannot even find the ls command, although /bin still is in the PATH. Anyway, strange things are happening, and I decide to re-install all on the Pi3 and try running from a single board.
Last edit: 5 years 4 months ago by Arjan.
5 years 4 months ago #14477

Please Log in or Create an account to join the conversation.

Then the installation didn't complete correctly, you should be able to see all the drivers. Make sure the installation completes successfully.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
5 years 4 months ago #14482

Please Log in or Create an account to join the conversation.

Time to create page: 0.605 seconds