×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

[SOLVED] PA, when auto and west selected, 2nd rotation is east

  • Posts: 13
  • Thank you received: 1
Hi.

In the Polar Alignment Assistant (beta), if "auto" and "west" are selected, 2nd rotation is east insted.

To reproduce:
1.- Start ekos. Telescope and CCD simulators are ok (plus GSC). Go to PA Assistant.
2.- Click "Start" then "Capture".
3.- Select "West", check "Auto Mode" and click "Rotate".
4.- The mount rotates west. A capture is made and solved.
5.- The UI now shows "east" selected instead of "west". The rotation is made east instead.
6.- The process completes but the result is wrong.

Maybe the radio button state in the UI is not saved between rotations.

Edit: I'm compiling from git. Maybe a couple of days old.

Is posting bug here in the forums ok? What's the preferred method? Bugtracker or something?

Many thanks!
Last edit: 5 years 4 months ago by Guillem. Reason: Version
5 years 4 months ago #18242

Please Log in or Create an account to join the conversation.

  • Posts: 13
  • Thank you received: 1
I've done a git pull and a clean compile just to be sure. The bug it's still there.

However, to trigger it, it seems that you have to first complete the process to the east, and only then the 2nd rotations to the west will fail on successive attempts.
5 years 4 months ago #18249

Please Log in or Create an account to join the conversation.

This is an _old_ bug, are you sure you're running latest stuff? what version does it show in Help? I just tried the same procedure and no issues.

EDIT: Ok let me check that then.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
Last edit: 5 years 4 months ago by Jasem Mutlaq.
5 years 4 months ago #18250

Please Log in or Create an account to join the conversation.

Ok I can confirm this issue, working on it.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
5 years 4 months ago #18251

Please Log in or Create an account to join the conversation.

Issue fixed in GIT. Please test.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
5 years 4 months ago #18252

Please Log in or Create an account to join the conversation.

  • Posts: 13
  • Thank you received: 1
Tested, and works great. Many thanks!
5 years 4 months ago #18253

Please Log in or Create an account to join the conversation.

Time to create page: 0.436 seconds