×
INDI Library v1.8.4 Released

Minor bugfix release with some highlights:

Can't get GPS dongle to work

1 year 8 months ago
pentaxian23
Platinum Boarder
Platinum Boarder
Posts: 422
Karma: 3
More
Topic Author
Can't get GPS dongle to work #27184
I've tried connecting the USB dongle directly to the Synscan hand controller of the HEQ5 Pro and it works.

I connect the dongle to StellarMate via a supplied USB2Serial cable with no markings and if I do an "lsusb" command it reports the "Prolific Technology PL2303 Serial Port" so it would seem that the INDI GPSD has something to talk to.

- I'm running Kstars/Ekos directly on the StellarMate with mouse and keyboard.

In my Ekos setup, I select USBD for Aux 1, start INDI and in the GPSD control panel it reports that its connected but all the other status is yellow. The console says GPS fix is in progress... and its stays that way. I've tried bringing the dongle to the field just in case it was a signal problem but it didnt work there either.

The logs don't report anything of any significance other than it appears to recognize and talk to the dongle. The only strange thing I saw was "indi_telescope_simulator snooping on GPS Simulator.GEOGRAPHIC_COORD". Why would there be a GPS simulator when I've connected a real one that successfully connected. I really don't understand the snooping business.

Please Log in or Create an account to join the conversation.

1 year 8 months ago
HelgeMK
Gold Boarder
Gold Boarder
Posts: 307
Karma: 1
More
Can't get GPS dongle to work #27187
Hi Greg,

Some time ago I had difficulties with my gps module, which was not an usb dongle. I received some hints in this forum which also may help you with the debugging, see thread:

indilib.org/forum/general/3068-astroberr...-breakout-board.html

Wish you good luck - weekend coming up, plenty of time for analysis! B)

Helge
The following user(s) said Thank You pentaxian23

Please Log in or Create an account to join the conversation.

1 year 8 months ago
knro
Administrator
Administrator
Posts: 7748
Karma: 51
Can't get GPS dongle to work #27198

gbeaton wrote: I've tried connecting the USB dongle directly to the Synscan hand controller of the HEQ5 Pro and it works.

I connect the dongle to StellarMate via a supplied USB2Serial cable with no markings and if I do an "lsusb" command it reports the "Prolific Technology PL2303 Serial Port" so it would seem that the INDI GPSD has something to talk to.

- I'm running Kstars/Ekos directly on the StellarMate with mouse and keyboard.

In my Ekos setup, I select USBD for Aux 1, start INDI and in the GPSD control panel it reports that its connected but all the other status is yellow. The console says GPS fix is in progress... and its stays that way. I've tried bringing the dongle to the field just in case it was a signal problem but it didnt work there either.

The logs don't report anything of any significance other than it appears to recognize and talk to the dongle. The only strange thing I saw was "indi_telescope_simulator snooping on GPS Simulator.GEOGRAPHIC_COORD". Why would there be a GPS simulator when I've connected a real one that successfully connected. I really don't understand the snooping business.


Did you use StellarMate Serial Port Assistant to assign a permanent designation to the GPS dongle?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 year 8 months ago 1 year 8 months ago by pentaxian23.
pentaxian23
Platinum Boarder
Platinum Boarder
Posts: 422
Karma: 3
More
Topic Author
Can't get GPS dongle to work #27207
Yes, I followed the video tutorial but it doesn't seem to apply to the GPS. There is no connection tab in the control panel to enter serial port ID. The serial port is /dev/gps which I doubt can be in conflict with anything and the control panel says the GPS is connected without any issues.

Please Log in or Create an account to join the conversation.

1 year 8 months ago
knro
Administrator
Administrator
Posts: 7748
Karma: 51
Can't get GPS dongle to work #27208
Ok I'm available online in stellarmate.com chat so come there and we'll check the issue.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 year 8 months ago
pentaxian23
Platinum Boarder
Platinum Boarder
Posts: 422
Karma: 3
More
Topic Author
Can't get GPS dongle to work #27211

HelgeMK wrote: Hi Greg,

Some time ago I had difficulties with my gps module, which was not an usb dongle. I received some hints in this forum which also may help you with the debugging, see thread:

indilib.org/forum/general/3068-astroberr...-breakout-board.html

Wish you good luck - weekend coming up, plenty of time for analysis! B)

Helge


I ran killall gpsd. unplugged and plugged the gps to see /dev/gps show up. Then ran sudo cat /dev/gps and got nothing :(

Please Log in or Create an account to join the conversation.

1 year 8 months ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1306
Karma: 7
More
Can't get GPS dongle to work #27213
Using cat on a block device usually doesn't produce any output. What do you get if you type

ls -l /dev/gps

? Also the dmesg command may be your friend. Unplug the gps dongle, wait a few seconds, open a terminal, plug in the dongle and type dmesg. At the bottom of the possibly long output should be log lines concerning your dongle.

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R

Please Log in or Create an account to join the conversation.

1 year 8 months ago
pentaxian23
Platinum Boarder
Platinum Boarder
Posts: 422
Karma: 3
More
Topic Author
Can't get GPS dongle to work #27260

wvreeven wrote: Using cat on a block device usually doesn't produce any output. What do you get if you type

ls -l /dev/gps

? Also the dmesg command may be your friend. Unplug the gps dongle, wait a few seconds, open a terminal, plug in the dongle and type dmesg. At the bottom of the possibly long output should be log lines concerning your dongle.


Thanks @wvreeven, I tried but just saw some report on the usb2serial device. I wasn't too effective yesterday. Tried when I had some mosquitos bothering me. Argh!

Looks like the baud rate is 4800. Found this document about the Synscan GPS dongle: www.michiana-astro.org/file/repository/S...ion_Rev_D_042210.pdf

Jasem is looking into it.

Please Log in or Create an account to join the conversation.

1 year 8 months ago 1 year 8 months ago by pentaxian23.
pentaxian23
Platinum Boarder
Platinum Boarder
Posts: 422
Karma: 3
More
Topic Author
Can't get GPS dongle to work #27278
@jasem, as you said, it looks like the dongle is not standard. I connected to a pc and after changing the baud to 4800, was able to communicate using GPS Utility but the messages were garbled. I checked again on its specs and its says the protocol is binary: "Protocol: SynScan Position, Velocity & Time II Binary Message"

I think the gps messages are ascii so I guess I'll give up on this device and maybe buy a USB GPS dongle. Thanks again for your help

Please Log in or Create an account to join the conversation.

1 year 8 months ago 1 year 8 months ago by pentaxian23.
pentaxian23
Platinum Boarder
Platinum Boarder
Posts: 422
Karma: 3
More
Topic Author
Can't get GPS dongle to work #27356
So now I have a working GPS device. I have tested it in windows and its working fine. The data stream is not garbled binary but nice ASCII

I tried it on StellarMate and it worked too! (After I manually started gpsd). So I rebooted StellarMate and it didnt work . So I returned the SD card with StellarMate 1.3 and tried again and it still didnt work. So I thought maybe it needs Kstars to set it up so I ran Kstars/Ekos and it connected but no data like before.

So I checked the /etc/default/gps file and it did not list a device so I entered /dev/gps and rebooted and still not working.

EDIT: OK, my bad! I had to go through the serial port setup again - not just kstars. Now GPS is working, yeah! :blink:
The following user(s) said Thank You knro

Please Log in or Create an account to join the conversation.

Time to create page: 0.709 seconds