×
INDI Library v1.8.3 Released (02 Jan 2020)

Minor monthly bugfix release with a new RainbowAstro mount driver and improved pier side simulation.

Can't connect consustenlty to Canon T3i Camera

1 year 1 month ago
werper
Expert Boarder
Expert Boarder
Posts: 82
Karma: 1
More
Topic Author
Can't connect consustenlty to Canon T3i Camera #33123
Hello,

I am running Ubuntu Mate 16.04 on a RPI 3B with a 128GB micro SD card. I have the latest bleeding version of Indi installed on the RPI and use a profile in Indi Web Manager for my hardware: iOpron iEQ45 PRo, Canon DSLR and QHY CCD. I connect via WiFi from a Windows 10 PC from which I run Kstars/Ekos. Ekos connects to my mount and QHY guide camera 100% of the time, no problem. However, Ekos only connects to my Canon T3i about 1 out of 20 attempts or ~ 5% of the time. I find to get it to connect to the Canon at all, i need to boot everything first while keeping the Canon turned off. Then ounce everything is running, turn the Canon on, wait 20 seconds, and THEN and ONLY then, play the "start" button in Ekos. Even then, most of the time Ekos does not make the connection, in which case I have to turn off the Canon, disconnect and "stop" Ekos, then turn the Canon back on, and start Ekos again - HOPING this time it'll connect. Obviously, this is no good and renders the RPI system useless.

I get the following error message in Ekos:
2018-12-31T18:35:35: [ERROR] Can not open camera: Power OK? If camera is auto-mounted as external disk storage, please unmount it and disable auto-mount.
2018-12-31T18:35:35: [ERROR] Camera_get_config failed (-2): Bad parameters

I have turned of auto-mounting in Ubuntu via the dconf Editor, by following these instructions I found, which did not help:
www.astrofriend.eu/astronomy/projects/pr...tars-indi-linux.html

I've researched this problem at GREAT length and see it's a fairly common problem for Canon DSLRs. Unless I can find a consistently reliable solution, this problem is a complete deal-breaker and will force me to go back to using my laptop along with Sequence Generator Pro and PHD, or Backyard EOS, or Astrophotography Tool. I have a background in Network Administration and am VERY computer literate, but am a total noob with Linux.

ANY and ALL help is GREATLY appreciated!! I really like the idea of using a RPI-based system and Kstars/Ekos look outstanding!! I firmly believe this is the way astrophotography is headed and I'm SO close to making this a viable system/solution for my rig, so I'm not about to give up trying.

Thank you for your time and any help you can give - I know there's many others out who have the exact same problem using this system with their Canon DSLR. If we can put this bug to bed once and for all, many others besides myself will become successful RPI - Indi - Kstars/Ekos users and evangelists!

Tom Bardenwerper

TPO 8" Ritchey-Chretien Astrograph
Moonlite CS focuser with Motor Drive
RoboFocus Auto Focuser
iOptron iEQ45 Pro Mount
Stellarrmate OS (beta) RPi 4, 4GB
Canon T3i DSLR - Primary Cam
Starlight Xpress Lodestar X2 Guide Cam
Astromania 60 Guide Scope
Polemaster Polar Alignment Cam
The following user(s) said Thank You pug916

Please Log in or Create an account to join the conversation.

2 months 1 week ago
Acapulco Rolf
Senior Boarder
Senior Boarder
Posts: 48
Karma: 2
More
Can't connect consustenlty to Canon T3i Camera #46724
Hi Tom

I pretty much observe the same as you though I am running Stellarmate 1.4.3 on a Raspberry Pi 4/4Gb on Ubuntu 18.04.3

My Canon DSLR 600d intermittently disconnects

For me, the only way to reconnect the DSLR is this:

unplug camera from usb
power off the camera
power on the camera
restart the raspberry pi
replug camera into usb


The issue is intermittent for me, but enough to ruin an imaging session

I too have done some research and come up with the same remedies that you quoted but still observe the Canon DSLR disconnect issue intermittently

As I type, I'm currently shooting darks at various exposures and durations and so far so good.....for now....


Did you find a solution in the end...?

Equipment:
Skywatcher EQ5 Mount/EQMOD
Canon 600D DSLR
Altair 80mm refractor
ZWO CCD ASI224MC Guide Camera
MyFocuserPro2 focuser
Stellarmate 1.4.3 (Raspberry Pi 4)
Raspberry Pi 4 (4GB)

KSTARS 3.3.8
Stellarmate 1.4.3

Please Log in or Create an account to join the conversation.

2 months 1 week ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1236
Karma: 6
More
Can't connect consustenlty to Canon T3i Camera #46725
Hi,

Same issue here. Our Canon EOS 77D disconnects very often or even refuses to connect. This is on a mini-pc, not an RPi. We are using the KStars and libgphoto2 nightlies from Jasem’s ppas. Any help would greatly be appreciated!


Wouter

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R

Please Log in or Create an account to join the conversation.

2 months 1 week ago 2 months 1 week ago by Acapulco Rolf.
Acapulco Rolf
Senior Boarder
Senior Boarder
Posts: 48
Karma: 2
More
Can't connect consustenlty to Canon T3i Camera #46732
Hi Wouter

For my use case, so far the only consistently reliable way I've found to reconnect the DSLR when the connection fails is as follows:

unplug camera from usb
power off the camera
power on the camera
restart the raspberry pi
replug camera into usb


For reference, I see the following in my logs when the disconnection event happens:

[2019-12-09T07:59:39.415 UTC INFO ][ org.kde.kstars.indi] - Canon DSLR EOS 600D : "[ERROR] Camera_get_config failed (-110): I/O in progress "
[2019-12-09T07:59:39.417 UTC INFO ][ org.kde.kstars.indi] - Canon DSLR EOS 600D : "[ERROR] Can not open camera: Power OK? If camera is auto-mounted as external disk storage, please unmount it and disable auto-mount. "
[2019-12-09T07:59:39.417 UTC DEBG ][ org.kde.kstars.ekos] - Canon DSLR EOS 600D is disconnected.
[2019-12-09T07:59:39.418 UTC INFO ][ org.kde.kstars.ekos] - "Canon DSLR EOS 600D is disconnected."


Attaching logs showing the issue from this morning for reference
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.626 seconds