×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Kstars Ekos is crashing randomly every day, after getting 300" subs imaging

1 year 6 months ago
Moia
Fresh Boarder
Fresh Boarder
Posts: 17
More
Topic Author
Kstars Ekos is crashing randomly every day, after getting 300" subs imagin #33403
Kstars/ekos was working about 3 h with no errors, but finally crashed...

the end of the logs say that: QImage: out of memory, returning null image !!!
and the FITS VIEWER was disable...

any ideas??

thanks

Guillem


p.s. logs
[2019-01-07T01:43:38.226 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:38.237 CET DEBG ][ org.kde.kstars.indi] - SX CCD LodeStar : "[DEBUG] Upload complete "
[2019-01-07T01:43:38.531 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:38: Driver indi_sx_ccd: sxSetSTAR2000: libusb_control_transfer -> OK"
[2019-01-07T01:43:38.531 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:38: Driver indi_sx_ccd: sxClearPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:38.532 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:38.714 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:38: Driver indi_sx_ccd: sxSetSTAR2000: libusb_control_transfer -> OK"
[2019-01-07T01:43:38.715 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:39.886 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:39: Driver indi_sx_ccd: sxLatchPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:39.886 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:39.984 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:39: Driver indi_sx_ccd: sxReadPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:39.984 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:39.986 CET DEBG ][ org.kde.kstars.indi] - SX CCD LodeStar : "[DEBUG] Uploading file. Ext: fits, Size: 221760, sendImage? Yes, saveImage? No "
[2019-01-07T01:43:40.001 CET DEBG ][ org.kde.kstars.indi] - SX CCD LodeStar : "[DEBUG] Upload complete "
[2019-01-07T01:43:40.192 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:40: Driver indi_sx_ccd: sxSetSTAR2000: libusb_control_transfer -> OK"
[2019-01-07T01:43:40.192 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:40: Driver indi_sx_ccd: sxClearPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:40.192 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:40.305 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:40: Driver indi_sx_ccd: sxSetSTAR2000: libusb_control_transfer -> OK"
[2019-01-07T01:43:40.306 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:41.595 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:41: Driver indi_sx_ccd: sxLatchPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:41.595 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:41.693 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:41: Driver indi_sx_ccd: sxReadPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:41.694 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:41.696 CET DEBG ][ org.kde.kstars.indi] - SX CCD LodeStar : "[DEBUG] Uploading file. Ext: fits, Size: 221760, sendImage? Yes, saveImage? No "
[2019-01-07T01:43:41.703 CET DEBG ][ org.kde.kstars.indi] - SX CCD LodeStar : "[DEBUG] Upload complete "
[2019-01-07T01:43:41.880 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:41: Driver indi_sx_ccd: sxSetSTAR2000: libusb_control_transfer -> OK"
[2019-01-07T01:43:41.880 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:41: Driver indi_sx_ccd: sxClearPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:41.881 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:42.054 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:42: Driver indi_sx_ccd: sxSetSTAR2000: libusb_control_transfer -> OK"
[2019-01-07T01:43:42.055 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:43.296 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:43: Driver indi_sx_ccd: sxLatchPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:43.296 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:43.394 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:43: Driver indi_sx_ccd: sxReadPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:43.395 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:43.399 CET DEBG ][ org.kde.kstars.indi] - SX CCD LodeStar : "[DEBUG] Uploading file. Ext: fits, Size: 221760, sendImage? Yes, saveImage? No "
[2019-01-07T01:43:43.412 CET DEBG ][ org.kde.kstars.indi] - SX CCD LodeStar : "[DEBUG] Upload complete "
[2019-01-07T01:43:44.218 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:43: Driver indi_sx_ccd: sxSetSTAR2000: libusb_control_transfer -> OK"
[2019-01-07T01:43:44.221 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:43: Driver indi_sx_ccd: sxClearPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:44.224 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:43: Driver indi_sx_ccd: sxSetSTAR2000: libusb_control_transfer -> OK"
[2019-01-07T01:43:44.226 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:45.033 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:45: Driver indi_sx_ccd: sxLatchPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:45.033 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:45.142 CET DEBG ][ org.kde.kstars.indi] - SX CCD LodeStar : "[DEBUG] Uploading file. Ext: fits, Size: 221760, sendImage? Yes, saveImage? No "
[2019-01-07T01:43:45.142 CET DEBG ][ org.kde.kstars.indi] - SX CCD LodeStar : "[DEBUG] Upload complete "
[2019-01-07T01:43:45.143 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:45: Driver indi_sx_ccd: sxReadPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:45.143 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:45.400 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:45: Driver indi_sx_ccd: sxSetSTAR2000: libusb_control_transfer -> OK"
[2019-01-07T01:43:45.400 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:45: Driver indi_sx_ccd: sxClearPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:45.401 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:45.432 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:45: Driver indi_sx_ccd: sxSetSTAR2000: libusb_control_transfer -> OK"
[2019-01-07T01:43:45.433 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:47.316 CET DEBG ][ org.kde.kstars.ekos.capture] - All capture jobs complete.
[2019-01-07T01:43:47.376 CET DEBG ][ default] - WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no objectName ) to Phonon::AudioOutput ( no objectName ).
[2019-01-07T01:43:47.386 CET DEBG ][ org.kde.kstars.indi] - SX CCD LodeStar : "[DEBUG] Uploading file. Ext: fits, Size: 221760, sendImage? Yes, saveImage? No "
[2019-01-07T01:43:47.387 CET DEBG ][ org.kde.kstars.indi] - SX CCD LodeStar : "[DEBUG] Upload complete "
[2019-01-07T01:43:47.411 CET DEBG ][ default] - WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no objectName ) to Phonon::AudioOutput ( no objectName ).
[2019-01-07T01:43:47.588 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:46: Driver indi_sx_ccd: sxLatchPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:47.589 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:46: Driver indi_sx_ccd: sxReadPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:47.589 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:47.605 CET DEBG ][ default] - WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no objectName ) to Phonon::AudioOutput ( no objectName ).
[2019-01-07T01:43:48.270 CET DEBG ][ org.kde.kstars.fits] - Started WCS Data Processing...
[2019-01-07T01:43:48.275 CET WARN ][ default] - QImage: out of memory, returning null image

Please Log in or Create an account to join the conversation.

1 year 6 months ago
knro
Administrator
Administrator
Posts: 8176
Karma: 51
Kstars Ekos is crashing randomly every day, after getting 300" subs imagin #33404
Will check on MacOS today if there is any memory leaks.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 year 6 months ago
knro
Administrator
Administrator
Posts: 8176
Karma: 51
Kstars Ekos is crashing randomly every day, after getting 300" subs imagin #33411
No memory leaks are apparent. Please use the Activity monitor and check the RAM usage. Check if either KStars or the INDI drivers use up more memory with time.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 year 6 months ago
Moia
Fresh Boarder
Fresh Boarder
Posts: 17
More
Topic Author
Kstars Ekos is crashing randomly every day, after getting 300" subs imagin #33418
Hi Jasem,

Yesterday memory usage was 60%-70% (RAM) and CPU 50%. I saw some SWAP usage, I don't know why... I will check it this night with the default monitor (ubuntu Mate).

With FITS Viewer disable, I only make some Zoom in and out to recent images in main Ekos tab...

I read this: www.indilib.org/forum/search.html?query=...ations&childforums=1 --> I may uninstall it !!!

Two days ago, I installed the missing packages of this 'annoying Phonon' message.
In Ubuntu Mate (not KDE) I did'nt found where to disable notifications sounds...

thanks for your help

Guillem

Please Log in or Create an account to join the conversation.

1 year 6 months ago
knro
Administrator
Administrator
Posts: 8176
Karma: 51
Kstars Ekos is crashing randomly every day, after getting 300" subs imagin #33419
which programs were responsible for that? KStars? INDI driver? both? can you share screenshots or number?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 year 6 months ago
Moia
Fresh Boarder
Fresh Boarder
Posts: 17
More
Topic Author
Kstars Ekos is crashing randomly every day, after getting 300" subs imagin #33421
Hi Jasem,
Now, I am running this test : ( During this night I can do more tests ( any more suggestions?? ))
I including this brief PDF.

thanks

Guillem
Attachments:

Please Log in or Create an account to join the conversation.

1 year 6 months ago
Moia
Fresh Boarder
Fresh Boarder
Posts: 17
More
Topic Author
Kstars Ekos is crashing randomly every day, after getting 300" subs imagin #33443
Hi Jasem,

I made more tests during night to real objects, and memory usage is about 80-90%.
Look the PDF with screenshots...

May I kill some services? this 'phonon' message at the end of the logs is getting me MAD...

thanks

Guillem
Attachments:

Please Log in or Create an account to join the conversation.

1 year 6 months ago
Moia
Fresh Boarder
Fresh Boarder
Posts: 17
More
Topic Author
Kstars Ekos is crashing randomly every day, after getting 300" subs imagin #33676
Hi Jasem,

I was taking some pictures ( Everthing was PERFECT) , but I realised that memory RAM increased up more than 800 MB, while I was doing ZOOM IN in fits viewer (main window, see attached file). I could see monitoring it with htop ...

I have FITS VIEWER disabled, but I only was observing the 'round' stars...
There is atached logs.

Now , I installed ZRAM from : github.com/novaspirit/rpi_zram

I will see whats happening...

thanks for your help,

Guillem
Attachments:

Please Log in or Create an account to join the conversation.

1 year 6 months ago
Moia
Fresh Boarder
Fresh Boarder
Posts: 17
More
Topic Author
Kstars Ekos is crashing randomly every day, after getting 300" subs imagin #33712
Hi,

Fortunately, with zram kstars - ekos didn't crashed...

but you can see on the video ( turn down the sound !!! ) how Ekos eats a lot of RAM while ZOOM IN on the captures...

clear skies !!

Guillem

Attachments:

Please Log in or Create an account to join the conversation.

1 year 6 months ago
knro
Administrator
Administrator
Posts: 8176
Karma: 51
Kstars Ekos is crashing randomly every day, after getting 300" subs imagin #33714
Turn on "Resource Limited Mode" in FITS options.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 year 6 months ago
Moia
Fresh Boarder
Fresh Boarder
Posts: 17
More
Topic Author
Kstars Ekos is crashing randomly every day, after getting 300" subs imagin #33721
Hi,

I'll do it this evening !!
There is als an upgrade to do for Kstars Ekos --> version 3.1

thanks

Guillem

Please Log in or Create an account to join the conversation.

1 year 6 months ago
Moia
Fresh Boarder
Fresh Boarder
Posts: 17
More
Topic Author
Kstars Ekos is crashing randomly every day, after getting 300" subs imagin #33788
Hi Everybody,

Finally, everything Kstars-Ekos is perfectly working
Thanks to Jasem for his support !!

Clear skies !!

Guillem
The following user(s) said Thank You knro

Please Log in or Create an account to join the conversation.

Time to create page: 0.232 seconds