×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

QHY Driver crashes on latest release of KStars/Ekos

  • Posts: 930
  • Thank you received: 432
also, forgot to mention, in case this is helpful.
I've never run any real sessions with this computer and ekos setup on this intel stick.
I've been trying to install and got this error--so the ekos isn't fully set up, but I don't think there's any setup for the guide camera. I was trying to set up things when I got this crash

I have, however, had many successful evenings with this equipment, and ekos running on a Raspberry Pi 3B+, though on 3.0. Weather's been too rainly lately here since the feb 27 release.
AP1100 & Orion Atlas Pro, WO/ZS105 w/Moonlight V2 focus, GSO RC10 w/RSF focus
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Greedy Scheduler, Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
3 years 10 months ago #36032

Please Log in or Create an account to join the conversation.

  • Posts: 43
  • Thank you received: 0
Still doesn’t work for me either. I did another update to the latest Indi library using the commands
sudo apt-add-repository ppa:mutlaqja/ppa
sudo apt-get update
sudo apt-get install indi-full gsc
The system no longer crashes but after I press connect on the QHY5 control panel I get a yellow light, not green. Also when I go to the Guiding tab the QHY5 is not available as a guider.
I also get a nagging message that the QHY5 Ii LM driver has crashed. I know I am using the latest Indi driver release because my Altair Hypercam 183 M now works. How frustrating, i waited months for my main imaging camera to work, but when it started working the guide camera quit.
Lou
3 years 10 months ago #36041

Please Log in or Create an account to join the conversation.

  • Posts: 43
  • Thank you received: 0
Just to elaborate I am using a Linux desktop not a Stellarmate. If the QHY 5 problem was fixed on Stellarmate it is not fixed on acLinux desktop.
Lou
3 years 10 months ago #36042

Please Log in or Create an account to join the conversation.

This is most likely a build issue as the camera works fine here. Tomorrow a new build would be out for the QHY driver.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
3 years 10 months ago #36043

Please Log in or Create an account to join the conversation.

  • Posts: 930
  • Thank you received: 432
Thanks very much Jasem.
I'll test tomorrow.
Do you mean that I should check for a standard release tomorrow, or is it just the nightly build?
AP1100 & Orion Atlas Pro, WO/ZS105 w/Moonlight V2 focus, GSO RC10 w/RSF focus
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Greedy Scheduler, Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
3 years 10 months ago #36044

Please Log in or Create an account to join the conversation.

  • Posts: 43
  • Thank you received: 0
So we should be using the nightly builds?
Lou
3 years 10 months ago #36050

Please Log in or Create an account to join the conversation.

  • Posts: 930
  • Thank you received: 432
FWIW, when I was testing those crashes yesterday, I tested on both the Feb27 3.1 release and the nightly build and it crashed for both. I expect you'll find the same, until this next build Jasem is speaking about.
AP1100 & Orion Atlas Pro, WO/ZS105 w/Moonlight V2 focus, GSO RC10 w/RSF focus
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Greedy Scheduler, Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
3 years 10 months ago #36054

Please Log in or Create an account to join the conversation.

  • Posts: 930
  • Thank you received: 432
I tried to run with the new build that was supposed to come out today, but couldn't find it.
Just verifying that it's not ready yet.

I tried:
sudo apt-get update
sudo apt-get upgrade
but no new version of kstars, etc. Still 2/27 3.1 release.
I tried the indinightly, and did get Build: 2019-03-07T12:48:11Z but that also crashed on startup.
This is what qhy versions I seem to be running, it's the same in the standard nightly release:
Selected version '2.1~201901131630~ubuntu18.04.1' (INDI Stable Builds:18.04/bionic [amd64]) for 'indi-qhy'

Both the standard release (which was the same as last time, and the new nightly crash right away.

As a reminder, I'm running Ubuntu 18.04 on an Intel Stick (Atom CPU).

Hy
AP1100 & Orion Atlas Pro, WO/ZS105 w/Moonlight V2 focus, GSO RC10 w/RSF focus
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Greedy Scheduler, Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
3 years 10 months ago #36142

Please Log in or Create an account to join the conversation.

is that 32bit or 64bit??
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
3 years 10 months ago #36148

Please Log in or Create an account to join the conversation.

  • Posts: 930
  • Thank you received: 432
I believe 64 bit.
This is the ISO I installed:
releases.ubuntu.com/18.04/ubuntu-18.04.2-desktop-amd64.iso
And this is the computer:
www.amazon.com/gp/product/B01AZC4NHS/ref...02_s00?ie=UTF8&psc=1

Thanks.
AP1100 & Orion Atlas Pro, WO/ZS105 w/Moonlight V2 focus, GSO RC10 w/RSF focus
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Greedy Scheduler, Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
3 years 10 months ago #36149

Please Log in or Create an account to join the conversation.

  • Posts: 930
  • Thank you received: 432
For what it's worth, tonight I tried compiling indi-1.7.6 from source on the stick to see if that would work.
I got it all to compile, and kstars/ekos/indi and my asi-1600 camera ran, but indi_qhy_ccd continued to crash.
AP1100 & Orion Atlas Pro, WO/ZS105 w/Moonlight V2 focus, GSO RC10 w/RSF focus
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Greedy Scheduler, Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
3 years 10 months ago #36150

Please Log in or Create an account to join the conversation.

  • Posts: 43
  • Thank you received: 0
I tested my QHY5IIL-M yesterday with the nightly build and the stable build. Just a reminder I am using a Linux Mint desktop running the latest updates. In both cases the QHY driver crashed.
Lou
3 years 10 months ago #36396

Please Log in or Create an account to join the conversation.

Time to create page: 0.722 seconds