×

INDI Library v1.8.0 is Released (27 Jul 2019)

INDI Library v1.8.0 is mostly a maintenance release to fix a few bugs in several drivers.

Capturing images with big sensors and Raspberry

  • Posts: 5
  • Thank you received: 0

Capturing images with big sensors and Raspberry was created by Navy

hello, I use an EOS450D and an ASI120 on a rapberry Pi3 + no problem with the capture and display of the image.

When I use my EOS 5DMKII or ASI1600 with the maximum resolution ... I request a capture (on the disk or memory card) but impossible to view it.
With Ekos, I have a message:
"Check Failed Check INDI Control Panel For details"
EKOS remains stuck: Status: Capturing.
In INDI I have the message: Can not convert / tmp / indi_wjL9ym: Unsufficient memory
and
: Exposure failed to parse raw image.

If I down on the UPS at 2X2 it works
If I go down on EOS 5D Small Normal JPEG it works.

Does anyone have experience with EKOS, Raspberry and "important" sensors? A solution? Pass on an ASUS Tinker Board?

Thank you and good evening.
3 months 1 week ago #38919

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 10

Replied by LinuxUser on topic Capturing images with big sensors and Raspberry

Hi Navy,
One possibility is that you may be pushing the limits of RAM memory (1GB on a RPI3). Have you installed the ZRAM package? If not it is in the RPI3 UBUNTU Mate repositories if you are running Mate. This extends available ram by using ram compression and setting up a SWAP file in some of the extended RAM. I have been using it successfully with my system for over 2 .5 years and there are many others on the forum here that use it as well (do a forum search for zram and you will find some helpful information).

Also make sure you are running in limited resource mode in the KStars settings. I believe the more recent builds of KStars automatically sets that mode as default if it is running on an ARM CPU based system, which the Raspberry PI3 family is. So give these a go and see how it works.
The following user(s) said Thank You: Navy
Last edit: 3 months 1 week ago by LinuxUser.
3 months 1 week ago #38925

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 0

Replied by Navy on topic Capturing images with big sensors and Raspberry

Hello LINUXUSER !!
zRam has solved my problem. You are fantastic !! thank you .

I did not find the "limited resource mode in the KStars settings" ... can you tell me more?
Last edit: 3 months 1 week ago by Navy.
3 months 1 week ago #38940

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 10

Replied by LinuxUser on topic Capturing images with big sensors and Raspberry

Navy,
It is always good to hear when a suggestion works and a problem is solved. You are very welcome!

The "Limited Resource Mode" can be found as follows - From the "Settings" menu go down near the bottom to"Configure KStars" and you will then see the window as included below:



From the left panel choose "FITS", then under the "Processing" section choose the check box just to the left of "Limited Resource Mode". This will turn off the "Auto Debayer", "Auto WCS", and "3D Cube" settings thereby saving memory and processing resources. This might already be set on your Raspberry PI3+. Once it is selected then on the lower right of the window choose "Apply" and "OK" and you will be all set. Now, let's hope on your next night out you will be able to grab some good data and revel in the final image. :-)
The following user(s) said Thank You: Navy
3 months 1 week ago #38948
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.418 seconds