×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Ekos on Mac OS X ?

  • Posts: 16
  • Thank you received: 20

Replied by Akarsh on topic Ekos on Mac OS X ?

Hi

Unfortunately, I don't have time to work on this today -- I'm about to leave for an astronomy trip, so there's all the packing and stuff. If I do have time to work on it during the day over the next few days, I will. But if someone else wants to look into it sooner than I can, please do so.

Workaround: Avoid altaz grid and horizontal coordinates.

Some developer information: While I believe that the transition to CachingDms could be responsible for this, I haven't found any immediate evidence. The problem seems to be:
1. A line that returns a Vector2f(0, 0) in Projector::toScreenVec instead of failing an assert and crashing (added in Android transition efforts)
2. A call to NoPrecessIndex::JITUpdate() seems to mangle the azimuth. I guess this is the effect of calling HorizontalToEquatorial and then EquatorialToHorizontal when altitude = 90.0 (i.e. when alt = 90, azimuth is indeterminate).
3. It should be okay to set the azimuth to something finite just so computations don't turn out to become NaN all the time -- but I would refrain from doing it in toScreenVec, since it is called a million times per draw under certain settings.

Regards
Akarsh
The following user(s) said Thank You: Rob Lancaster
5 years 11 months ago #10541
The topic has been locked.
  • Posts: 2793
  • Thank you received: 785

Replied by Rob Lancaster on topic Ekos on Mac OS X ?

Hi Akarsh,

Thats perfectly fine enjoy your trip! KStars has been perfectly usable on OS X, even in Horizontal mode (which I like better anyway). The error messages just happen at the beginning and then its fine. I agree the horizontal grid looks weird, but its fine if you don't turn on the horizontal grid ;-)

Thanks,

Rob
5 years 11 months ago #10542
The topic has been locked.
  • Posts: 2793
  • Thank you received: 785

Replied by Rob Lancaster on topic Ekos on Mac OS X ?

Updated instructions on how to Install KStars/INDI/Ekos and even GSC on OS X. Most of the commands can be simply copied and pasted to a terminal. Adam, I made the changes you suggested, please look over it and see if there is anything else you would add. I hope in the future that these instructions can be made simpler or even that we can make an installer and/or dmg. But for now, I'm just glad we got it all working!!



This browser does not support PDFs. Please download the PDF to view it: Download PDF

5 years 11 months ago #10543
Attachments:
The topic has been locked.
  • Posts: 25
  • Thank you received: 8

Replied by Sean Houghton on topic Ekos on Mac OS X ?

I've been following this thread remotely and it's awesome to see the progress. I think all of my pull requests have been integrated into the mainline so you shouldn't need to use my branch anymore (as mentioned earlier). I have a fix for the Debug mode crash which I'll post once I get my backup laptop working (beer on MBP keyboard = death).

Once we come up with a reliable build configuration I'd like to set up a Travis CI job to keep things running and upload nightly builds to S3 so everyone can have fresh OSX/MacOS builds without suffering through 6 hour Qt builds (!).
The following user(s) said Thank You: Rob Lancaster, Adam
5 years 11 months ago #10544
The topic has been locked.
  • Posts: 2793
  • Thank you received: 785

Replied by Rob Lancaster on topic Ekos on Mac OS X ?

That sounds excellent! Yes, if you look at the updated directions, i am using the current kstars git instead of yours now. Mainly we are using your excellent instructions for the preparations with the environment variables.

As of right now I have kstars, indi, ekos, and gsc working on my system. I havent tested xplanet or astrometry with os x yet. There are still a few bugs, the biggest being the download new data problem.

And yes, not having to build every time would be awesome! Your assistance is most welcome!
5 years 11 months ago #10545
The topic has been locked.
  • Posts: 82
  • Thank you received: 9

Replied by Adam on topic Ekos on Mac OS X ?

Hi all,

Akarsh, enjoy your trip! :)
Rob, thanks for your update on the instructions. I want to add that I also had to export the directories as described by Sean before building libindi for it to find the homebrew qt5 installation. Maybe you also have a manual installation of qt5 so it works for you without the exports. In addition, I had to install cmake using homebrew before everything else. So maybe it would be good to move all the homebrew stuff to the top of the instructions. I would also add "brew install pkgconfig" there as I needed that for kstars to detect indi.
You could also add the changes to the qt5 formula I had to follow to make it build using homebrew in case someone wants to try before this is fixed officially.
I will also try to build kstars and indi on macos 10.12 again if I can, so for now you could also add a remark that the instructions are only tested on 10.11 yet.
Also, thanks for the gsc instructions! I haven't tried them yet.
And Sean, thanks for your initial work! It would indeed be great if the whole process could be eased in the end. As most of the dependencies are installed using homebrew already, maybe it would be possible to also make indi and kstars available through homebrew somehow in the end? I have absolutely no experience with that however and homebrew doesn't seem that reliable on recent versions of OS X.
The following user(s) said Thank You: Rob Lancaster
5 years 11 months ago #10547
The topic has been locked.
  • Posts: 2793
  • Thank you received: 785

Replied by Rob Lancaster on topic Ekos on Mac OS X ?

Hi Adam,

No, you are right, when I installed libindi from source, I definitely used the exports because otherwise, it doesn't know where things are. I believe I already had cmake on my mac, and I don't remember installing pkgconfig, but I do see both of them in my home-brew /usr/local/cellar directory so I don't know when I did that, so you might be right on that too. I just added all this to the instructions. Please take a look at them again.

This browser does not support PDFs. Please download the PDF to view it: Download PDF



Thanks,

Rob
The following user(s) said Thank You: Adam
5 years 11 months ago #10553
Attachments:
The topic has been locked.
  • Posts: 82
  • Thank you received: 9

Replied by Adam on topic Ekos on Mac OS X ?

Hi Rob,
I think that should be easy to follow, well done! :) Just to save the reader some searching, you could add the directory of the qt5 formula which is a bit hard to find:
/usr/local/Homebrew/Library/Taps/homebrew/homebrew-core/Formula/qt5.rb

I have yet to try gsc (and astrometry.net), but from your instructions, I don't see a reason why it shouldn't work.

Thanks for the nice write-up!
Adam
5 years 11 months ago #10557
The topic has been locked.
  • Posts: 2793
  • Thank you received: 785

Replied by Rob Lancaster on topic Ekos on Mac OS X ?

do you possibly have a link to somewhere the fix is discussed so I can put a link in the instructions too?
5 years 11 months ago #10558
The topic has been locked.
  • Posts: 82
  • Thank you received: 9

Replied by Adam on topic Ekos on Mac OS X ?

Yes, the fix is somewhere in the last third of the discussion here:
github.com/Homebrew/homebrew-core/issues/4841
and the issue is being further tracked here:
github.com/Homebrew/homebrew-core/issues/5391
The following user(s) said Thank You: Rob Lancaster
5 years 11 months ago #10559
The topic has been locked.
  • Posts: 82
  • Thank you received: 9

Replied by Adam on topic Ekos on Mac OS X ?

Hi,
I just want to say that the qt5 issue seems to be fixed now so installing qt5 with homebrew should work without the patch from before. I actually had to undo the patch manually because homebrew keeps user-made changes to formulas between updates.
Unfortunately, I still have no luck building libindi on macos 10.12 because the cmake files searching for libnova and libusb don't seem to work. I made cmake find them by giving the directories manually to the command, but when trying to build libindi afterwards, it fails because it doesn't find libnova with the 'include <libnova.h>' statements for example.
Another issue I encountered is, that starting drivers locally from Ekos (with the 'Mode: local' setting) doesn't work. It gives a pop-up error message:

Driver indi_simulator_telescope was not found on the system. Please make sure the package that provides the 'indi_simulator_telescope' binary is installed

although I set the indi server and drivers directories to /usr/local/bin/indiserver and /usr/local/share/indi and the files in question seem to be right there.
5 years 11 months ago #10819
The topic has been locked.
  • Posts: 2793
  • Thank you received: 785

Replied by Rob Lancaster on topic Ekos on Mac OS X ?

Hi Adam,

So we can probably remove the section about patching the qt5, and just go back to installing it with home-brew?

The problems you stated with building libindi, were those problems just with OS10.12, or were you unable to build libindi on 10.11 too? I was able to successfully build libindi, but had some trouble with the 3rd party drivers. That is all now working on my system.

For the local mode, was that just on 10.12, or does that include 10.11 too? My setup is the same as yours on 10.11 I think and my local mode works fine.

Note, if you cannot get the local mode to work, for now you can use the Cloudmakers indiserver app and run that "remotely" on the same computer. But hopefully yours can work locally.

I haven't been working on this problem for a little while because it was working on my system now and I turned my attention to learning some C++ and improving the fits viewer. My changes are not available yet but they will be soon (a couple of weeks I think?). I have added panning with a left button mouse drag, using trackpad gestures like pinch and two fingered panning for zooming and panning the image file, keeping the zooming focused on the point you intend instead of going to the upper left hand corner all the time, optional gridlines and crosshairs for overlaying your image, and a mouse mode for centering your telescope on a point you click in the image. These are all currently working fairly well on my Mac and Linux machines, but there are still some minor kinks that need to be worked out. Hopefully will be soon.

The problems you brought up are really important though because the first priority is to get it installed on your computer, extra features would come second to that. Please let me know anything you can about the problem.

Thanks,

Rob
5 years 11 months ago #10830
The topic has been locked.
Time to create page: 0.990 seconds