×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Ekos on Mac OS X ?

3 years 5 months ago
jamiesmithnc
Gold Boarder
Gold Boarder
Posts: 211
Karma: 1
More
Ekos on Mac OS X ? #14051
Hi All-
Work has been crazy busy lately- I will try to take a look at the doc steps and see if I can help there.

The merge looked fine - not sure why I didn't get notified if there was a PR. Since it is merged in to master you should probably remove the old brand if you are done.
The topic has been locked.
3 years 5 months ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2264
Karma: 22
More
Ekos on Mac OS X ? #14052
I did the merge shortly after the request because I wanted to try it. I am not sure if notifications would still be sent if it is resolved quickly?
The topic has been locked.
3 years 5 months ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2264
Karma: 22
More
Ekos on Mac OS X ? #14066
Hi Jamie, could you also take a look at building the other 3rd party drivers? We are not building many of them and there are more available that we could build. We are already doing gphoto, eqmod, cloudwatcher, spectracyber, maxdomeII and sx. Three that I am particularly interested in are the ZWO/ASI, the SBIG, and the DSI. I started trying to modify the code to make them work, but I was having trouble. You will find my lines of code in the script commented out. Please take a look at your convenience. Thanks!
The topic has been locked.
3 years 5 months ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2264
Karma: 22
More
Ekos on Mac OS X ? #14068
Oh also, Jasem pushed a change that added Kf5NotificationConfiguration to KStars and it caused a build error. He will have to make another change that I don't know to make the emerge version work properly with this new dependency. But I did manage to fix the cmake build by just adding that to the brew installs. I pushed it to the script.

Jamie, I tried to delete the other branch, but cannot find the option. can you do it?
The topic has been locked.
3 years 5 months ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2264
Karma: 22
More
Ekos on Mac OS X ? #14095
So Jasem fixed the build for KStars.

But there is more good news about the startup wizard. I figured out what I was doing wrong on the installers for netpbm, pip, and pyfits. I have a working dmg with those functional (but relying on home-brew being installed, if it is not, I give the user a link to how to install it)

I also fixed the OK button being enabled when it shouldn't be enabled problem, but haven't sent the change to Jasem yet.

Next I will add an installer button for gsc. data. Should be nice.
The topic has been locked.
3 years 5 months ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2264
Karma: 22
More
Ekos on Mac OS X ? #14098
Ok, I got the gsc data installer working! i sent it to Jasem, and if all checks out, I will build a new dmg for you guys to test tomorrow afternoon/evening. Get ready for it! It should be able to install everything but homebrew internally.
The topic has been locked.
3 years 5 months ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2264
Karma: 22
More
Ekos on Mac OS X ? #14108
oops, one mistake, I used wget for the gsc downloader. It now occurs to me that wget is not installed by default. I think I will switch to curl. hindsight is 20-20, sorry, will get that new dmg to you guys tomorrow then.
The topic has been locked.
3 years 5 months ago 3 years 5 months ago by rlancaste.
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2264
Karma: 22
More
Ekos on Mac OS X ? #14137
Great News, a new KStars DMG to test. Jasem, myself, and others have added a lot since I posted the last DMG.

NEW KSTARS DMG 01-26-2017

If you can, it would be nice if you could delete (or rename) your data directory at least briefly to test my startup wizard. Also, if you can see if some of these installers work, that would be great!

Please let me know about any issues.

New Improvements:
A fully working GSC installer!!
The disabling of the OK button in the Wizard before the data directory is made.
Possibly working installers for python, pip, pyfits, and netpbm (I keep having trouble with these, but I think its better now)
An improved Focus Module.
Acknowledgements for Jamie and Stephane for their contributions to the OS X port.
Better zooming with the Mac trackpad pinch gesture in Fits Views. (I slowed it down a lot, it was WAY too fast/responsive)
The beginnings of a floating toolbar in embedded FitsViews on the Focus and Guide Modules
Live Video in the Capture Module (for supported cameras)
Disabled the JupiterMoonTool (sad, but it didn't work)
And other things. . .
The following user(s) said Thank You knro, nmac, Poison
The topic has been locked.
3 years 5 months ago 3 years 5 months ago by nmac.
nmac
Platinum Boarder
Platinum Boarder
Posts: 426
Karma: 2
More
Ekos on Mac OS X ? #14142
I have just downloaded and had a quick 10 minute test before heavy rain started to fall :-/

From what I could see, apart from the autofocus issue that I have already reported in the forum, the new Live Video function is not working with my 450D.I don't know if it should work with DSLRs but mine does not. I crashes Kstars as soon as I use it and I have to disconnect the camera and restart INDI server
before I can connect again or it crashes as soon as I connect to INDI Server.

According to the log I get this: "2017-01-27T19:15:23.911 - WARN - QImage::scaled: Image is a null image"

Everything else seems ok, and new features (GSC & Installers) work fine :-)
I didn't have much time to test. Will make another run as possible.

EDIT: Just rebooted to linux and tested live preview, it starts capturing some images and after some seconds it crashes too, so not an exclusive of
DMG version.

(PT) SC@ROS Observatory
TS 6" F4 Newtonian / Canon 550D / GPU CC / Datyson T7M / Arduino Moonlite DC Clone- HEQ5 Pro
Explore Scientific 80APO - 120ST / G2-8300FW5 / ES FF 2" / ASI120MM - Arduino Moonlite DC Clone - Vixen GPD2
www.flickr.com/photos/139335144@N03/
Attachments:
The topic has been locked.
3 years 5 months ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2264
Karma: 22
More
Ekos on Mac OS X ? #14144
Yeah the live video function is brand new. Jasem was working on that. It crashes with my asi after about 10s of video streaming if I use the asi remotely trying to stream video to my mac, but not if I try to run the live video from the asi to kstars running on the pi itself. So I think at least my crash might be a network speed issue.
The topic has been locked.
3 years 5 months ago
knro
Administrator
Administrator
Posts: 8089
Karma: 51
Ekos on Mac OS X ? #14146
It is a network speed issue. What happen is that remote INDI server is generating more frames than it can transmit over the network leading to congestion.. when this congestion to the client reaches the now-default value of 128MB, the server terminates. One way to deal with this is to use the "Rate Divisor" property in streaming which was designed for this purpose. Set it to 5 or 10 to "slow" down the generation of frames. Currently, there is no way in INDI to know if we're lagging behind frames, but I'll try to figure out a solution.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The topic has been locked.
3 years 5 months ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2264
Karma: 22
More
Ekos on Mac OS X ? #14150
That's what I suspected because it worked for a short time and then quit. If it was a software glitch, it would have happened sooner I think.
The topic has been locked.
Time to create page: 0.304 seconds