×

INDI Library v1.9.4 Released (17 Jan 2022)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

No any icon in the new build kstars

  • Posts: 94
  • Thank you received: 38
Yes, use kstars as a standalone application
6 years 10 months ago #3444

Please Log in or Create an account to join the conversation.

  • Posts: 173
  • Thank you received: 10
Would I be correct in assuming Kstars itself is not being upgraded but only in its bleeding version?. I`ve tried a few of the latest 15.04 distros and installing Kstars through their various package managers gives you 2.2, you have to manually install kstars-bleeding through a terminal?
Steve
6 years 10 months ago #3445

Please Log in or Create an account to join the conversation.

Correct.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
6 years 10 months ago #3452

Please Log in or Create an account to join the conversation.

  • Posts: 94
  • Thank you received: 38
Hi knro
I still can't make kstars display all the icon, please help.

Trying to make thing simple, I did the following :
1.debootstrap a clean ubuntu vivid with vncserver

2.install deps for building libindi
sudo apt-get install libnova-dev libcfitsio3-dev libusb-1.0-0-dev zlib1g-dev subversion libgsl0-dev build-essential cmake git libjpeg-dev

3.check out code of indi and build and install

4.install deps for building kstars
sudo apt-get install cmake extra-cmake-modules kdoctools-dev kinit-dev kio-dev libkf5config-dev libkf5parts-dev libkf5dbusaddons-dev libkf5guiaddons-dev libkf5i18n-dev libkf5jobwidgets-dev libkf5newstuff-dev libkf5notifications-dev libkf5texteditor-dev libkf5windowsystem-dev libkf5xmlgui-dev libkf5plotting-dev libkf5iconthemes-dev pkg-kde-tools plasma-framework-dev qtbase5-dev qtscript5-dev qtdeclarative5-dev qtmultimedia5-dev libqt5svg5-dev libqt5opengl5-dev libeigen3-dev zlib1g-dev libcfitsio3-dev libglu1-mesa-dev libnova-dev pkg-config wcslib-dev xplanet libkf5parts-dev

5.checkout code of kstars ,build and install kstars

6.run kstars from vnc display no icon

7.install oxygen icon theme and run kstars, display only part of the icon, but most of it still missing.


8.install kubuntu desktop

9,run dolphin from vnc and it display all icon


so this is maybe an issue of kstars. I try to do this in my PC and ARM board, same result.

For running kstars from VNC, I trying to build a ARM linux system to run on ARM mini pc ,like ODROID C1
in this way, I don't need the computer when go out for capturing image and save so much weight and power
I can even use battery for all of my gear.
6 years 10 months ago #3478
Attachments:

Please Log in or Create an account to join the conversation.

btw, I just checked the PPA and there is armhf version of KStars-bleeding for Ubuntu vivid. Can you install the PPA the regular way and see?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
6 years 10 months ago #3481

Please Log in or Create an account to join the conversation.

  • Posts: 94
  • Thank you received: 38
I'm not able to install kstars-bleeding because of the deps.
kstars-bleeding -> indi-full -> indi-fishcamp, there is no indi-fishcamp in PPA
even there is libfishcamp and indi_fishcamp_ccd in my system.
6 years 10 months ago #3482

Please Log in or Create an account to join the conversation.

yeah I'm working on that now
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
6 years 10 months ago #3483

Please Log in or Create an account to join the conversation.

  • Posts: 94
  • Thank you received: 38
Hi knro

I install kstars-bleeding from PPA, but same happen



What I did just debootstrap a clean ubuntu vivid with vnc, add PPA and install kstars-bleeding and run it from VNC

Not only ARM version, but also PC show the same result.
Last edit: 6 years 10 months ago by max.
6 years 10 months ago #3495
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 94
  • Thank you received: 38
Is this because missing some deps ?
6 years 10 months ago #3537

Please Log in or Create an account to join the conversation.

  • Posts: 94
  • Thank you received: 38
Problem solved by setting :
QT_QPA_PLATFORMTHEME=kde
The following user(s) said Thank You: Jasem Mutlaq, pauledd, Piero, Eric
6 years 10 months ago #3597

Please Log in or Create an account to join the conversation.

  • Posts: 314
  • Thank you received: 34

Thank you, that (and installing the QT4/KDE4-part of oxygen icons under gentoo*) helped. I can see all Icons now.

* kde-base/kdebase-desktoptheme-4.14.3,kde-base/oxygen-icons-4.14.3
--= human, without Windows™ =--
pls excuse my bad english! :)
The following user(s) said Thank You: Piero, Eric
Last edit: 6 years 10 months ago by pauledd. Reason: addition
6 years 10 months ago #3620

Please Log in or Create an account to join the conversation.

  • Posts: 32
  • Thank you received: 4
Did you really get this fixed?
Today I have installed kstars-bleeding from PPA, i386
They oxygen-icons package is not installed as dependence. I need to install the oxygen package manually to see the icons.
3 years 10 months ago #23688

Please Log in or Create an account to join the conversation.

Time to create page: 1.184 seconds