×

INDI Library v1.9.0 Released (23 Apr 2021)

Major INDI Library release v1.9.0 bring significant internal changes championed by @pawel-soja to modernize core INDI Library drivers and clients. New drivers for DeepSkyDad Flat Panel & Pegasus devices plus further improvements to PCM8 drivers.

ZWO 8 Position Filter Wheel - *SOLVED*

  • Posts: 19
  • Thank you received: 1
Just wondering why I am unable to assign filters to slots 6-8 on my ZWO 8 position filter wheel? I am running K-Stars/Ekos on Astroberry and only have the option for 5 slots on the filter wheel, despite it being an 8 position wheel, and being able to move through all eight positions.




Jim
Last edit: 1 year 2 months ago by NewfieStargazer.
1 year 2 months ago #50394
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 1112
  • Thank you received: 171
Not sure. I also have the ASI 8 position filter wheel and all positions are detected correctly.
Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
1 year 2 months ago #50405

Please Log in or Create an account to join the conversation.

  • Posts: 518
  • Thank you received: 133
I have seen a case where someone previously had the 5 position wheel installed, and then installed the 8, and the 5 driver stuck. There's some thing you can do to reset the driver, but I don't remember what it is. That was how they fixed the issue.
-Andrew
––––––––––
Mac Observatory - All about using the Mac for Astrophotography: www.macobservatory.com
Astrobin: www.astrobin.com/users/Lead_Weight/
The following user(s) said Thank You: pug916
1 year 2 months ago #50406

Please Log in or Create an account to join the conversation.

  • Posts: 227
  • Thank you received: 29

Replied by gilesco on topic ZWO 8 Position Filter Wheel


I imagine locating the EFW .xml files in your ~/.indi folder and deleting or moving it to another location then restarting INDI would probably reset the configuration, you'll have to re-assign your filter names after doing that though.
__
I blog my progress: www.coochey.net
1 year 2 months ago #50416

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 1
*SOLVED*

I deleted the "ASI EFW_config.xml" and "ASI EFW_config.xml.default" files and then restarted K-Stars and this solved the issue.

Jim
The following user(s) said Thank You: pug916
1 year 2 months ago #50419

Please Log in or Create an account to join the conversation.

  • Posts: 54
  • Thank you received: 12

Replied by jnowat on topic ZWO 8 Position Filter Wheel

While I'm happy for you that you've solved it, I did want to chime in to mention that the error is still present as of version 1.7 of indi_asi_efw, using KStars 3.4.2, latest Astroberry dist.

It's odd to me because restarting my remote Astroberry will sometimes bring up the 8pos efw plainly, but restarting later will revert back to the 5pos efw. What gives? If the 8pos efw is detected by EKOS, can it not signal to overwrite the old config file? May I ask for someone who is familiar with the code to explain why it sometimes chooses one and the rest of the time, the other? Trying to understand the workings behind both ekos/indi and my equipment drivers.

Cheers,

Jacob
Losmandy G11, Gemini II, 10" f/3.8 Newt (Ostahowski Optics),
TV Paracorr-2, 2" Starlight FT, HSM20, Pegasus UPBv2,
ASI1600MM Pro, ASI174MM Mini, ZWO LRGB, EFW, & OAG,
StellarMate on RPi3 and/or Astroberry on RPi4
KStars 3.4.1 Build 2020-02-24T07:38:50Z on Win10 (updated 20200506)
Indi ver....
11 months 1 week ago #54864
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.573 seconds