´╗┐
×

INDI Library v1.9.1 Released (26 Jun 2021)

Bi-monthly INDI Library v1.9.1 is released bringing a few new drivers and improvements to existing drivers.

Scheduled refocus failing

  • Posts: 56
  • Thank you received: 2
Hello !

I recently updated kstars to the latest version (Build: 2020-02-23T18:06:07Z) in order to get the new features (the new focus algorithm is great!! Thanks!).

However, since then, I am experiencing issues when a scheduled refocus is triggered.
The issue is present for all scheduled refocus (but the filter change focus still works like a charm).

I attach the logs in this post. Here is what happens:

1. After some images are captured, a scheduled refocus is triggered:
<code>[2020-03-28T20:44:02.838 CET INFO ][ org.kde.kstars.ekos.capture] - "Scheduled refocus starting after 1821 seconds..."
[2020-03-28T20:44:02.840 CET DEBG ][ org.kde.kstars.ekos.focus] - Frame is reset. X: 0 Y: 0 W: 3354 H: 2529 binX: 1 binY: 1
[2020-03-28T20:44:02.841 CET DEBG ][ org.kde.kstars.ekos.capture] - Capture is triggering autofocus on line 1904.
[2020-03-28T20:44:02.841 CET DEBG ][ org.kde.kstars.ekos.focus] - Check Focus requested with minimum required HFR 0.1
[2020-03-28T20:44:02.842 CET INFO ][ org.kde.kstars.ekos.focus] - "Capturing image..."</code>

I am a bit surprised the log says bin1, although bin2 is selected in the focus module. Also note I did not specify a minimum HFR.

2. An image is being taken by the camera, but guiding was not paused!
<code>[2020-03-28T20:44:06.233 CET DEBG ][ org.kde.kstars.ekos.guide] - PHD2: event: "{\"Event\":\"GuideStep\",\"Timestamp\":1585424646.232,\"Host\":\"florian-U36SD\",\"Inst\":1,\"Frame\":481,\"Time\":1804.307,\"Mount\":\"On Camera\",\"dx\":0.644,\"dy\":-0.172,\"RADistanceRaw\":0.658,\"DECDistanceRaw\":-0.032,\"RADistanceGuide\":0.428,\"DECDistanceGuide\":0.000,\"RADuration\":97,\"RADirection\":\"West\",\"StarMass\":5160,\"SNR\":32.52,\"HFD\":3.07,\"AvgDist\":0.52}\r\n"
[2020-03-28T20:44:06.258 CET DEBG ][ org.kde.kstars.ekos.guide] - PHD2: request: "{\"id\":474,\"jsonrpc\":\"2.0\",\"method\":\"get_lock_position\"}"</code>

3. The image is downloaded:
<code>[2020-03-28T20:44:08.005 CET DEBG ][ org.kde.kstars.indi] - Atik 383L : "[DEBUG] Uploading file. Ext: fits, Size: 4248000, sendImage? Yes, saveImage? No "
[2020-03-28T20:44:08.168 CET DEBG ][ org.kde.kstars.indi] - USBFocusV3 : "[DEBUG] CMD: FPOSRO. "
[2020-03-28T20:44:08.262 CET DEBG ][ org.kde.kstars.indi] - Atik 383L : "[DEBUG] BLOB transfer took 0.231732 seconds "
[2020-03-28T20:44:08.266 CET DEBG ][ org.kde.kstars.indi] - Atik 383L : "[DEBUG] Upload complete "

[2020-03-28T20:44:08.774 CET INFO ][ org.kde.kstars.fits] - Reading FITS file buffer
[2020-03-28T20:44:08.858 CET INFO ][ org.kde.kstars.ekos.focus] - "Image received."
[2020-03-28T20:44:08.868 CET DEBG ][ org.kde.kstars.ekos.focus] - Focus newFITS # 1 : Current HFR 1.08186 Num stars 2</code>

4. Nothing happens. Guiding is still on-going, the scheduler still waits for the focus to finish.
After a few minutes, I decide to click the Autofocus button in the focus module.
This time, the focus procedure is working fine, guiding is paused, focus is done, and sequence is resumed:

<code>[2020-03-28T20:46:46.176 CET DEBG ][ org.kde.kstars.ekos.focus] - Starting focus with box size: 208 Subframe: no Autostar: yes Full frame: no [ 0 %, 100 %] Step Size: 150 Threshold: 150 Tolerance: 5 Frames: 1 Maximum Travel: 50000
[2020-03-28T20:46:46.176 CET INFO ][ org.kde.kstars.ekos.focus] - "Autofocus in progress..."
[2020-03-28T20:46:46.177 CET DEBG ][ org.kde.kstars.ekos.guide] - PHD2: request: "{\"id\":517,\"jsonrpc\":\"2.0\",\"method\":\"set_paused\",\"params\":[true,\"full\"]}"
[2020-03-28T20:46:46.177 CET DEBG ][ org.kde.kstars.ekos.focus] - State: "In Progress"
[2020-03-28T20:46:46.177 CET DEBG ][ org.kde.kstars.ekos.capture] - setFocusStatus: 5
[2020-03-28T20:46:46.177 CET INFO ][ org.kde.kstars.ekos.focus] - "Capturing image..."
[2020-03-28T20:46:46.178 CET DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[DEBUG] RES: <W> "
[2020-03-28T20:46:46.211 CET DEBG ][ org.kde.kstars.ekos.guide] - PHD2: event: "{\"Event\":\"Paused\",\"Timestamp\":1585424806.211,\"Host\":\"florian-U36SD\",\"Inst\":1}\r\n"
[2020-03-28T20:46:46.212 CET INFO ][ org.kde.kstars.ekos.guide] - "PHD2: Guiding Paused."
[2020-03-28T20:46:46.212 CET DEBG ][ org.kde.kstars.ekos.capture] - Guiding state changed from "Guiding" to "Suspended"
[2020-03-28T20:46:46.213 CET INFO ][ org.kde.kstars.ekos.guide] - "Guiding suspended."
[2020-03-28T20:46:46.215 CET DEBG ][ org.kde.kstars.ekos.guide] - PHD2: response: "{\"jsonrpc\":\"2.0\",\"result\":0,\"id\":517}\r\n"</code>

The issue occurs for all scheduled refocus, tested on 2 different nights. There must be a regression here.

Could you please have a look?

Thank you!
Clear skies
Florian
Last edit: 1 year 4 months ago by Florian Signoret.
1 year 4 months ago #51357
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 1936
  • Thank you received: 414
I have experienced scheduled refocus issues as well lately. In my case the last focus image of the PREVIOUS refocus was used for all focus images, leading to a flat curve all with exactly the same number of stars and HFR values. But the focuser moves so after the auto-focus fails, imaging is resumed with an out-of-focus camera. During focusing, guiding is suspended but the guide cam keeps on taking pics. Not sure if that is the expected behavior.

Here are the logs from a few weeks ago. Note for instance the last values of the second refocus attempt and all values of the third.


Wouter
Wouter van Reeven

ASI6200MM and 7 slot 2" filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and 5 slot 1.25" filter wheel with an 8" TS Ritchey-Chr├ętien on a SkyWatcher EQ6-R
Last edit: 1 year 4 months ago by Wouter van Reeven.
1 year 4 months ago #51358
Attachments:

Please Log in or Create an account to join the conversation.

Thank you for the report. This issue is now fixed in GIT.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Florian Signoret, Wouter van Reeven
1 year 4 months ago #51403

Please Log in or Create an account to join the conversation.

  • Posts: 56
  • Thank you received: 2
Thank you!
When is the next maintenance delivery scheduled?
Clear skies,
Florian
1 year 4 months ago #51413

Please Log in or Create an account to join the conversation.

Time to create page: 0.426 seconds