×

INDI Library v1.9.8 Released (Yesterday)

Bi-monthly INDI Library released with new drivers and bug fixes.

Guiding problem using EKOS

  • Posts: 55
  • Thank you received: 2

Replied by Dirk on topic Guiding problem using EKOS

Hello Ralf,
You write you are using an ST4 cable. What are you using in the guiding tab under via: the camera or the mount, for ST4 you would need the camera...


Regards

Dirk
iOptron CEM25P
Skywatcher Evostar 72 ED DSPro
Explore Scientific ED 102
ASI 1600Mm Pro ASI EFW Mini
QHY 8L
DeepSky Dad AF1 motor focus
ASI 120MM Mini and Bresser (Touptek) 290 Guidecams
Sykwatch EvoGuide 50/242 and NoName 50/175 Guidescopes
Raspberry Pi 3 and 4
2 years 5 months ago #52169

Please Log in or Create an account to join the conversation.

  • Posts: 23
  • Thank you received: 0
Hi Dirk,

thanks for your reply. Honestly, I don't know, never looked at that part. Need to check that and will come back to this thread.

Ralf.
Last edit: 2 years 5 months ago by Ralf Karpa.
2 years 5 months ago #52176

Please Log in or Create an account to join the conversation.

  • Posts: 23
  • Thank you received: 0
I checked the settings and the guiding setup is via ZWO camera.
2 years 5 months ago #52259

Please Log in or Create an account to join the conversation.

  • Posts: 23
  • Thank you received: 0
Dears,

I must apologize... When I looked today in the late afternoon, the default guiding was set to the ZWO camera. Now, once I started my session and connected all my stuff, the "via" setting was on the Celestron. I switched it to camera and within seconds eKOS reported that it started guiding.

Thanks for the hint. Seems to work now...

Ralf.
2 years 5 months ago #52275

Please Log in or Create an account to join the conversation.

  • Posts: 147
  • Thank you received: 28
Hi all just to add to the guiding issue, i have not had much luck with the internal guider on my RPi4 over the last few nights ever since the last update (3.4.2). See attached logs.

When i use phd2, i have no issues. See attached log from phd2.

Initially i though the problem was with my mount, so i adjusted my mount to eliminate backlash. Polar alignment was within within 12" of the south celestial pole. The weather was fine (no wind), no cable snags, everything was balanced and mount clutches tight.

But the internal guider just did not want to cooperate. I also tested with my Asus tinker board which was last updated on 2/1/2020 and the internal guider works perfectly.

So something has changed in the internal guider.

regards
Takahashi FC-100DF refractor
ZWO ASI 071 imaging camera
ZWO ASI 224MC on 50mm guidescope
HEQ5 Pro mount
Raspberry Pi 4 running KStars/indi
Last edit: 2 years 5 months ago by Petar Milevski. Reason: spelling
2 years 5 months ago #52422

Please Log in or Create an account to join the conversation.

Any special settings for RA in PHD2? It appears that you might need more proportional gain for RA? Perhaps decrease minimal pulse to 50 instead of 100?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 years 5 months ago #52429

Please Log in or Create an account to join the conversation.

  • Posts: 826
  • Thank you received: 139

Replied by Alfred on topic Guiding problem using EKOS

The internal guider graph looks like the RA pulses never reached the mount. Are you guiding via ST4 or mount? The log tells us Ekos sends correction pulses of >1s in RA (which is huge) yet no reaction in the guide graph at all. Clearly this is not what one would expect! [BTW, have guide graph and log file been taken at the same time? It would be helpful if we could see the correction pulses in the guide graph, too.] It's not a PA issue. Did the internal guider calibrate OK? Did you watch it calibrate?
Last edit: 2 years 5 months ago by Alfred.
2 years 5 months ago #52435

Please Log in or Create an account to join the conversation.

  • Posts: 147
  • Thank you received: 28
Hi krno and Herrhausen, thanks for your fast responses.

I using eqmod pulse guiding method, not ST4. I have not used ST4 cable from guide camera to mount for a long time.

The graphs were taken one after the other. I first ran phd2 (using its default settings), guidered for a while until everything was stable. I then disconnected phd2 and reinstated the internal guider and did the same. I did not move the mount, it was still pointing at the same target and the time from disconnection of phd2 and re-connection to internal guiding was only 20 or seconds. I have now plotted the pulse below the error correction and Herrhausen is correct; the mount is not receiving the RA connection pulses for some reason. See attachment.

How can one use phd2 and internal guider logging at the same time? As you suggest this will be the best way to log what is going on?

regards
Takahashi FC-100DF refractor
ZWO ASI 071 imaging camera
ZWO ASI 224MC on 50mm guidescope
HEQ5 Pro mount
Raspberry Pi 4 running KStars/indi
2 years 5 months ago #52477
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 881
  • Thank you received: 419
Out of curiosity, which guide star-detection algorithm are you using?
AP1100 & Orion Atlas Pro, WO/ZS105 w/Moonlight V2 focus, GSO RC10 w/RSF focus
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Greedy Scheduler, Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
2 years 5 months ago #52486

Please Log in or Create an account to join the conversation.

  • Posts: 147
  • Thank you received: 28
hi hy,

Im using the default ekos logarithm, Smart. I have also tried SEP as well with the same results. I have also tried the other 3 with no luck.

regards
Takahashi FC-100DF refractor
ZWO ASI 071 imaging camera
ZWO ASI 224MC on 50mm guidescope
HEQ5 Pro mount
Raspberry Pi 4 running KStars/indi
2 years 5 months ago #52487
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 147
  • Thank you received: 28
Hi all so after the issues with RPi4 guiding (and wifi eqmod connection) I uninstalled everything and did a fresh install. I tested eqmod wifi and it now connects. I have not had a chance to test the guider due to weather, but i have a funny feeling it will now work.

Correct me if I'm wrong (I'm no Linux expert), but to update my Rpi4 (and tinker board), all i do:

sudo apt update && sudo apt upgrade

Is this the correct way to keep my system up to date with the stable INDI releases?

regards
Takahashi FC-100DF refractor
ZWO ASI 071 imaging camera
ZWO ASI 224MC on 50mm guidescope
HEQ5 Pro mount
Raspberry Pi 4 running KStars/indi
2 years 5 months ago #52769

Please Log in or Create an account to join the conversation.

  • Posts: 384
  • Thank you received: 95
In the guide tab in Ekos, make sure you select "EQMod" next to "Via" and not your guide camera. Selecting your guide camera will attempt to send the guiding corrections via the ST4 port, but as you said, you have nothing plugged in there. Hence, no guide pulses will reach the mount!

2 years 5 months ago #52905
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.604 seconds