×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Pentak K30 anyone have any luck getting it working?

2 months 2 weeks ago
lennyk
Fresh Boarder
Fresh Boarder
Posts: 18
More
Topic Author
Pentak K30 anyone have any luck getting it working? #54484
Hey Folks,
I know there has been a lot of posts around getting Pentax to work with EKOS and there has been huge work put into it and there has been a lot of success. I was wondering if anyone has manged to get their Pentax K30 to shoot in bulb mode? I am able to connect to my camera in msc mode and it detects it beautifully , How ever if i have my camera in bulb mode and force bulb mode option is enabled I cannot take a test shot, it dosent even fire regardless of the bulb setting I choose on the camera. Either press and hold or press once and press again to release. IF i disable force bulb mode and try to take an exposure of a couple of seconds the camera will fire off a shot but not for the required time only for 1/120 of a second or faster. I know some of the K family of cameras have some issues with bulb mode control, but it seems like we are very close to getting an actual working solution for these models.
So i was wondering if anyone out there had had any luck getting there K30 to work?

Thanks for reading.
Lenny

Please Log in or Create an account to join the conversation.

2 months 2 weeks ago
knro
Administrator
Administrator
Posts: 8205
Karma: 51
Pentak K30 anyone have any luck getting it working? #54485
Try it with the new dedicated INDI Pentax driver.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

2 months 2 weeks ago
lennyk
Fresh Boarder
Fresh Boarder
Posts: 18
More
Topic Author
Pentak K30 anyone have any luck getting it working? #54491
Thanks Jasem! I will update and give it another go and report back.

Please Log in or Create an account to join the conversation.

2 months 2 weeks ago
lennyk
Fresh Boarder
Fresh Boarder
Posts: 18
More
Topic Author
Pentak K30 anyone have any luck getting it working? #54616

File Attachment:

File Name: log_19-06-56.txt
File Size:310 KB


Hi Jasem,
I tried my Pentax again and I have attached the log file, this is probably a question for whoever wrote the driver. The camera would not trigger the shutter if i set the time greater than 30 seconds, if the time was less tha 30 seconds the shutter would fire and close instantly, this would only happen if i had force bulb disabled, if it was enabled nothing would happen. When i changed the bulb mode to 2 i.e once to open once to close the shutter would only fire when force bulb was disabled and time was less than 30 seconds. Also i had to manually press the shutter a second time in order to get it to stop and down load exposure. Maybe this could be a way foreward?

Hope this helps or can be used to get it working on this model. Feels like its so close :)

Thanks,
Lenny.
Attachments:

Please Log in or Create an account to join the conversation.

2 months 2 weeks ago
knro
Administrator
Administrator
Posts: 8205
Karma: 51
Pentak K30 anyone have any luck getting it working? #54683
You're using INDI GPhoto driver still, there is a new driver INDI Pentax NATIVE should be available in nightly releaeses.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

2 months 2 weeks ago
lennyk
Fresh Boarder
Fresh Boarder
Posts: 18
More
Topic Author
Pentak K30 anyone have any luck getting it working? #54688
Im sorry Jasem I thought this was the native driver? This is what I was using. Are you saying there is another driver i need to download?
Attachments:

Please Log in or Create an account to join the conversation.

2 months 1 week ago
karlrees
Junior Boarder
Junior Boarder
Posts: 30
Karma: 1
More
Pentak K30 anyone have any luck getting it working? #54951
Lenny,

I'm responsible for the new Pentax driver. As far as I know, there hasn't been a ton of testing yet (beyond me and my K70), and I'd be really interested in finding out how it performs with other cameras. Sorry for the late response. I don't poke my head around here very often.

From the logs, it does not appear that you are using the new driver yet. The logs show you using indi_pentax_ccd, which is the Gphoto-based driver, whereas the new/native driver would show simply indi_pentax.

If you've downloaded and installed the nightlies, when you are selecting the driver in Ekos, you should see an option for "Pentax DSLR (Native)." I've attached a screenshot. Let me know if that helps. I'll subscribe to the thread so I can respond more quickly if you have any questions.

Karl

Attachments:

Please Log in or Create an account to join the conversation.

2 months 1 week ago
lennyk
Fresh Boarder
Fresh Boarder
Posts: 18
More
Topic Author
Pentak K30 anyone have any luck getting it working? #54954
Thanks Karl, This would wear I went wrong I didn't download the nightlies! I am going to test this now as I am a huge fan of my Pentax but gave up using it for astronomy due to the lack of tethering.

Please Log in or Create an account to join the conversation.

2 months 1 week ago
lennyk
Fresh Boarder
Fresh Boarder
Posts: 18
More
Topic Author
Pentak K30 anyone have any luck getting it working? #54958
Karl/Jasem,
I have updated the nightlys build but I dont see any Pentax Native available to use. Is there something I am missing or failing to do?

Thanks,
Lenny.
Attachments:

Please Log in or Create an account to join the conversation.

2 months 1 week ago 2 months 1 week ago by wvreeven.
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1576
Karma: 8
More
Pentak K30 anyone have any luck getting it working? #54961
Putting back the text (more or less) since I was right after all:

It looks like the indi-3rdparty packages are not building and they haven't been building for a week at least now. For instance, I updated my nightly installation on Ubuntu 20.04 just now and the indi-asi package is
$> dpkg -l \*indi-asi\*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version                        Architecture Description
+++-==============-==============================-============-======================================
ii  indi-asi       1.7~202005291515~ubuntu20.04.1 amd64        INDI Driver for ZWO Optics ASI cameras

while the libasi package is
$> dpkg -l \*libasi\*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version                        Architecture Description
+++-==============-==============================-============-======================================================
ii  libasi         1.4~202004262330~ubuntu20.04.1 amd64        Library for ASI Cameras, Filter Wheel, Focuser and ST4

and I know for a fact that it should be newer since I pushed code for that last week which has been accepted into GitHub.

ASI6200 and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R

Please Log in or Create an account to join the conversation.

2 months 1 week ago
karlrees
Junior Boarder
Junior Boarder
Posts: 30
Karma: 1
More
Pentak K30 anyone have any luck getting it working? #54968
I don't think this has anything to do with the indi-3rdparty packages not building.

Just from a quick test, I think this is an incompatibility problem between the driver or the package and Ubuntu Mate. Ubuntu Mate *thinks* the indi-pentax package is installed, but the indi_pentax executable never ends up in the /usr/bin folder.

I don't think Raspbian or Ubuntu x86 have the same problem. I'll have to double-check with a clean install to make sure.

I wonder if this has something to do with the armv6-armv7 compatibility problems with the Ricoh SDK I was having when compiling on Ubuntu Mate. But, my recollection is that I still at least was able to compile, so I'm not sure why Indi_pentax isn't getting installed. I'll dig into it some more over the next few days.

Please Log in or Create an account to join the conversation.

2 months 1 week ago
knro
Administrator
Administrator
Posts: 8205
Karma: 51
Pentak K30 anyone have any luck getting it working? #54970
There was one missing file in the debian directory which I just added and pushed, so it should be fixed in the next nightly.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

Time to create page: 0.459 seconds