×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Focus Module crashes quite often with Canon DSLR and other (small) issues

1 month 1 week ago
luggiduggi
Fresh Boarder
Fresh Boarder
Posts: 16
Karma: 1
More
Topic Author
Focus Module crashes quite often with Canon DSLR and other (small) issues #56079
Hi,
I am quite new to Ekos since I am just now upgrading to operating my telescope (mostly home build or modified) with a Raspi and Ekos.
I have two issues that I need some help with.
1. the focuser module keeps crashing - in particular when I am klicking on a star to get its HFR. This happens sometimes as soon as I click, sometimes when it tries to get an exposure for the subframe. It sometimes announces the upcoming crash by strange behavior - e.g. you click but the green box does not appear. This is really hindering my picture taking and is frustrating because sometimes it works, but not stable.
2. It might be that the next problem is sitting in front of the screen, but I would like to monitor the focus during picture taking with the capture module. It seems like this is possible (by reading the manual), but I cannot get my hands around how to make it work. My workflow is to complete an autofocus cycle (autofocus completes successfully and the dots show up in the v-curve window). Then I move over to the capture module and start my capture sequence. If I go to the focus module during the running capture sequence, I still see the dots from the autofocus operation before. I expected to see dots now, representing the HFR of my selected star for the subsequent captures. This way, I could monitor focus drift...
3. less of a problem, but curious anyways: I would expect for the last captured image to show up on the Ekos summary tab (the one with the wrench symbol). It shows the guiding info from PHD2 correctly, the autofocus info is frozen from the last autofocus HFR (but visible), but the picture area is "blank", meaning I only see the default "no parking at the horsehead nebular" picure of Ekos. This seems strange to me.
If anybody can help, I would really appreciate it.

My equipment:
Raspberry Pi 4 with Kstars, Ekos and guiding through PHD2
Canon DSLR (760d) with INDI Canon driver
Arduino controlled focuser using the INDI moonlite driver
Guinding with separate scope and ASI120MC-S ad INDI ZWO ASI driver
PS: This weekend, I will try to replicate it at home to make testing during the day possible.

Please Log in or Create an account to join the conversation.

1 month 1 week ago
sterne-jaeger
Platinum Boarder
Platinum Boarder
Posts: 593
Karma: 6
More
Focus Module crashes quite often with Canon DSLR and other (small) issues #56095
Regarding 1., we need your logs. See here for an instruction.

#2 is a very good idea, but that's not the case currently.

#3 can be activated in the Ekos options EKOS > Capture > Summary Screen preview

HTH
Wolfgang

TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro + ASI 294mc pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10

Please Log in or Create an account to join the conversation.

1 month 1 week ago
luggiduggi
Fresh Boarder
Fresh Boarder
Posts: 16
Karma: 1
More
Topic Author
Focus Module crashes quite often with Canon DSLR and other (small) issues #56187
Hello Wolfgang,
thanks for geting back to me. I am sorry, I couldn´t write earlier but I was out this weekend.
I have now prepared a log file of a crash that I was recreating. Attached to the raspberry were my focuser (arduino based, listenes to moonlite protocol) and my Canon.
Attached is the log file.
Thanks for your efforts!
Best regards
Stephan

File Attachment:

File Name: log_22-27-...t.tar.gz
File Size:27 KB
Attachments:

Please Log in or Create an account to join the conversation.

1 month 1 week ago
luggiduggi
Fresh Boarder
Fresh Boarder
Posts: 16
Karma: 1
More
Topic Author
Focus Module crashes quite often with Canon DSLR and other (small) issues #56269
Hi,
I still need help with these focus module crashes. I played around and was able to recreate the crashes with
a) ZWO camera instead of Canon
b) with ZWO and focus simulator instead of moonlite focusser
So I would conclude it is not the Canon driver and not the moonlite driver. I have attached both logs below in a tar ball.
Could it be the installation on my raspberry 4?
Help would really be appreciated!
Best regards
Stephan

File Attachment:

File Name: logs.txt.tar.gz
File Size:15 KB
Attachments:

Please Log in or Create an account to join the conversation.

1 month 1 week ago
luggiduggi
Fresh Boarder
Fresh Boarder
Posts: 16
Karma: 1
More
Topic Author
Focus Module crashes quite often with Canon DSLR and other (small) issues #56276
I just set up a Virtual Box on my laptop running the Raspbian OS and kstars. With the same combination of ZWO and Focus Simulator that crashed before, I wasn´t able to create a crash. So it seems, it has to do with Kstars/Ekos running on Raspberry Pi Hardware. I am, therefore, officially out of ideas... Need your help.
Best regards
Stephan

Please Log in or Create an account to join the conversation.

1 month 1 week ago
sterne-jaeger
Platinum Boarder
Platinum Boarder
Posts: 593
Karma: 6
More
Focus Module crashes quite often with Canon DSLR and other (small) issues #56282
In both cases there is an assertion failure in the code:
[2020-06-30T17:47:31.956 CEST FATL ][                       default] - ASSERT failure in analyzeSources: "Tracking box is disabled when detecting in full-field", file /home/astroberry/DEV/BUILD/kstars/kstars/kstars/ekos/focus/focus.cpp, line 1061

But maybe the more interesting warning is this:
[2020-06-30T17:43:31.500 CEST INFO ][           org.kde.kstars.indi] - ZWO CCD ASI120MC-S :  "[WARNING] Telescope focal length is missing. "
[2020-06-30T17:43:31.503 CEST INFO ][           org.kde.kstars.indi] - ZWO CCD ASI120MC-S :  "[WARNING] Telescope aperture is missing. "

It seems like there is no telescope driver running. Are you holding your scope in your bare hands? :-)

Add at least the telescope simulator as scope and try again.

HTH and greetings from Schwäbisch Hall to Munich
Wolfgang

TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro + ASI 294mc pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10

Please Log in or Create an account to join the conversation.

1 month 1 week ago
luggiduggi
Fresh Boarder
Fresh Boarder
Posts: 16
Karma: 1
More
Topic Author
Focus Module crashes quite often with Canon DSLR and other (small) issues #56285
Hello Wolfgang,
for the tests, I didn´t hold my telescope in my bare hands :-) , but it was indeed in its box. I just hooked up what I thought was needed. I don´t think this is the right clue, however, because I noticed the crashes when I first used it under the stars - telescope and all hooked up.
Anyhow, I will test it right away - just to make sure. Thanks for your help and for looking into this.
Greetings back to Schwäbisch-Hall (where I was just two weeks ago)
Stephan

Please Log in or Create an account to join the conversation.

1 month 1 week ago
luggiduggi
Fresh Boarder
Fresh Boarder
Posts: 16
Karma: 1
More
Topic Author
Focus Module crashes quite often with Canon DSLR and other (small) issues #56287
Hello Wolfgang,
as I suspected, the telescope not being connected was not the culprit.
I now had the telescope simulator on and the same thing happened. Attached is the log from this latest case.

File Attachment:

File Name: log_21-27-...t.tar.gz
File Size:7 KB

Is there anything else, I can do to diagnose the issue? Run it in gdb or something?
Thanks
Stephan
Attachments:

Please Log in or Create an account to join the conversation.

1 month 1 week ago
sterne-jaeger
Platinum Boarder
Platinum Boarder
Posts: 593
Karma: 6
More
Focus Module crashes quite often with Canon DSLR and other (small) issues #56291
Hi Stephan,
OK, so the warning about missing scope parameters are not relevant. The last entry in the log is an assertion failure "Tracking box is disabled when detecting in full-field". I currently do not understand where this assertion comes from. Are you using full field mode and is "auto select star" selected?

TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro + ASI 294mc pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10

Please Log in or Create an account to join the conversation.

1 month 1 week ago
luggiduggi
Fresh Boarder
Fresh Boarder
Posts: 16
Karma: 1
More
Topic Author
Focus Module crashes quite often with Canon DSLR and other (small) issues #56296
Hi Wolfgang,
the path to (quite certain) crash is as follows:
1. Autostar is not selected, Sub Frame is selected
2. Capture image
3. Click in image (to select star - new sub frame is captured and displayed)
4. Select Full Field
5. Capture image
6. Klick on Zoom-to-Fit in image
7. Click in image (as to select different star)
At this point, it sometimes crashes already at this point, some other times, it crashes when you repeat steps 4-7
Cheers
Stephan

Please Log in or Create an account to join the conversation.

1 month 1 week ago
sterne-jaeger
Platinum Boarder
Platinum Boarder
Posts: 593
Karma: 6
More
Focus Module crashes quite often with Canon DSLR and other (small) issues #56297
Hi Stephan,
sorry, I cannot reproduce it, but I'm on the latest version. You could give a try to compile it from the sources: invent.kde.org/education/kstars

Wolfgang

TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro + ASI 294mc pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10

Please Log in or Create an account to join the conversation.

1 month 1 week ago
hy
Gold Boarder
Gold Boarder
Posts: 287
Karma: 3
More
Focus Module crashes quite often with Canon DSLR and other (small) issues #56302
Stephan,

Re your point #2 (getting the HFR of subs): This functionality is partially implemented right now. It is tied to fitsviewer. As I don't have a DSLR, I can't test it with one, but if you can get your images to come up with fitsviewer after capture, then go to the view menu, and select "Mark Stars". After some computation, you should see an HFR value on the bottom (status line) of the fitsviewer tab's window. All future captures will also compute the HFR and display it there too. You can inspect them that way. If you want a record of the HFRs of all your images, you can run your Ekos with logging set to: Verbosity: "verbose", Output: "file", EKOS: "FITS" (the logging menu is accessed by clicking "Logs" on the "Setup" tab), then the HFR values will be written to your logs and you can grep them out: e.g.

> egrep '(FITS HFR|file saved to)' log_00-27-53.txt
[2020-06-21T00:43:13.245 PDT INFO ][ org.kde.kstars.indi] - "FITS" file saved to "/home/pi/mydisk//Pelican/Light/Ha/Pelican_Light_Ha_480_secs_2020-06-21T00-43-13_054.fits"
[2020-06-21T00:51:16.911 PDT INFO ][ org.kde.kstars.indi] - "FITS" file saved to "/home/pi/mydisk//Pelican/Light/Ha/Pelican_Light_Ha_480_secs_2020-06-21T00-51-16_055.fits"
[2020-06-21T00:51:20.585 PDT DEBG ][ org.kde.kstars.fits] - FITS HFR: 2.13282
[2020-06-21T00:59:24.461 PDT INFO ][ org.kde.kstars.indi] - "FITS" file saved to "/home/pi/mydisk//Pelican/Light/Ha/Pelican_Light_Ha_480_secs_2020-06-21T00-59-24_056.fits"
[2020-06-21T00:59:28.142 PDT DEBG ][ org.kde.kstars.fits] - FITS HFR: 2.04297
[2020-06-21T01:07:32.299 PDT INFO ][ org.kde.kstars.indi] - "FITS" file saved to "/home/pi/mydisk//Pelican/Light/Ha/Pelican_Light_Ha_480_secs_2020-06-21T01-07-32_057.fits"
[2020-06-21T01:07:35.969 PDT DEBG ][ org.kde.kstars.fits] - FITS HFR: 1.99833
[2020-06-21T01:15:35.678 PDT INFO ][ org.kde.kstars.indi] - "FITS" file saved to "/home/pi/mydisk//Pelican/Light/Green/Pelican_Light_Green_240_secs_2020-06-21T01-15-35_032.fits"
[2020-06-21T01:15:39.410 PDT DEBG ][ org.kde.kstars.fits] - FITS HFR: 2.27915
[2020-06-21T01:19:43.799 PDT INFO ][ org.kde.kstars.indi] - "FITS" file saved to "/home/pi/mydisk//Pelican/Light/Green/Pelican_Light_Green_240_secs_2020-06-21T01-19-43_033.fits"
[2020-06-21T01:19:47.672 PDT DEBG ][ org.kde.kstars.fits] - FITS HFR: 2.25149

...

Obviously this is an inadequate user interface. On my list is a way to improve that, and I hope to get to that in the codebase in next month or two. I'm a fan of monitoring the HFR as well, and in fact use the technique I describe above regularly.

Hy

Please Log in or Create an account to join the conversation.

Time to create page: 0.308 seconds