×

INDI Library v1.9.0 Released (23 Apr 2021)

Major INDI Library release v1.9.0 bring significant internal changes championed by @pawel-soja to modernize core INDI Library drivers and clients. New drivers for DeepSkyDad Flat Panel & Pegasus devices plus further improvements to PCM8 drivers.

align fails to slew mount: latest git

  • Posts: 732
  • Thank you received: 197
It looks like there is an issue with EQMod. The first time in your log - when it went well - there are log entries from the pointing model of EQMdód:
[2020-06-30T22:25:09.202 CEST INFO ][           org.kde.kstars.indi] - EQMod Mount :  "[INFO] Align Pointset: added point 0 alt = 47.7436 az = 69.7723 "
[2020-06-30T22:25:09.203 CEST INFO ][           org.kde.kstars.indi] - EQMod Mount :  "[INFO] Align Triangulate: number of faces is 0 "
[2020-06-30T22:25:09.204 CEST INFO ][           org.kde.kstars.indi] - EQMod Mount :  "[INFO] Align Sync: point added: lst=15.01028029 celestial RA 18.70000000 DEC 39.90610000 Telescope RA 18.62786274 DEC 38.80300532 "
[2020-06-30T22:25:09.205 CEST DEBG ][           org.kde.kstars.indi] - EQMod Mount : "[ALIGNMENT] New sync point Date 2459031.350776 RA 18.700000 DEC 39.906100 TDV(x 0.455157 y 0.632573 z 0.626645) "
These entries are missing for the attempt later.
TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10
10 months 1 week ago #56308

Please Log in or Create an account to join the conversation.


My bad, this was my mistake. It's fixed now, please try again.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
10 months 1 week ago #56309

Please Log in or Create an account to join the conversation.

  • Posts: 683
  • Thank you received: 51

i did the same with the latest git but using INDI from the stable PPA.

The first session works fine. The issue occurs after a restart. The logs for the first session and the restart are posted here

Thanks
kubuntu 20.04
700d, eq6, t7m
10 months 1 week ago #56310

Please Log in or Create an account to join the conversation.

  • Posts: 683
  • Thank you received: 51

@jasem
Could you confirm what INDI version we need? e.g. is INDI from your stable PPA OK with the latest git?
TIA,
Steve
kubuntu 20.04
700d, eq6, t7m
10 months 1 week ago #56313

Please Log in or Create an account to join the conversation.

Issue was in KStars, not INDI.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: alacant, AxelM
10 months 1 week ago #56316

Please Log in or Create an account to join the conversation.

  • Posts: 683
  • Thank you received: 51
Ah, OK.
So we need only build the latest git and use it with the INDI from your ppa?
Cheers
kubuntu 20.04
700d, eq6, t7m
10 months 1 week ago #56320

Please Log in or Create an account to join the conversation.

  • Posts: 683
  • Thank you received: 51

Tried with latest fit. No change. Alignment works first time then fails.
Please see the log after 00:10 for the failed alignment.
TIA
log: drive.google.com/file/d/1fjoViSH_rq0Y33g...uD6/view?usp=sharing
kubuntu 20.04
700d, eq6, t7m
Last edit: 10 months 1 week ago by alacant.
10 months 1 week ago #56344

Please Log in or Create an account to join the conversation.

  • Posts: 525
  • Thank you received: 262
I have to say that I ran into a similar problem last night--I guess.
It failed to start slewing, but seemingly only to a target near the pole.
When I went to a different target, things seemed to work.
I had assumed something flakey in my setup, but now seeing this, seems too similar.
I was likely running almost the latest git code at the time (probably commit db1a8211)
so if the fix Jasem is talking about is 44681d5 (which is after the above), I was not running that.

Will post if I run into the issue again.
Hy
Orion Atlas Pro, William Optics ZS105, Moonlight V2 focuser
ZWO ASI1600, OAG & Filterwheel, Astronomik Filters, QHY 5L-IIm guidecam.
KStars/Ekos/Indi on RPi4 w/SSD
Ekos Projects: Terrain Backgrounds, Polar Alignment, Analyze, Linear Focuser, SEP MultiStar & GPG Guiding, FITS autostretch.
10 months 1 week ago #56348

Please Log in or Create an account to join the conversation.

  • Posts: 9
  • Thank you received: 2
I did one full night of imaging with the latest KStars from GitHub (commit 446481d5fb485ec6437c43bb6bcc1c5b76adedfd) and INDI 1.8.5 from the stable PPA. My EQ6-R mount slewed and aligned to four different targets without problems.
Axel
Ubuntu Mate 20.04 (arm64) on Raspberry Pi 4 (4 GB)
Vixen R200SS 8" f/4
EQ6-R Pro
ASI 1600MM Pro + EFW, Canon 6D

10 months 1 week ago #56360

Please Log in or Create an account to join the conversation.

  • Posts: 683
  • Thank you received: 51
Ok. Now disconnect the mount and reconnect. Alignment now fails:

drive.google.com/file/d/1fjoViSH_rq0Y33g...uD6/view?usp=sharing

I started a new thread;
indilib.org/forum/ekos/7279-align-does-n...rget-latest-git.html

Cheers,
Steve
kubuntu 20.04
700d, eq6, t7m
10 months 1 week ago #56362

Please Log in or Create an account to join the conversation.

Time to create page: 0.481 seconds