×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Remove and reinstall indi library and kstars

1 month 1 week ago
Kitama01
Fresh Boarder
Fresh Boarder
Posts: 10
More
Topic Author
Remove and reinstall indi library and kstars #56272
Hello!

I have some problems with my Ekos, in fact I can no longer see the "gain" option of the CCD Simulator. Therefore I want to remove indi libraries and kstars and reinstall them.

Is there a way to fix it without doing that?
If no, what commands should I write in the terminal of Ubuntu? (I had lots of problems in the first time when I installed them)

Thanks

Please Log in or Create an account to join the conversation.

1 month 1 week ago 1 month 1 week ago by El Corazon.
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 805
Karma: 3
More
Remove and reinstall indi library and kstars #56300
$ sudo apt purge [whatever you want to purge here]

itsfoss.com/apt-command-guide/

PS: What hardware platform are you using. Assuming Linux? RPi4?

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set

Please Log in or Create an account to join the conversation.

1 month 1 week ago
Kitama01
Fresh Boarder
Fresh Boarder
Posts: 10
More
Topic Author
Remove and reinstall indi library and kstars #56305
I'm using Linux on virtual machine (macos high Sierra)

Please Log in or Create an account to join the conversation.

1 month 1 week ago
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 805
Karma: 3
More
Remove and reinstall indi library and kstars #56321
I never used Kstars on a virtual machine, but Wouter (wvreeven) uses it on a Mac as well. He would be able to give more qualified advice.
Generally, I would suggest using an RPi4 running Ubuntu MATE 20.04. I have the best experience with that constellation. Painless since I went from Ubuntu 18.04 to 20.04. Run everything on the Pi4, control it via VNC from inside the house. Just works.

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set

Please Log in or Create an account to join the conversation.

1 month 1 week ago 1 month 1 week ago by wvreeven.
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1576
Karma: 8
More
Remove and reinstall indi library and kstars #56327
I used to run KStars on a VirtualBox VM on Mac about two years ago but really haven't since (apart from occasionally compiling KStars and INDI myself and even that I don't do in a VM anymore). Apart from removing all KStars and INDI libraries and binaries I'd advice you to also remove the .indi and .local/share/kstars directories since they hold all configuration for INDI and KStars respectively.

Having said that, why not simply install KStars for Mac and run it directly without a VM?


Wouter

ASI6200 and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R

Please Log in or Create an account to join the conversation.

1 month 1 week ago
hy
Gold Boarder
Gold Boarder
Posts: 287
Karma: 3
More
Remove and reinstall indi library and kstars #56335
I installed Indi/KStars on a Ubuntu 20.04 VM (VMware Fusion) on Mac OS Catalina a month or two ago.
According to my notes, this is what I did, starting from a pretty fresh 20.04 Ubuntu installation:

sudo apt-add-repository ppa:mutlaqja/ppa -y
sudo apt update
sudo apt -y install indi-full
sudo apt -y install indi-full kstars-bleeding
sudo apt -y install kstars-bleeding-dbg indi-dbg

sudo apt -y install gsc
sudo apt -y install astrometry.net
sudo apt-add-repository ppa:pch/phd2 -y
sudo apt update
sudo apt -y install phd2
sudo apt install phdlogview
Saved the machine →

Then there's the usually setup of KStars.

Please Log in or Create an account to join the conversation.

1 month 1 week ago
wotalota
Gold Boarder
Gold Boarder
Posts: 176
More
Remove and reinstall indi library and kstars #56363
Only thought is to see if ~/.indi/CCD_Simulator_config.xml file syntax seems to be intact and includes something like:
<newNumberVector device="CCD Simulator" name="CCD_GAIN">
<oneNumber name="GAIN">
50
</oneNumber>
</newNumberVector>

Mach1, TS86SDQ, ASI071, ASI174, OAG, focusPro

Please Log in or Create an account to join the conversation.

Time to create page: 0.593 seconds