×
INDI Library v1.8.6 Released (21 Aug 2020)

August 2020 release of INDI Library v1.8.6 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Weather radio don't want connect

2 months 1 week ago 2 months 1 week ago by astrolivier76.
astrolivier76
Senior Boarder
Senior Boarder
Posts: 48
More
Topic Author
Weather radio don't want connect #56840
Hi,
You were right!
I’m very bad!! All is ok!!
Sorry for that! I’m tired!
Olivier

Please Log in or Create an account to join the conversation.

2 months 1 week ago
astrolivier76
Senior Boarder
Senior Boarder
Posts: 48
More
Topic Author
Weather radio don't want connect #56905
So,

I'm happy to say you that all is good!! the indi driver and the web server!! ouahhhh very cool!!
It's perfect.

This is my weather radio web site:
176.135.77.1/weatherradio/

I've juste one question:
when I go to the web site, I must to click on the time range (6h - 1d - 7d or 30d) to see the values and the grpahs.
if I will go on your website the values is instantaneous printed.

So, do you have an idea of why I have this effect?? thank you very much.

Olivier

Please Log in or Create an account to join the conversation.

2 months 1 week ago
sterne-jaeger
Platinum Boarder
Platinum Boarder
Posts: 642
Karma: 6
More
Weather radio don't want connect #56907
You could see it in the JavaScript debugger, what happens. There occurs an exception in charts.js line 226
wchart.updateOptions(...)
The problem here is that my JavaScript code expects wind data, which in your case does not exist. You need to comment out everything that is related to "windspeed" and "wchart" in the JavaScript file.

HTH
Wolfgang

TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10

Please Log in or Create an account to join the conversation.

2 months 1 week ago
astrolivier76
Senior Boarder
Senior Boarder
Posts: 48
More
Topic Author
Weather radio don't want connect #56909
Hello,
I'm very stupid! I'm not a jedi and I should have seen that !! Arff
You are a boss!
Thank you :-)

Please Log in or Create an account to join the conversation.

2 months 1 week ago
astrolivier76
Senior Boarder
Senior Boarder
Posts: 48
More
Topic Author
Weather radio don't want connect #56910
I have a last question.
Everything is OK, Web and indi.
But, if I want to use the web server 24 hours a day, I have to let kstars run.
So, is it possible to make a script that starts after each reboot?
Thank you very much
Olivier

Please Log in or Create an account to join the conversation.

2 months 1 week ago
sterne-jaeger
Platinum Boarder
Platinum Boarder
Posts: 642
Karma: 6
More
Weather radio don't want connect #56912
Sure, you need indiserver, not kstars. Call
/usr/bin/indiserver -v indi_weatherradio

If you are using a Debian style Linux, create the file /etc/systemd/system/indi-weatherradio.service
[Unit]
Description=INDI server for weather radio

[Service]
Type=simple
User=root
ExecStart=/usr/bin/indiserver -v indi_weatherradio


[Install]
WantedBy=multi-user.target

Save it, enable the service and start it:
sudo systemctl enable indi-weatherradio.service
sudo systemctl start indi-weatherradio.service

This ensures that it starts automatically after reboot. If you want to let it run under a different user, exchange "root" in the script by the user id of choice.

Good luck
Wolfgang

TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10

Please Log in or Create an account to join the conversation.

2 months 1 week ago
astrolivier76
Senior Boarder
Senior Boarder
Posts: 48
More
Topic Author
Weather radio don't want connect #56964
Hello Wolfgang,

sorry for the response time, it was really nice.
Everything is functional except for one detail!
I created the service and the server starts well. However, despite this I have to go through my iNDI app on my phone.
To be more cair, this application allows you to see all the INDI servers running. Except, that of weather radio is active but not connected. So I do it manually just like I would in kstars.
Suddenly, the interest of the service becomes limited.
Is there anything else to do to make sure that when the service is started it automatically connects the arduino without having to go through the phone application?

Otherwise, apart from that everything is functional and really very good !!

Many thanks for all this work!

Olivier

Please Log in or Create an account to join the conversation.

2 months 1 week ago
sterne-jaeger
Platinum Boarder
Platinum Boarder
Posts: 642
Karma: 6
More
Weather radio don't want connect #56981
Hi Olivier,
the script wr_rrd_update.py should automatically connect to the weather radio service. Check if this script is working as expected - you can run it with the option "-v" to get more verbose output.

Maybe there is a wrong parameter in wr_config.py.

Wolfgang

TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10

Please Log in or Create an account to join the conversation.

2 months 1 week ago
astrolivier76
Senior Boarder
Senior Boarder
Posts: 48
More
Topic Author
Weather radio don't want connect #57001
Thanks for you response.
I will try this.
If i don’t see pb, i will send you my file if you can to look!
I have just change the name of port (ttyUSB0 to Weather beacause I created a symlink)
And in the service I change root to nafa, this is the name of the user

Please Log in or Create an account to join the conversation.

2 months 1 week ago
sterne-jaeger
Platinum Boarder
Platinum Boarder
Posts: 642
Karma: 6
More
Weather radio don't want connect #57003
Olivier,
I‘ll send you a PN with my email address so that we can communicate directly.

Wolfgang

TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10

Please Log in or Create an account to join the conversation.

2 months 6 days ago
xthestreams
Expert Boarder
Expert Boarder
Posts: 132
More
Weather radio don't want connect #57020
Wolfgang, after going through the source code for Meteostation and just having pitchased all the bits for the old project, I see you’ve done some great work to build your own updated version with an SQM, wireless and a website! I love it!

Is there a project page where we can learn how to DIY? This is a hugely important project Ithink!

GSO Ritchey Chretien 12" Truss | SkyWatcher ED72 | Celestron C14
ZWO ASI 183MC Pro | ZWO ASI290MM | ZWO ASI224MC all-sky | ZEO EFW | ZWO OAG
Moonlite V2 CSL | DeepSkyDad AF3
EQ8-R | Paramount ME (needs some loving)
Nexdome | SQM LE | Ultimate Power Box V2 | Spike-a-Flat
Angry missus

Please Log in or Create an account to join the conversation.

2 months 6 days ago
xthestreams
Expert Boarder
Expert Boarder
Posts: 132
More
Weather radio don't want connect #57021
I should say I would also like to try adding a (heated) rain sensor if you haven’t already. I don’t want to shut down my observatory when cloudy as I get intermittent clouds and can image pretty well even throwing out 25-50% of frames, but I can’t afford the dome to be open in the wet.

I was thinking that perhaps the UNO generates enough heat to keep it dry enough.

My other thought was to merge into an AllSky dome and use a heater that’s relay controlled for both dew control and rain sensor.

GSO Ritchey Chretien 12" Truss | SkyWatcher ED72 | Celestron C14
ZWO ASI 183MC Pro | ZWO ASI290MM | ZWO ASI224MC all-sky | ZEO EFW | ZWO OAG
Moonlite V2 CSL | DeepSkyDad AF3
EQ8-R | Paramount ME (needs some loving)
Nexdome | SQM LE | Ultimate Power Box V2 | Spike-a-Flat
Angry missus

Please Log in or Create an account to join the conversation.

Time to create page: 0.663 seconds