×
INDI Library v1.8.6 Released (21 Aug 2020)

August 2020 release of INDI Library v1.8.6 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Weather radio don't want connect

2 months 3 days ago
astrolivier76
Senior Boarder
Senior Boarder
Posts: 48
More
Topic Author
Weather radio don't want connect #57158
Looks like the Apache configuration file for weather radio hasn't been copied or is in a different place. Try first
sudo cp add-on/weatherradio/weatherradio.conf /etc/apache2/conf-available
and then try the a2enmod command again.

Hi, it's an error,
if you want to use a2enmod, you must to copy the file in mod-available.
Also, you must to use command a2enconf if you want to put in conf-available ;)

Please Log in or Create an account to join the conversation.

2 months 3 days ago
sterne-jaeger
Platinum Boarder
Platinum Boarder
Posts: 642
Karma: 6
More
Weather radio don't want connect #57159
Oops, yes, you are right!

TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10

Please Log in or Create an account to join the conversation.

2 months 3 days ago
G_Gagnon
Expert Boarder
Expert Boarder
Posts: 149
Karma: 2
More
Weather radio don't want connect #57161
Hello Wolfgang,

Did a "a2enconf" instead of "a2enmod" and things advanced, I got a blank page.

I got things to work locally and I could display weather info on the localhost (http://localhost/weatherradio) but I would only get a blank page if I accessed from another PC (http://weatherradio_server/weatherradio). Maybe some apache2 settings or some permission issues?

Please Log in or Create an account to join the conversation.

2 months 3 days ago
astrolivier76
Senior Boarder
Senior Boarder
Posts: 48
More
Topic Author
Weather radio don't want connect #57163
Hi G_Gagnon,

if you want to see the web page from another client, you must to open the port 80 in your router (internet router) for your server.
for exemple, my server is on a tinkerbaord and his name is nafabox. In my internet box I've open Nat rules 80 on nafabox!!

Please Log in or Create an account to join the conversation.

2 months 3 days ago
G_Gagnon
Expert Boarder
Expert Boarder
Posts: 149
Karma: 2
More
Weather radio don't want connect #57166
Bonjour Olivier,

The two machines are on the same network (home) thus I assume that I do not have to do NAT or port forwarding. The weather radio being run on a StellarMate machine, I can access the StellaMate Control Panel without problem, so it's not a port 80 issue. Any other clues?

Merci.

Please Log in or Create an account to join the conversation.

2 months 3 days ago
astrolivier76
Senior Boarder
Senior Boarder
Posts: 48
More
Topic Author
Weather radio don't want connect #57167
Do you can to try the NAT. if Ok you will know ;)
In my tinker, same local, I had must to open port!

Please Log in or Create an account to join the conversation.

2 months 3 days ago
astrolivier76
Senior Boarder
Senior Boarder
Posts: 48
More
Topic Author
Weather radio don't want connect #57168
Explication for my tinker: Apache2 is on the port 80.
if you go on the web and put RL:
http://ip_local
you must to see the apache2 webpage.
if you test from another PC what do you see?

Please Log in or Create an account to join the conversation.

2 months 3 days ago
G_Gagnon
Expert Boarder
Expert Boarder
Posts: 149
Karma: 2
More
Weather radio don't want connect #57173
On the weather radio machine, if I put http://localhost in the browser, I get the apache2 webpage, as you mention. On another local machine, http://ipaddress gives me the Stellar Mate Dashboard. I thus assume that Stellar Mate redirects port 80 to another port if accessed from outside. If I can figure out how to disable Dashboard this may solve the issue.

I will try to figure it out.

Merci.

Please Log in or Create an account to join the conversation.

2 months 3 days ago
astrolivier76
Senior Boarder
Senior Boarder
Posts: 48
More
Topic Author
Weather radio don't want connect #57175
OK.... I had have the same pb with the nafabox project!
So, I had must to uninstall ngnix & apache2, then I had reinstalled apache2 and after it was ok!

Please Log in or Create an account to join the conversation.

2 months 3 days ago
G_Gagnon
Expert Boarder
Expert Boarder
Posts: 149
Karma: 2
More
Weather radio don't want connect #57177
Uninstalled and re-installed apache2 but no change. I will ask the Stellar Mate forum if there may be conflicts between the Dashboard and apache2.

Please Log in or Create an account to join the conversation.

2 months 3 days ago
astrolivier76
Senior Boarder
Senior Boarder
Posts: 48
More
Topic Author
Weather radio don't want connect #57178
do you have ngnix installed?

Please Log in or Create an account to join the conversation.

2 months 3 days ago
G_Gagnon
Expert Boarder
Expert Boarder
Posts: 149
Karma: 2
More
Weather radio don't want connect #57182
No ngnix on Stellarmate, so it is not part of the problem.

Please Log in or Create an account to join the conversation.

Time to create page: 1.073 seconds