×

INDI Library v1.9.2 Released (14 Sep 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones.

Weather radio don't want connect

  • Posts: 89
  • Thank you received: 16

Replied by Adrian on topic Weather Radio - info channel

If you use sudo you should be able to edit it, sudo makes you the super user.

If you tried sudo and it did not work please post the command you tried and the output you got back.
7 months 3 weeks ago #66472

Please Log in or Create an account to join the conversation.

  • Posts: 177
  • Thank you received: 3
hello
so I managed to modify the command line, more than waiting for the next crash to see where the problem comes from.

Christophe
7 months 3 weeks ago #66479

Please Log in or Create an account to join the conversation.

  • Posts: 89
  • Thank you received: 16

Replied by Adrian on topic Weather Radio - info channel

Here are two useful commands for you to try to monitor the situation

Check that indi is working
====================
$ ps aux | grep indiserver

You should see a line saying that indiserver is working, it will include the command including indi_weatherradio

Check the output of the logfile
=======================
$ tail -f /tmp/logfilename.txt

Instead of /tmp/logfilename.txt put in the path to the log file you used in the service script

This will show the output from the indiserver being put into the log file.
-f means follow and uou need to press ^C to get your command prompt back again.

Changing verbosity of indi
====================
You can increase the amount of information that indi outputs by adding extra v to the service file.

The service file above has one v as in
indiserver -v indi_weatherradio >> /tmp/outputfile.txt

To make it more verbose use -vv or -vvv
indiserver -vv indi_weathreradio >> /tmp/outputfile.txt

Hopefully your mystery will be solved soon.
7 months 3 weeks ago #66481

Please Log in or Create an account to join the conversation.

  • Posts: 177
  • Thank you received: 3
hello
so here it is, it happened, my weather station crashed.
So now I'm doing how to find and read the file that will tell me what happened.
because I can't find a file

See you
Christophe
Last edit: 7 months 1 week ago by Porchet.
7 months 1 week ago #67109

Please Log in or Create an account to join the conversation.

  • Posts: 177
  • Thank you received: 3
hello
so I have a good look, in the "tmp" file.
there is nothing .

Why?
7 months 1 week ago #67187

Please Log in or Create an account to join the conversation.

  • Posts: 835
  • Thank you received: 246
Did your system reboot? On some systems, /tmp gets cleaned when the system is started.
TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10
7 months 1 week ago #67189

Please Log in or Create an account to join the conversation.

  • Posts: 177
  • Thank you received: 3
No, I did not reboot !
7 months 1 week ago #67190

Please Log in or Create an account to join the conversation.

  • Posts: 89
  • Thank you received: 16

Replied by Adrian on topic Weather Radio - info channel

Christophe, sorry to hear you are still having problems.

Did you check that something was being entered into the logfile with
$ tail -f /tmp/logfilename.txt
 
Use whatever path and name for (/tmp/logfile.txt) you called your logfile in your init script.
after you set up things?

It is wise to check that what you have done is working, in case of simple typing errors, etc.

If you did check that and the file has disappeared then something deleted it, perhaps the system
lost power and rebooted? This would explain your issue.

Anyhow - you can easily put the logfile somewhere else that isn't deleted on a system reboot.

Please post your init script after you have changed it and we will check it for you.

In addition, at a terminal you can type
$ uptime
which will tell you how long the sytem has been running. If it rebooted the uptime will
be much shorter than you think it should be.

Kind regards,
7 months 1 week ago #67218

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Thank you received: 0
Hi to all,
I've assembled my weather station on an arduino uno With dht sensor, IR sensor and water sensor and ll works fine on kstars.
My only problem is that I can't find the way to use the water sensor output to automatically close he roof because the rain data are not between the weather parameters shown on the dome tab.
Can anyone help me?

Tks

Matteo
Ekos running on RPI4
Telescope apo triplet 90/600
Camera Canon Eos 1100D
Mount Skywatcher HEQ5 pro
Giudescope 50/180
Guidecamera Magzero 5M
Focuser Arduino clone of Moonlite

Remote observatory - work in progress
7 months 6 days ago #67282

Please Log in or Create an account to join the conversation.

  • Posts: 835
  • Thank you received: 246
Hi Mattheo,
please be a little bit patient, release 1.12 of weather radio will contain this option. If you know what you are doing, you could check out the branch weatherradio-v_1.12 from my indi-3rdparty clone github.com/sterne-jaeger/indi-3rdparty.git

The INDI driver is ready, the integration into the web page is missing.

With this upcoming release, I added the option for rain drop detectors, i.e. as soon as first rain drops are recognized, the weather status changes to ALARM so that for example the observatory controller could close the roof.

Wolfgang
TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10
7 months 5 days ago #67294

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Thank you received: 0
Thanks Wolfgang for the good news!
I tried to install the wetherradio release that you linked to me but, not being very familiar with Linux, I failed.
I will wait for the official release.

Matteo
Ekos running on RPI4
Telescope apo triplet 90/600
Camera Canon Eos 1100D
Mount Skywatcher HEQ5 pro
Giudescope 50/180
Guidecamera Magzero 5M
Focuser Arduino clone of Moonlite

Remote observatory - work in progress
7 months 5 days ago #67325

Please Log in or Create an account to join the conversation.

  • Posts: 197
  • Thank you received: 13
I am testing it on my Wemos D1 mini. I am using the TSL2591 sensor for the SQM and this is the measeurement in a stable dark conditions. I do not know if other people use this sensor for his SQM calculation and how they are stable and if they are copared they with a real SQM device.



So regarding to the WiFi, actually it is configured to connect to my home router, but if I go out it switch to be an AccessPoint with some defaults data? Thereis a way to change the wireless settings via a webpage?
7 months 4 days ago #67354
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 1.050 seconds