×

INDI Library v1.8.9 Released (01 Mar 2021)

INDI monthly update. In addition to driver improvements, major code refactoring is in progress by @pawel-soja to modernize and improve INDI aging code.

New forum users, please go here first: indilib.org/forum/new-forum-users.html

Weather radio don't want connect

  • Posts: 732
  • Thank you received: 197
Did your system reboot? On some systems, /tmp gets cleaned when the system is started.
TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10
2 months 1 week ago #67189

Please Log in or Create an account to join the conversation.

  • Posts: 173
  • Thank you received: 3
No, I did not reboot !
2 months 1 week ago #67190

Please Log in or Create an account to join the conversation.

  • Posts: 89
  • Thank you received: 16
Christophe, sorry to hear you are still having problems.

Did you check that something was being entered into the logfile with
$ tail -f /tmp/logfilename.txt
 
Use whatever path and name for (/tmp/logfile.txt) you called your logfile in your init script.
after you set up things?

It is wise to check that what you have done is working, in case of simple typing errors, etc.

If you did check that and the file has disappeared then something deleted it, perhaps the system
lost power and rebooted? This would explain your issue.

Anyhow - you can easily put the logfile somewhere else that isn't deleted on a system reboot.

Please post your init script after you have changed it and we will check it for you.

In addition, at a terminal you can type
$ uptime
which will tell you how long the sytem has been running. If it rebooted the uptime will
be much shorter than you think it should be.

Kind regards,
2 months 6 days ago #67218

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Thank you received: 0
Hi to all,
I've assembled my weather station on an arduino uno With dht sensor, IR sensor and water sensor and ll works fine on kstars.
My only problem is that I can't find the way to use the water sensor output to automatically close he roof because the rain data are not between the weather parameters shown on the dome tab.
Can anyone help me?

Tks

Matteo
Ekos running on RPI4
Telescope apo triplet 90/600
Camera Canon Eos 1100D
Mount Skywatcher HEQ5 pro
Giudescope 50/180
Guidecamera Magzero 5M
Focuser Arduino clone of Moonlite

Remote observatory - work in progress
2 months 5 days ago #67282

Please Log in or Create an account to join the conversation.

  • Posts: 732
  • Thank you received: 197
Hi Mattheo,
please be a little bit patient, release 1.12 of weather radio will contain this option. If you know what you are doing, you could check out the branch weatherradio-v_1.12 from my indi-3rdparty clone github.com/sterne-jaeger/indi-3rdparty.git

The INDI driver is ready, the integration into the web page is missing.

With this upcoming release, I added the option for rain drop detectors, i.e. as soon as first rain drops are recognized, the weather status changes to ALARM so that for example the observatory controller could close the roof.

Wolfgang
TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10
2 months 5 days ago #67294

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Thank you received: 0
Thanks Wolfgang for the good news!
I tried to install the wetherradio release that you linked to me but, not being very familiar with Linux, I failed.
I will wait for the official release.

Matteo
Ekos running on RPI4
Telescope apo triplet 90/600
Camera Canon Eos 1100D
Mount Skywatcher HEQ5 pro
Giudescope 50/180
Guidecamera Magzero 5M
Focuser Arduino clone of Moonlite

Remote observatory - work in progress
2 months 4 days ago #67325

Please Log in or Create an account to join the conversation.

  • Posts: 144
  • Thank you received: 5
I am testing it on my Wemos D1 mini. I am using the TSL2591 sensor for the SQM and this is the measeurement in a stable dark conditions. I do not know if other people use this sensor for his SQM calculation and how they are stable and if they are copared they with a real SQM device.



So regarding to the WiFi, actually it is configured to connect to my home router, but if I go out it switch to be an AccessPoint with some defaults data? Thereis a way to change the wireless settings via a webpage?
2 months 4 days ago #67354
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 732
  • Thank you received: 197
Version 1.12 is released, but as I just saw, the water sensor is already present in version 1.11.

Wolfgang
TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10
Last edit: 2 months 3 days ago by sterne-jaeger. Reason: Water sensor already implemented with 1.11
2 months 3 days ago #67363

Please Log in or Create an account to join the conversation.

  • Posts: 732
  • Thank you received: 197

So regarding to the WiFi, actually it is configured to connect to my home router, but if I go out it switch to be an AccessPoint with some defaults data? Thereis a way to change the wireless settings via a webpage?

I'm not sure what you want to achieve using the Arduino as access point. If you want to use it in the field, I would recommend one of these two options:
  • Use a WiFi access point in the field and connect all your devices including the Wemos to it. This way you simply span a local network without internet connection.
  • Connect your Wemos with the USB cable directly to the server (Raspberry or whatever you are using)
HTH
Wolfgang
TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10
2 months 3 days ago #67365

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Thank you received: 0
Hi Wolfgang, i try to instal the version 1.12 but i get some errors like the following:
/home/pi/Projects/weatherradio/indi-3rdparty/indi-duino/weatherradio.cpp:1119:21: error: ‘defineProperty’ was not declared in this scope
defineProperty(deviceProp);
^~~~~~~~~~~~~~
/home/pi/Projects/weatherradio/indi-3rdparty/indi-duino/weatherradio.cpp:1119:21: note: suggested alternative: ‘deleteProperty’
defineProperty(deviceProp);
^~~~~~~~~~~~~~
deleteProperty

What am I doing wrong?
Matteo
Ekos running on RPI4
Telescope apo triplet 90/600
Camera Canon Eos 1100D
Mount Skywatcher HEQ5 pro
Giudescope 50/180
Guidecamera Magzero 5M
Focuser Arduino clone of Moonlite

Remote observatory - work in progress
2 months 3 days ago #67376

Please Log in or Create an account to join the conversation.

  • Posts: 732
  • Thank you received: 197
Looks like your INDI library is outdated. Please update to the latest version 1.8.8.
TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10
2 months 3 days ago #67377

Please Log in or Create an account to join the conversation.

  • Posts: 144
  • Thank you received: 5
Could be necessary to change the wifi options in any case, like default accesspoint die or any other case.
A quick way to change the SSID is better than have to reupload the code just for change the wifi station settings
2 months 3 days ago #67394

Please Log in or Create an account to join the conversation.

Time to create page: 0.723 seconds