×
INDI Library v1.8.6 Released (21 Aug 2020)

August 2020 release of INDI Library v1.8.6 introduces new drivers while providing fixes and improvements to existing devices and core framework.

KStars v3.4.3 Released

2 months 1 week ago 2 months 1 week ago by dmsummers.
dmsummers
Gold Boarder
Gold Boarder
Posts: 241
Karma: 2
More
KStars v3.4.3 Released #57145
Note that in my case, it wasn't a no-brainer to get the state machine happy. Kstars mount control said one thing, and INDI said another about the park state. It's not quite clear how I got the state machine to sync up again, but it was awkward. Some number of unpark, park, and GOTO requests were made after I changed the INDI GUI before it unstuck. Something's not quite right in there; I hope too many folks don't get tripped up by this (especially those without domes who may not be thinking about it!)....

RASA11, Celestron CGX-L, ASI183mc Pro, 60mm guider + ASI290mm mini, ASI EAF focuser, PPB, Rpi4-4Gb+SSD, Powered USB3 hub, hardwire Ethernet.
The following user(s) said Thank You pug916

Please Log in or Create an account to join the conversation.

2 months 1 week ago 2 months 1 week ago by El Corazon.
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 880
Karma: 3
More
KStars v3.4.3 Released #57147
I hope so, too. I fired up the system and started the upgrade again. Unfortunately, the updated Indi drivers for my ZWO-EFW and the ZWO cameras, as well as QHY CCD crash when called up by the older 3.4.2 Kstars version.
If I can't figure out your sequence of making this unstuck once I have rebuild the latest Kstars, I will have to purge everything again, at least Indi, and restart once more from the stable repo.

However, as I wrote, this must be a new bug that was introduced between July 15 and 19. I had been using 3.4.3 for a few weeks already and did not have that problem as late as July 15, when I installed the last functioning version. The havoc started on July 19, when I installed the newest version because I wanted to test Hy's new guider algorithms.

Thanks again for this great tip! I had dismissed the dome warning and would most likely not have gone back to it.

PS: The logs can be downloaded here: www.dropbox.com/sh/bbwfky2ij9y1ag0/AAA2H...WugxDTSQ10nKEwa?dl=0

The very last one, at >600 MB, is the one after I purged everything and reinstalled 3.4.2. The imaging with that worked without a flaw throughout the night.

I wonder if this is where the problem is rooted in the CEM60 driver:

[2020-07-19T22:57:46.091 CDT DEBG ][ org.kde.kstars.indi] - iOptron CEM60 : "Error: DOME_IGNORED is not a member of Dome parking policy (DOME_POLICY) property. "

That error, which did not prevent the mount from moving, no longer shows with the latest Indi update, it now says:

[2020-07-19T21:17:09.536 CDT INFO ][ org.kde.kstars.indi] - iOptron CEM60 : "[WARNING] Cannot unpark mount when dome is locking. See: Dome Policy in options tab. "

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set

Please Log in or Create an account to join the conversation.

2 months 1 week ago
alacant
Platinum Boarder
Platinum Boarder
Posts: 649
Karma: 1
More
KStars v3.4.3 Released #57153

I hope too many folks don't get tripped up by this (especially those without domes


Just to mention (for my own sanity), be sure to save the dome policy after you've changed it. Otherwise it comes and kicks you each time you start!

Cheers and clear skies,
Steve

kubuntu 20.04
700d, eq6, t7m
The following user(s) said Thank You TallFurryMan

Please Log in or Create an account to join the conversation.

2 months 1 week ago
Marc2b
Expert Boarder
Expert Boarder
Posts: 119
Karma: 1
More
KStars v3.4.3 Released #57157
El Corazon says :

[2020-07-19T21:17:09.536 CDT INFO ][ org.kde.kstars.indi] - iOptron CEM60 : "[WARNING] Cannot unpark mount when dome is locking. See: Dome Policy in options tab. "

Just as the message says, go to the indi panel/your mount/options and simply click "Dome Ignored". Save and reload and you're done. ;)

- Marc
The following user(s) said Thank You El Corazon

Please Log in or Create an account to join the conversation.

2 months 1 week ago 2 months 1 week ago by Marc2b.
Marc2b
Expert Boarder
Expert Boarder
Posts: 119
Karma: 1
More
KStars v3.4.3 Released #57160
Now, my own problems :

1/ I'm using Kstars with the dark theme "Black Body". When I quit and then restart, the soft comes back with an incomplete white menu and I have to set my theme again.
it is very unpleasant when you're in the dark and have your vision adapted because of the crude white light.



2/ I have 3 problems with indiwebmanager. (The last version including agent)

- I can't change the default 'root' user in the indiwebmanager.service or it refuses my connection.
- If I connect through indiweb, the indiserver and drivers are launched but everything stalls then. I'can't even unpark my mount.
If I start manually the indiserver and the drivers through an ssh cnx, everything works fine.
- In simulation mode, it says there is no GSC available. (It works with the workaround above)

- Marc
Attachments:
The following user(s) said Thank You TallFurryMan

Please Log in or Create an account to join the conversation.

2 months 1 week ago
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 880
Karma: 3
More
KStars v3.4.3 Released #57165

Marc2b wrote: El Corazon says :

[2020-07-19T21:17:09.536 CDT INFO ][ org.kde.kstars.indi] - iOptron CEM60 : "[WARNING] Cannot unpark mount when dome is locking. See: Dome Policy in options tab. "

Just as the message says, go to the indi panel/your mount/options and simply click "Dome Ignored". Save and reload and you're done. ;)

- Marc



Done that, of course, but have been unable to test since it is cloudy again now. But if that is all that is required for fixing it, then that's easy enough, of course. Can you confirm, that that is all that's required, Marc? Doug's experience suggested something else.

Jo

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set

Please Log in or Create an account to join the conversation.

2 months 1 week ago
Marc2b
Expert Boarder
Expert Boarder
Posts: 119
Karma: 1
More
KStars v3.4.3 Released #57170

El Corazon wrote:

Marc2b wrote: El Corazon says :

[2020-07-19T21:17:09.536 CDT INFO ][ org.kde.kstars.indi] - iOptron CEM60 : "[WARNING] Cannot unpark mount when dome is locking. See: Dome Policy in options tab. "

Just as the message says, go to the indi panel/your mount/options and simply click "Dome Ignored". Save and reload and you're done. ;)

- Marc



Done that, of course, but have been unable to test since it is cloudy again now. But if that is all that is required for fixing it, then that's easy enough, of course. Can you confirm, that that is all that's required, Marc? Doug's experience suggested something else.

Jo


Hi Jo,

If your nights are cloudy you can verify it works with the indi_simulator_telescope driver (Telescope Simulator in the profile editor )

- Marc

Please Log in or Create an account to join the conversation.

2 months 1 week ago
knro
Administrator
Administrator
Posts: 8398
Karma: 51
Topic Author
KStars v3.4.3 Released #57171
The "Mount cannot unpark due to dome" issue was fixed in INDI, please update!

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You TallFurryMan, El Corazon, pug916

Please Log in or Create an account to join the conversation.

2 months 1 week ago
Gilles
Expert Boarder
Expert Boarder
Posts: 144
Karma: 2
More
KStars v3.4.3 Released #57172
Tested last night IRL
Same problem with dome locking stuff, quickly solved :-)
i've tested multistar SEP guiding, and did'nt noticed any improvement on my guiding accuracy but it needs more testing obviously
i tried Backlash measurment for DEC axis, but i could'nt achieve any calibration, i have to understand what happens (possibly mount problems)
BTW calibration plot is really usefull !
i also tried Bahtinov focus assistant, but also need more testing : need to understand what graph shows
(it's also hard to use with manual focus)

Anyway :
Great work ! (again)

Please Log in or Create an account to join the conversation.

2 months 1 week ago
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 880
Karma: 3
More
KStars v3.4.3 Released #57174
I assume it was fixed in the nightly repository only and not in the stable release?

Or do I need to compile Indi manually?

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set

Please Log in or Create an account to join the conversation.

2 months 1 week ago
maxthebuilder
Gold Boarder
Gold Boarder
Posts: 371
More
KStars v3.4.3 Released #57191
I don't have a dome but cannot unpark my mount either.
How do I download nightlies on Raspbian (Srellarmate 1.5.3)?

Max S.

RPI 4 B (4Gb) with SMate
Nikon D5500 H-a modified. Nikon D5500 stock
AT72EDII, TPO RC6
ZWO ASI294MC Pro, ASI071MC Pro
ZWO ASI120MC-S on ZWO 30F4
ZWO EAF x 2
SW AZ-GTi x 2
SW HEQ5

Please Log in or Create an account to join the conversation.

2 months 1 week ago
phomer60
Gold Boarder
Gold Boarder
Posts: 219
More
KStars v3.4.3 Released #57192
Marc,

I think the issue is more than just resetting the Dome Ignored flag.
If you don't have a Dome then why is it happening and secondly what triggered this in the first place?

Paul

Please Log in or Create an account to join the conversation.

Time to create page: 1.587 seconds