×
INDI Library v1.8.6 Released (21 Aug 2020)

August 2020 release of INDI Library v1.8.6 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Shutdown procedure and "Aborted Job Management" Gotcha

1 month 2 weeks ago
AxelM
Fresh Boarder
Fresh Boarder
Posts: 9
More
Topic Author
Shutdown procedure and "Aborted Job Management" Gotcha #57941
This morning I noticed an interesting behavior of the shutdown procedure. After a night of taking O-III and S-II frames, I was surprised to see that the sequence queue did not show the jobs as "completed", but as "Aborted" (O-III) and "Idle" (S-II). Yet, the images were there.



After going through the logs, I am beginning to understand what happened. After taking all 85 O-III frames and 80 out of 85 S-II frames, the scheduler reached astronomical twilight at 05:09 local time:
[2020-08-08T05:08:02.601 EDT INFO ][           org.kde.kstars.fits] - Loading FITS file  "/home/axel/astro/IC_1396/Light/SII/IC_1396_Light_SII_120_secs_122.fits"
[2020-08-08T05:08:02.603 EDT INFO ][   org.kde.kstars.ekos.capture] - "Received image 80 out of 85."
[2020-08-08T05:08:02.685 EDT INFO ][   org.kde.kstars.ekos.capture] - "Capturing 120.000-second SII image..."
[2020-08-08T05:08:02.786 EDT INFO ][           org.kde.kstars.indi] - ZWO CCD ASI1600MM Pro :  "[INFO] Taking a 120 seconds frame... "
[2020-08-08T05:09:02.815 EDT INFO ][ org.kde.kstars.ekos.scheduler] - "Job 'IC 1396' is now approaching astronomical twilight rise limit at Sat Aug 8 05:09:00 2020 (0 minutes safety margin), marking idle."
[2020-08-08T05:09:02.824 EDT INFO ][ org.kde.kstars.ekos.scheduler] - "Job 'IC 1396' is stopping guiding..."
[2020-08-08T05:09:02.825 EDT INFO ][   org.kde.kstars.ekos.capture] - "Autoguiding stopped. Aborting..."
Thus, the job was aborted. However, in the scheduler, the "Aborted Job Management" was set to "Queue" with a 0 s delay:

Thus, the job was immediately restarted. At that time, apparently, the astronomical twilight limit was re-calculated. Since it was a new day (the original job started before midnight), and since the nights are getting longer, the new twilight was 05:12. Thus, the scheduler thought it had 3 minutes left before dawn and re-started the job. At 05:12, job execution was aborted again, and this time the mount was properly parked:
[2020-08-08T05:10:16.279 EDT INFO ][   org.kde.kstars.ekos.capture] - "Job requires 120.000-second OIII images, has 0/85 frames captured and will be processed."
[2020-08-08T05:10:16.284 EDT INFO ][   org.kde.kstars.ekos.capture] - "Capturing 120.000-second OIII image..."
[2020-08-08T05:10:16.535 EDT INFO ][           org.kde.kstars.indi] - ZWO CCD ASI1600MM Pro :  "[INFO] Taking a 120 seconds frame... "
[2020-08-08T05:10:40.969 EDT INFO ][     org.kde.kstars.ekos.guide] - "Lost track of the guide star. Searching for guide stars..."
[2020-08-08T05:10:45.132 EDT INFO ][     org.kde.kstars.ekos.guide] - "Autoguiding started."
[2020-08-08T05:12:01.677 EDT INFO ][ org.kde.kstars.ekos.scheduler] - "Job 'IC 1396' is now approaching astronomical twilight rise limit at Sat Aug 8 05:12:00 2020 (0 minutes safety margin), marking idle."
[2020-08-08T05:12:01.684 EDT INFO ][ org.kde.kstars.ekos.scheduler] - "Job 'IC 1396' is stopping guiding..."
[2020-08-08T05:12:03.678 EDT INFO ][ org.kde.kstars.ekos.scheduler] - Starting shutdown process...
[2020-08-08T05:12:03.678 EDT INFO ][ org.kde.kstars.ekos.scheduler] - "Warming up CCD..."
[2020-08-08T05:12:03.727 EDT INFO ][   org.kde.kstars.ekos.capture] - "Cooler is off"

Looking at all the scheduler's settings, I think there are two that could have prevented this sequence of events:
  1. Set the "Aborted Job Managment" delay to at least 5 minutes (must be larger than the daily change in astronomical twilight)
  2. A few minutes of Pre-dawn time in the scheduler options (it was set to zero). I also should have turned on "Remember Job Progress", so that the sequence would continue with the aborted S-II sequence, rather than re-start O-III:

Am I on the right track? Any thoughts?

Axel

Ubuntu Mate 20.04 (arm64) on Raspberry Pi 4 (4 GB)
Vixen R200SS 8" f/4
EQ6-R Pro
ASI 1600MM Pro + EFW, Canon 6D

Attachments:
The following user(s) said Thank You knro

Please Log in or Create an account to join the conversation.

Time to create page: 0.429 seconds