×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

[SOLVED] Kstars crash after INDI start Kubuntu 15.04

  • Posts: 5
  • Thank you received: 0
I am using Kubuntu desktop 15.04 and Kstars 2.3.0. The INDI server is hosted on a Raspberry Pi 2 running Ubuntu-Mate(3.18.0-20-rpi2 #21-Ubuntu SMP PREEMPT Sun Apr 5 01:56:02 UTC 2015 armv7l armv7l armv7l GNU/Linux). I can sometimes establish a connection to the INDI server, but Kstars crashes immediately after this; below is the Kstars output of the error. At first I thought it was a permission problem, but I am starting Kstars as root.

Below is the output from the indiserver
Thank you for your help, I have been beating my head against this for a few days.

UPDATE: Was able to connect to the telescope. Had a couple seconds of control before the above error occurred again.
Last edit: 6 years 10 months ago by Benjamin. Reason: update
6 years 10 months ago #4463

Please Log in or Create an account to join the conversation.

  • Posts: 13
  • Thank you received: 0
I can confirm that this bug exists; I've been getting it (with the same error message) when running KStars inside the Ekos VM. I've just updated everything in the VM to the current (2015-06-24, around 0300 GMT) versions. Running an older KStars (from the regular package, not kstars-bleeding) under Ubuntu 15.04 (not in a VM), the problem doesn't occur. All this is with the INDI server running on Ubuntu Mate on a Pi2 as well.

In general, the whole KStars/INDI/Ekos system has been very impressive and I'd like to help with the debugging...but need some expert guidance to know where to begin.
6 years 10 months ago #4464

Please Log in or Create an account to join the conversation.

  • Posts: 20
  • Thank you received: 12
Hi

looks like the same problem as mentioned here . All sound notifications crash KStars.
You can try using phonon-backend-vlc by installing:
sudo apt-get install phonon-backend-vlc phonon4qt5-backend-vlc
I also had to clean the vlc plugin cache to avoid problems introduced by different qt versions:
sudo /usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins
To use the backend open system settings -> Multimedia -> Backend and Prefer the Phonon VLC backend.

cs Markus
Last edit: 6 years 10 months ago by Markus. Reason: Format error
6 years 10 months ago #4466

Please Log in or Create an account to join the conversation.

This is an annoying bug with Phonon (a KDE multimedia component). Try the following, it might resolve the issue:
sudo apt-get remove phonon4qt5-backend-gstreamer
sudo apt-get install phonon4qt5-backend-vlc
sudo /usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins/
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
Last edit: 6 years 10 months ago by Jasem Mutlaq.
6 years 10 months ago #4468

Please Log in or Create an account to join the conversation.

  • Posts: 13
  • Thank you received: 0
I've just tried making the recommended changes and running the latest in EkosVM with Ubuntu Mate on a Pi 2 controlling a NexStar 6se.

The bug appears to have been resolved with this change. Thanks for the suggestion!

Also, the latest version is much more successful than the non-bleeding KStars with a Celestron in equatorial mode, so thanks for another important improvement! Further discussion about that belongs in the Celestron thread, I guess.
6 years 10 months ago #4473

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 0
I can confirm also that the suggested fix work immediately. Thank you all for the quick responses.
6 years 10 months ago #4474

Please Log in or Create an account to join the conversation.

Time to create page: 0.609 seconds