×

INDI Library v1.8.9 Released (01 Mar 2021)

INDI monthly update. In addition to driver improvements, major code refactoring is in progress by @pawel-soja to modernize and improve INDI aging code.

New forum users, please go here first: indilib.org/forum/new-forum-users.html

Re:Connecting PHD2 from Ekos

  • Posts: 41
  • Thank you received: 8
Been having trouble finding a good set of parameter values for calibrating the Dec axis on my CEM25p with the internal guider, plus getting weirdly inconsistent Dec guiding within an imaging session (I'll get more specific in a separate post later, unless someone asks here). Want to give PHD2 a try.

I read in some documentation that PHD2 must be running before starting KStars - so I'm good on that front. Started PHD2, set up a profile and successfully connected to both the ASI120mm-mini and the mount. Started KStars/Ekos, using a 'PHD2' profile that has the iOptron, Canon & ZWO drivers and the Guiding box set to PHD2. Went through PA in Ekos, chose a target, plate-solved. Hit the Guide button but PHD2 was not able to connect to the mount.

Am I missing a step or two? Is there full documentation of how to do it somewhere (assuming it isn't just as simple as what I did above)?

Thanks
2 months 3 weeks ago #66396

Please Log in or Create an account to join the conversation.

  • Posts: 332
  • Thank you received: 96

Replied by dmsummers on topic Connecting PHD2 from Ekos

It shouldn't matter whether you connect from the PHD2 side or Ekos side, but what I do is launch PHD2 but NOT connect from PHD2. Connect from Ekos (guide tab). Once connected, you can guide. I've seen odd circumstances where if you connect first from PHD2, the state machine between Ekos & PHD2 can get confused. Most of the time, just disconnecting and reconnecting works to solve it. That said, I recommend you launch PHD2 but wait to connect from Ekos. Good luck, Doug
RASA11, Celestron CGX-L, ASI183mc Pro, 60mm guider + ASI290mm mini, ASI EAF focuser, PPB, Rpi4-4Gb+SSD, Powered USB3 hub, hardwire Ethernet.
The following user(s) said Thank You: alastairmck
2 months 3 weeks ago #66397

Please Log in or Create an account to join the conversation.

  • Posts: 41
  • Thank you received: 8

Replied by dx_ron on topic Connecting PHD2 from Ekos

Thanks - I'll give that a try next time it is clear. The 1st couple of tries it seemed obvious to connect to PHD2 first, if only to be sure that it *could*.
2 months 3 weeks ago #66399

Please Log in or Create an account to join the conversation.

  • Posts: 41
  • Thank you received: 8

Replied by dx_ron on topic Connecting PHD2 from Ekos

Hmmm. Still not able to connect PHD2 to the mount. Even when exit KStars and have only PHD2 open. It connected when I first made the profile, but I don't think it has again since.

Is it correct to have both the mount and the Aux Mount in the PHD2 connection window be INDI Mount [iEQ] (for a CEM25p, that is)?

Everything is running on the rpi that is out at the mount. Is 'localhost' correct for that configuration? (in astroberry, if that makes a difference) I left the port as whatever showed up as the default value.

(on the other hand, Ekos internal guiding is working extremely well tonight, maybe I'm just gradually zeroing in on exactly how to balance and set the tension screws on the CEM25p)
Last edit: 2 months 3 weeks ago by dx_ron.
2 months 3 weeks ago #66408

Please Log in or Create an account to join the conversation.

  • Posts: 41
  • Thank you received: 8

Replied by dx_ron on topic Connecting PHD2 from Ekos

Still trying. I deleted the PHD2 profile I had made earlier and started over, both with and without the wizard. There's not real choice for "Mount", besides INDI Mount. At one point last week I had successfully made a profile where it reported INDI Mount [iEQ], but I don't now recall where I was given the option to choose a specific driver. Anyway, INDI Mount does not connect. I've tried in the Hostname field localhost (that should be right, it's all on the same rpi, right?), astroberry and astroberry.local. It defaults to Port 7624, but I haven't found anything that tells me I need to change that.
2 months 3 weeks ago #66411

Please Log in or Create an account to join the conversation.

  • Posts: 332
  • Thank you received: 96

Replied by dmsummers on topic Connecting PHD2 from Ekos

Here's my setup (not astroberry...but SM which should be still the same for this info):

RASA11, Celestron CGX-L, ASI183mc Pro, 60mm guider + ASI290mm mini, ASI EAF focuser, PPB, Rpi4-4Gb+SSD, Powered USB3 hub, hardwire Ethernet.
2 months 3 weeks ago #66412
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 245
  • Thank you received: 44

Replied by kengs on topic Connecting PHD2 from Ekos

In PHD2 connect screen.
Click the mount setting button (1). The Mount Setting popup is displayed
If it is not connected to INDI click the Connect button (2). If you connected through Ekos this should show Connected already
Select your mount driver (3). Options visible when connected to INDI
If you need to, open the INDI control panel (4)
If having trouble connecting from Ekos, make sure Enable Server is ticked on the Tools menu in PHD2
-- Ken
RPi3 Ubuntu Server 20.04, Windows 10 AMD64, AAEON UP Core Ubuntu Desktop 20.04
Avalon M-Uno, EQ6 Pro, Atik420, ASI1600MM-C, ASI120MM-S, DBK21AU04, ZWO EFW, Optec TCFSi
Vixen R150S, GSO RC8, ST80
2 months 3 weeks ago #66413
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 41
  • Thank you received: 8

Replied by dx_ron on topic Connecting PHD2 from Ekos

(can I start by pointing out that anything one types into the 'Quick reply' box in this forum software simply vanishes when one moves to the 'editor'? ugh)

I think I am crashing into a thing that has always befuddled me - the multiple ways/places to create and start Profiles: from within Ekos vs the INDI Web Manager (is that just an astroberry thing?, if so how else does one start INDI before starting KStars?).

If I start a profile running in the INDI Web Manager and then start PHD2, I can connect to the mount (1st picture)

I start Kstars & Ekos. Ekos pops up a box about an existing INDI web server running and do I want to close it. If I say 'yes', then I cannot connect PHD2 to the mount.

If instead I say 'no', then KStars complains that the mount has been disconnected
So at that point, I have two separate INDI servers running, right? Maybe that is all normal and I can just commence guiding at that point (can't test that now, this is all in the garage while it is daytime and snowing anyway). But it seems that I would no longer be able to command the mount to slew, right?

Like I said - I have never managed to wrap my head around multiple INDI instances running. It always seemed safest, when starting Ekos, to stop the existing instance because Ekos is the program that I will be interacting with.
2 months 3 weeks ago #66437
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 947
  • Thank you received: 288
In any case, you need both Ekos and Phd2 to connect to the mount, thus whatever the number of different servers, there has to be one single mount driver connected at the same time.

If you work with both Ekos and Phd2, let Ekos request Phd2 to connect to the mount driver, this will avoid configuration issues, especially on the geographical settings and horizon limits.

To be very deterministic, if you do everything from a single raspberry:
- you first ensure there is no indiserver running,
- then you start Phd2 with no further action except adding your CCD and your mount with default config to the profile (no aux), making sure the server port is enabled,
- then you start Ekos with a local profile that includes both your mount and the Phd2 guider option, so that it instantiates an indiserver on the default port with the mount connected and adds the guider tab to the interface.

In that situation, Ekos must ask Phd2 to connect to the mount. If it does not, you are free to manipulate of Phd2 side to see if the port or the address are correct, try loops, whatever, Ekos will follow-up and simply wait for you.

-Eric
HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access
2 months 3 weeks ago #66443

Please Log in or Create an account to join the conversation.

  • Posts: 41
  • Thank you received: 8

Replied by dx_ron on topic Re:Connecting PHD2 from Ekos

I think I have it now (pending testing outside) - thank you to those who helped.

Astroberry sometimes starts up with an INDI server running, so I need to make sure that is stopped. For indoor PHD2 testing, I needed to add the camera simulator ("None" is the default Camera option, but if left at None it just fails to complete its connection to Ekos without any error message).
The following user(s) said Thank You: TallFurryMan
2 months 3 weeks ago #66453

Please Log in or Create an account to join the conversation.

  • Posts: 41
  • Thank you received: 8

Replied by dx_ron on topic Re:Connecting PHD2 from Ekos

Hopefully my final update (today's testing was all indoors again). I think I finally have it, so I want to document it in case someone ever gets to this thread by searching for PHD2/ekos connection problems. In all the failed trials, I was connecting things in various orders that all seemed more intuitive to me, though I must be in the minority there because most of you all never went through this.

So:
I deleted all existing PHD2 equipment profiles, just to be safe.
Checked to be sure there were no rogue INDI servers running.
Started PHD2, but did *not* create an equipment profile (that is the counterintuitive part)
Started KStars and ekos, then went back to PHD2 to use the wizard to create a profile and connect the equipment

Looks good so far. Rebooted, started PHD2, then ekos. PHD2 and the mount were successfully connected. Have to wait out a couple of storm systems headed my way over the next week (at least) before I can tell PHD2 to actually do anything.

Thanks again for the help and input.
The following user(s) said Thank You: alastairmck
2 months 2 weeks ago #66709

Please Log in or Create an account to join the conversation.

Time to create page: 1.181 seconds