×

INDI Library v1.9.2 Released (14 Sep 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones.

ASI EAF not recognized in Nightly

  • Posts: 129
  • Thank you received: 33
About two weeks ago I noticed my ASI EAF no longer was being loaded in Ekos in the latest (at that time) nightly version.  I have stable versions that I revert to when these things crop up so this is more just to alert those developing the software.  Since then I have kept up with the updates of Kstars and the various indi libraries and drivers that are made available. So far my focuser still doesn't show up in Ekos.  

 

File Attachment:

File Name: log_18-09-18.txt
File Size:38 KB

running apt list --installed|grep asi  returns this:

brian@nanopct4:~$ apt list --installed|grep asi

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

indi-asi/focal,now 1.9~202104031911~ubuntu20.04.1 arm64 [installed,automatic]
libasi/focal,now 1.14~202104031825~ubuntu20.04.1 arm64 [installed,automatic]
libbasicusageenvironment1/focal,now 2020.01.19-1build1 arm64 [installed,automatic]

Jo, (El Corazan)  mentioned in another thread his filter wheel had disappeard recently after an update and noticed the nightly version 99-asi.rules in the rules.d folder was missing the first line. After editing it back, his filter wheel was loading again.  I was also missing that first line, edited it back but it seems to not have changed anything in my case.  

The 99-asi.rules file from the stable version of Kstars (March 1 2021) appears as below:

ACTION=="add", ATTR{idVendor}=="03c3", RUN+="/bin/sh -c '/bin/echo 256 >/sys/module/usbcore/parameters/usbfs_memory_mb'"

# All ASI Cameras and filter wheels

SUBSYSTEMS=="usb", ATTR{idVendor}=="03c3", MODE="0666" 

The 99-asi.rules file from the nightly version is missing that first line.  I'm not sure this is significant but thought I would mention it.

The log file is attached , it looks pretty normal to me but I'm no developer, maybe someone can spot something.
-Brian

NanoPC-T4 - Armbian focal
iOptron CEM25P mount
Photoline 80mm triplet refractor
ZWO ASI294MC Pro Imaging camera
ZWO ASI290MM mini Guide camera
ZWO ASI EAF focuser

Last edit: 5 months 3 weeks ago by Brian.
5 months 3 weeks ago #69694
Attachments:

Please Log in or Create an account to join the conversation.

It's not missing, it was removed on purpose and move to INDI Library. So if you install INDI Library latest from GIT, it should install a udev rule file that's generic for all USB devices.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Jose Corazon
5 months 3 weeks ago #69713

Please Log in or Create an account to join the conversation.

  • Posts: 504
  • Thank you received: 101
Hi Brian,

The missing line was moved to indilib and changed slightly so that it only changes the memory allocation if it is not already set to something higher. This was on purpose, and seems to be working now, so I do not think this is the issue, unless you did not also update indilib? Something to check anyway.

You can also verify the setting by running
cat /sys/module/usbcore/parameters/usbfs_memory_mb
After a reboot it may say 16, but after running indi, it should say 256.

Either way, the usb memory allocation shouldn't affect device discovery.

More suspect is the update made on the 19th, to libasi, where the ZWO SDK was updated. Before that, only the version number changed for the release of 1.8.9, nothing else in libasi changed, all the way back to Jan 4. Can you install a version just before March 19 to verify the focuser still works at that point?

Jim



 
12" pier with HDX110 using EQMod
ASI 1600 mono/color mains with ASI290MM in off-axis
ASI filter wheel
Moonlite focusers for the sharpening
AT115EDT w/.8x for the light
Fedora Linux, 100% INDI
The following user(s) said Thank You: Jose Corazon
5 months 2 weeks ago #69715

Please Log in or Create an account to join the conversation.

  • Posts: 1114
  • Thank you received: 182
I agree, specifying the image buffer memory size is unlikely to affect the recognition of ZWO peripherals when added to the asi.rules file, now that it is already being set globally.

As I wrote earlier, I cannot say for certain that increasing the memory was what fixed the problem in my case, as I also found the efw.rules file that was missing in the udev/rules.d folder. Adding that back together with the modified asi.rules file fixed the problem in my case where the EFW was not recognized. I do not have a ZWO-EAF, so I cannot test that. I am using Moonlite, and that has no problem.

I did not find an EAF.rules file anywhere, so whatever governs the recognition of the EAF is likely contained somewhere else, possibly in the libasi that Jim also suspects. So purging libasi and installing the March 10 version of that library may fix Brian's problem.
Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
5 months 2 weeks ago #69720

Please Log in or Create an account to join the conversation.

  • Posts: 129
  • Thank you received: 33
Jasem made the first suggestion so I did that first and it fixed it.
I went here  indilib.org/forum/general/210-howto-buil...st-libindi-ekos.html   and followed the directions for "Building Indie from Source".  Thanks everyone for taking the time to help.
-Brian

NanoPC-T4 - Armbian focal
iOptron CEM25P mount
Photoline 80mm triplet refractor
ZWO ASI294MC Pro Imaging camera
ZWO ASI290MM mini Guide camera
ZWO ASI EAF focuser

5 months 2 weeks ago #69722

Please Log in or Create an account to join the conversation.

  • Posts: 1114
  • Thank you received: 182
That's great! When I last updated Indi from the source about a week ago, that fix was not yet there.
Glad it works now!
I'll rebuild my own drivers then next time and see if that fixes the filter wheel issue as well.
Thanks, Jasem!

PS:  Did this involve a revision of libasi and would just rebuilding libasi have been sufficient?
Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
Last edit: 5 months 2 weeks ago by Jose Corazon.
5 months 2 weeks ago #69723

Please Log in or Create an account to join the conversation.

Time to create page: 0.216 seconds