×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Guiding problem with two QHYCCD cameras and PHD2

  • Posts: 13
  • Thank you received: 2
Hello,I use a PI4 with Stellarmate, an AZEQ6 mount, a QHY294M camera for imaging, a QHYFW3 filter wheel connected directly to the camera, a QHY5III178C camera for guiding, a focuser all controlled on VNC with PC DELL on Windows 10. I control the mount, the focuser, the GPSD and the QHY294M camera directly from Kstars which runs on the Stellarmate and the PI4. So I use EKOS and INDI drivers.For the guidance, I had problems with the internal guidance of EKOS. I use PHD2 which runs on the PI4 and is called by EKOS as external guider. Finally, for the PolarMaster camera that was conflicting with EKOS, I finally run the software directly from Windows 10.

 I guide with a QHY5III178C camera. When I prepare my setup in EKOS, if I put two QHYCCD cameras, it recognizes the QHY294M and the QHY5III178C. But when I launch PHD2, it sees the QHY5III178C but crashes after the 1st capture... I never get my hand back if I ask for a stop and I have to kill the PHD2 process in progress. If I do all the same but I don't declare the QHY5III178C in EKOS or I explicitly disconnect it from INDI, then PHD2 recognizes it and drives it correctly. But in this case, I don't have to connect the QHY5III178C when I connect EKOS, because it looks for the first available camera and it finds the QHY5III178C first and never offers the QHY294M again. So, the only way is to put both in EKOS and then disconnect the QHY5III178C manually from INDI before launching PHD2 or not to connect the USB cable of the QHY5III178C, launch EKOS with only the QHY294M and then once EKOS is not looking for a camera, connect the QHY5III178C and launch PHD2.

 Obviously, it works by tinkering like that, but it reminds me of my beginnings in computing at the end of the 70's... If it works, touch it more! We are far from plug-and-play ;-). Than
Last edit: 1 year 5 months ago by Christian Voirol.
1 year 5 months ago #72111

Please Log in or Create an account to join the conversation.

  • Posts: 13
  • Thank you received: 2
Dear Jasem, I have taken the time to detail the June 10, 2021 session minute by minute. My goal was to document the problem in connection with the FITS and Calibrate window. But nothing went as planned. Before leaving, I had updated my StellarMate. The system updated 28 components. From then on, preparing flats with Calibrate was not a problem. Switching the display in the FIT window from "Histogram" to "Statistics" which was crashing Kstar works perfectly (Grrr! I hate these bugs which are not reproducible). After the update, I even noticed that Calibrate saved the settings, which was not the case before. For this problem, the case is solved. Thank you. However, what has always been a problem has become a major obstacle. After the update, my QHYCCD cameras were no longer recognized by EKOS. I had to make some changes in the physical wiring. So I moved the cameras from the USB3 HUB to USB2 HUB. But I was not able to test the QHYCCD5III178C while guiding. It is when I arrived on site that I discovered the problem. Everything went perfectly until 23:05 (page 17 of the PDF). There I connected the QHY5III178C guidance camera.As a reminder, the internal guidance of SM never went below +/- 8". So, I switched to PHD2. If the two cameras QHY294M and QHY5III178C are connected when EKOS starts, EKOS identifies and initializes them. But when I start PHD2, it connects the EQMod mount and the guidance camera. But at the first loop, PHD2 doesn't answer anymore. Pressing stop has no effect. It is necessary to kill PHD2 to take again the hand. Obviously, the guidance doesn't work. On the other hand, if I start EKOS without connecting the QHY5III178C guidance camera, EKOS only sees the QHY294M. Once EKOS has started, I connect the QHY5III178C and launch PHD2. PHD2 initializes the camera and the guidance starts normally. If I ask for a stop on PHD2, the camera stops the looping function and I take over.Except that on 10.06.2021 at 23:05, PHD2 did not see my camera. I made many unsuccessful attempts until 00:53 when I tried to move the QHY5III178C from the USB2 Hub to the USB3 Hub. After that, PHD2 obviously found the guiding camera and I was able to image without a problem.The fact remains that EKOS obviously confuses QHY294M and QHY5III178C when both cameras are present at startup. I tried to document my entire sequence. Obviously, I have log files which are relatively large. But here is in the attached file a systematic flow of the session of June 10, 2021. I know that this problem exists since I created my setup with QHY294M, PoleMaster and QHY5III178C. But it's complicated to show. So, I hope this will help to understand what is going on. Thank you for your helpSincerelyChristian
1 year 5 months ago #72284
Attachments:

Please Log in or Create an account to join the conversation.

Thank you for the PDF, will check it out.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 5 months ago #72285

Please Log in or Create an account to join the conversation.

  • Posts: 94
  • Thank you received: 3
Hi Christian.
Did you found a solution to this? I ran into exactly the same problem with my qhy174 and qhy294 . The internal guider works for me but it's extremely limited in feature and I prefer phd2.
2 months 2 weeks ago #86196

Please Log in or Create an account to join the conversation.

Time to create page: 0.310 seconds