×
INDI Library v1.8.8 Released (09 Jan 2021)

Here are the changes from v1.8.7 to v1.8.8

Missing button icons in EKOS under Ubuntu 15.10

5 years 1 week ago
noste99
Premium Member
Premium Member
Posts: 131
More
Topic Author
Missing button icons in EKOS under Ubuntu 15.10 #6563
Hi,
Having installed KStars with EKOS last version under Ubuntu-Mate 15.10 all is working fine. I am able to connect to the RPi2 running the indiserver with the drivers for mount and ZWO ASI 120MC.

The buttons on the screens in EKOS do not all show their graphical icon, some do.
Have a look to the attached screen-shot I include.
The panel on which I can slew my mount in the different directions has empty buttons in the positions: N, S, E, W and Centre. At the corners one sees the arrows. It is self explaining what these buttons with missing graphic icons mean and I do not know what to expect there, but it seems there is something missing at the level of the themes loaded in KSTARS.

It is more disturbing in the case of the ZWO ASI cam and the EKOS control screen, or the Scheduler tab.
See the second picture attached. Icons are missing on the top right series of buttons. Here it is totally unclear what the buttons do.

Any idea how to overcome this issue?
Thanks a lot!
Stefan

Pentax K-5; Samyang 800mm F8.0;Sky-Watcher ED80 D=80mm F=600mm;ZWO ASI120MC
Attachments:

Please Log in or Create an account to join the conversation.

4 years 10 months ago 4 years 10 months ago by noste99.
noste99
Premium Member
Premium Member
Posts: 131
More
Topic Author
Missing button icons in EKOS under Ubuntu 15.10 #7088
I found in the mean time a post about this subject on the forum.
www.indilib.org/forum/ekos/967-rpi-ekos-...e-no-icons.html#6339

I tried it out without result.

Pentax K-5; Samyang 800mm F8.0;Sky-Watcher ED80 D=80mm F=600mm;ZWO ASI120MC

Please Log in or Create an account to join the conversation.

4 years 10 months ago
gerardvs
Junior Member
Junior Member
Posts: 27
More
Missing button icons in EKOS under Ubuntu 15.10 #7100
The following user(s) said Thank You noste99

Please Log in or Create an account to join the conversation.

4 years 9 months ago
ggkids
Senior Member
Senior Member
Posts: 58
More
Missing button icons in EKOS under Ubuntu 15.10 #7336
Sorry, I tried what suggested in the above link but I still missing icons. I use Kubuntu distro ...

Please Log in or Create an account to join the conversation.

4 years 9 months ago
knro
Administrator
Administrator
Posts: 8725
Karma: 51
Missing button icons in EKOS under Ubuntu 15.10 #7345

ggkids wrote: Sorry, I tried what suggested in the above link but I still missing icons. I use Kubuntu distro ...


Kubuntu? Are you sure? which version? KDE based distros shouldn't have a problem with this.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

4 years 9 months ago
ggkids
Senior Member
Senior Member
Posts: 58
More
Missing button icons in EKOS under Ubuntu 15.10 #7349
Sorry, my mistake: xubuntu 15.10 with xfce 4.12

Giovanni

Please Log in or Create an account to join the conversation.

4 years 9 months ago
sarkkipas
Senior Member
Senior Member
Posts: 58
More
Missing button icons in EKOS under Ubuntu 15.10 #7360
I'm using Kubuntu and also missing some button icons. Jasem you can see them missing in those moravian screenshots i send you.
The following user(s) said Thank You noste99

Please Log in or Create an account to join the conversation.

4 years 9 months ago
gus_
Senior Member
Senior Member
Posts: 45
More
Missing button icons in EKOS under Ubuntu 15.10 #7448
I am testing rp3 ubuntu-mate 15.10 and same problem for me.
export QT_QPA_PLATFORMTHEME=kde
kstars
didn't work for me.

Please Log in or Create an account to join the conversation.

4 years 8 months ago
sywong2000
Senior Member
Senior Member
Posts: 60
More
Missing button icons in EKOS under Ubuntu 15.10 #8185
I followed the steps here to install qt5ct:
fixmynix.com/change-qt5-application-style-with-qt5ct/
(latest version is qt5ct-0.23.tar.bz2)
build the package and configure once in qt5ct

and then run kstars at terminal with: QT_QPA_PLATFORMTHEME=qt5ct kstars

and the icons pop up right
I'm using ubuntu server 16.04 with vnc
The following user(s) said Thank You knro

Please Log in or Create an account to join the conversation.

4 years 8 months ago
noste99
Premium Member
Premium Member
Posts: 131
More
Topic Author
Missing button icons in EKOS under Ubuntu 15.10 #8241
I have now upgraded my OS to Ubuntu Mate 16.04 on RPi2.
Most of the buttons now have icons visible. Here and there an icon is missing.
Huge improvement, Great!!!!
stefan

Pentax K-5; Samyang 800mm F8.0;Sky-Watcher ED80 D=80mm F=600mm;ZWO ASI120MC

Please Log in or Create an account to join the conversation.

4 years 8 months ago
nmac
Elite Member
Elite Member
Posts: 426
Karma: 2
More
Missing button icons in EKOS under Ubuntu 15.10 #8243
Hi, I am running Xubuntu 16.04 and had the same problem.
After digging the forum nothing worked.

Installing this library "libqt5libqgtk2" solved the problem.

sudo apt-get install libqt5libqgtk2

Regards

(PT) SC@ROS Observatory
TS 6" F4 Newtonian / Canon 550D / GPU CC / Datyson T7M / Arduino Moonlite DC Clone- HEQ5 Pro
Explore Scientific 80APO - 120ST / G2-8300FW5 / ES FF 2" / ASI120MM - Arduino Moonlite DC Clone - Vixen GPD2
www.flickr.com/photos/139335144@N03/
The following user(s) said Thank You knro, max

Please Log in or Create an account to join the conversation.

4 years 8 months ago
noste99
Premium Member
Premium Member
Posts: 131
More
Topic Author
Missing button icons in EKOS under Ubuntu 15.10 #8274
I checked again and without any other manipulation all icons are no present on the buttons.
Also the new feature allowing to create profiles before launching and connecting the indi-server to devices works very well.

In order to repeat, I just upgraded to Ubuntu-Mate 16.04 and installed kstars-bleedingedge and it is all OK.

Stefan

Pentax K-5; Samyang 800mm F8.0;Sky-Watcher ED80 D=80mm F=600mm;ZWO ASI120MC

Please Log in or Create an account to join the conversation.

Time to create page: 1.082 seconds