×

INDI Library v2.0.6 is Released (02 Feb 2024)

Bi-monthly release with minor bug fixes and improvements

Esatto not connecting on Mac, wrong driver loaded?

  • Posts: 207
  • Thank you received: 17
The Esatto will not connect on my Mac. It looks like when selecting Esatto, actually the driver for the Sesto Senso 2 is chosen. Is that correct?
 
 
2 years 4 months ago #76621
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 348
  • Thank you received: 69
I think the sestosenso2 driver supports the esatto.

With my Sestosenso 2 I find that I have to manually select the serial port for it to work correctly. Otherwise the driver connects to the wrong serial port and kind of hangs, even if I stop INDI completely the indi_sestosenso2 is still there running.

Perhaps it is the same case for the Esatto, I'd suggest setting the serial port manually, save the config. Reboot the system (to ensure that the driver isn't still running) and then see if you can restart INDI.
2 years 4 months ago #76627

Please Log in or Create an account to join the conversation.

  • Posts: 207
  • Thank you received: 17
Ah, that is very helpful. I always have auto search enabled and have experienced some erratic behavior with my SestoSenso before it ‘snapped’ into connection, after which it has been working well. I might just have been lucky then that time and this time is a bit more tricky.
Will try manually connect and see how it works.


Sent from my iPad using Tapatalk
2 years 4 months ago #76729

Please Log in or Create an account to join the conversation.

  • Posts: 207
  • Thank you received: 17
Unfortunately this did not work. Also after manually selecting the proper USB-port, the connection could not be established. It looks like it is a problem with the MAC-software/driver, as it does connect properly to a unix (Ubuntu 20.04) machine. This is the message I'm getting. It is looking for a parameter 'SN', which it cannot find. Does anyone have an idea what that means? Unfortunately this did not work. Also after manually selecting the proper USB-port, the connection could not be established. It looks like it is a problem with the MAC-software/driver, as it does connect properly to a unix (Ubuntu 20.04) machine. This is the message I'm getting. It is looking for a parameter 'SN', which it cannot find. Does anyone have an idea what that means?

 
2 years 3 months ago #77406
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 348
  • Thank you received: 69
The driver requested the serial number of the Esatto, and that returned an error. Could be a few things:

1. Firmware on the Esatto is incompatible with the driver.
2. The serial port the driver is attempting to use is not the Esatto serial port.

It's a result of this function in the driver:

github.com/indilib/indi/blob/master/driv...user/sestosenso2.cpp

bool CommandSet::getSerialNumber(char *res) { return sendCmd("{\"req\":{\"get\":{\"SN\":\"\"}}}", "SN", res); }
If it is a firmware issue, the driver download contains the V1.3 firmware: eu.primalucelab.com/info/downloads.html
Last edit: 2 years 3 months ago by Giles.
2 years 3 months ago #77408

Please Log in or Create an account to join the conversation.

  • Posts: 207
  • Thank you received: 17
Thanks Giles.
I have firmware 1.3 on the Esatto. The serial port the driver is trying to connect to is the port of the Esatto. So can't see where this goes wrong. Are the drivers for the Mac version the same as the drivers for Ubuntu? Since everything is working on Ubuntu, could it be a problem specific to the way the drivers are compiled for Mac?
Btw using a Mac M1.
2 years 3 months ago #77410

Please Log in or Create an account to join the conversation.

  • Posts: 348
  • Thank you received: 69
I believe they are the same drivers. But unfortunately, I'm unfamiliar with Mac stuff.
The following user(s) said Thank You: W J Drijfhout
2 years 3 months ago #77411

Please Log in or Create an account to join the conversation.

  • Posts: 348
  • Thank you received: 69
I see you've found the other thread where people are experiencing this same problem. Looks to be Serial driver on the Mac related.
2 years 3 months ago #77430

Please Log in or Create an account to join the conversation.

  • Posts: 207
  • Thank you received: 17
Indeed, and since the problem was identical, I thought the fix would work as well. But unfortunately that's not the case yet. Investigating Silabs drivers on the Mac opens up quite a can of worms....
2 years 3 months ago #77432

Please Log in or Create an account to join the conversation.

  • Posts: 58
  • Thank you received: 2

I have the same problem with a different focuser on Mac.
It will connect with TheSky with the same serial driver but not with Ekos.

Probably there’s something wrong with the Mac port of Ekos?
indilib.org/forum/focusers-filter-wheels...i-won-t-connect.html
 
Last edit: 2 years 3 months ago by Oliver.
2 years 3 months ago #77433

Please Log in or Create an account to join the conversation.

  • Posts: 207
  • Thank you received: 17
It starts to look that way indeed. A pity, as one of the benefits of Macs is that driver issues are almost never an issue.
2 years 3 months ago #77434

Please Log in or Create an account to join the conversation.

  • Posts: 989
  • Thank you received: 154
Here's what I used with the MacOSX version of INDI Web Manager:
But this version of the driver is not the same as the version built into the MacOSX version off KStars.  They are different.  The INDI Web Manger version (which comes out as Sesto2) does not have as many controls, and no backlash compensation.  The Sesto2 and Esatto drivers in the built-in version of KStars OSX do have those features.

 
2 years 3 months ago #77443
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.317 seconds