×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Trouble Connecting ZWO/ASI EFW Wheel

  • Posts: 7
  • Thank you received: 0
Yes. Using kstars as a normal user, remotely connecting to a manually created indi server as prescribed OR using the indi web server(!), the EFW appears in my INDI control panel and I was able to connect to the filter wheel. I probably will not get to connect it up the full telescope setup until this weekend.

I'm now trying to sort out a remote connection where my laptop connects to the RPi as that was my original intention 6 months ago. It's also where my RPi/Linux knowledge fades. I'm getting connection issues (e.g. too slow / timeout) when pointing at the IP:port. I'm sure I can find a thread on those issues, though.

To summarize:
1. The EFW will not work under a local connection (June 20, 2017)
2. Make sure indiserver is properly configured to allow a remote connection (I didn't have indi_asi_wheel in my indiserver, which is why it did not connect - the web server made the apparent!)

But I think the original purpose of the thread has been solved. Thanks, Maudy!!! Please let me know if you hear anything from ZWO.
C11 on CGEM, ATIK314L+, ASI120MM on ST80 for guiding, motorized Moonlite focuser, ZWO EFW with Ha, OIII, and SII and Lum, all connected to RPi 3 with Kstars/Ekos/Indi
5 years 1 week ago #17360

Please Log in or Create an account to join the conversation.

  • Posts: 333
  • Thank you received: 24
Hi,

Per an update in another thread, I am retesting the ASI224 connecting as user. Other thread: indilib.org/forum/embedded-indi/2449-new...b-manager.html#18303

After a quick change of the systemd service file back to a user and not root. The ASI224 did connect and a test image was taken. This was done both with the local indi server and the INDI web manager running as a USER - Yay!

With the initial success, I will test a complete setup: RPI3 -> ASI1600 -> ASI EFW + ASI224 (another config is to the ASI174), and then a future setup of RPI3 -> ASI1600 -> USB2 hub -> ASI174 and Focuser.
The following user(s) said Thank You: Jasem Mutlaq
4 years 10 months ago #18319

Please Log in or Create an account to join the conversation.

  • Posts: 333
  • Thank you received: 24
Although not as planned, good news:

RPI3 -> ASI1600 -> ASI EFW + ASI174
With RPI3 -> CGEM
And RPI3-> USB Stick

All worked using the INDI-web, and Kstars/Ekos as USER and not ROOT.

Testing the ASI224 will be delayed a bit. Willl report back.
4 years 10 months ago #18363

Please Log in or Create an account to join the conversation.

  • Posts: 333
  • Thank you received: 24
I got to do a quick indoor test of the ASI224 and my other setup using the RPI3. Even though it is cloudy again, the rain is needed so no complaints.

Good news! The ASI224mm-cooled connect as USER.

This is recent for me as I tried to use it beginning of July and still needed to change the server to run as root.

Thank you for the great update!!



Sent from my iPhone using Tapatalk Pro
4 years 10 months ago #18438

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
That's great! Always nice to see some great software still being improved upon!

After getting my initial testing done a few months ago I wasn't able to get back to it. The weather has been awful and my job has just drained every ounce of energy from me!
C11 on CGEM, ATIK314L+, ASI120MM on ST80 for guiding, motorized Moonlite focuser, ZWO EFW with Ha, OIII, and SII and Lum, all connected to RPi 3 with Kstars/Ekos/Indi
4 years 10 months ago #18439

Please Log in or Create an account to join the conversation.

Time to create page: 0.425 seconds