×
INDI Library v1.8.6 Released (21 Aug 2020)

August 2020 release of INDI Library v1.8.6 introduces new drivers while providing fixes and improvements to existing devices and core framework.

ZWO EAF: Reverse Motion not working

5 months 3 days ago
mdlearnest
Fresh Boarder
Fresh Boarder
Posts: 5
More
ZWO EAF: Reverse Motion not working #52504
Sorry, what i mean by the reverse button not working is if i tell ekos to focus out 1000 steps, the focuser moves in 1000 steps. then if i hit the reverse button in order to reverse that wrong directional move, it still moves in, not out like the reverse button should do. hope that makes sense. i did pull the source down from git and compiled it. that version is working correctly.

Please Log in or Create an account to join the conversation.

5 months 3 days ago
mdlearnest
Fresh Boarder
Fresh Boarder
Posts: 5
More
ZWO EAF: Reverse Motion not working #52505
I'd also like to say one more thing. I hope it doesn't sound like I'm complaining here. I want it known that I have been using kstars/ekos with indi drivers for just over a yr now. I have been extremely pleased with them. Until the other night when this issue showed up with the ZWO focuser, I couldn't have been more pleased. I'm not sure what changed the other night, I dont remember running updates on that pi, but maybe I did. All I can say is I am SO proud of everyone that maintains these packages. To all of you developers, THANK YOU :-)
The following user(s) said Thank You gilesco

Please Log in or Create an account to join the conversation.

4 months 6 days ago
jiberjaber
Junior Boarder
Junior Boarder
Posts: 38
More
ZWO EAF: Reverse Motion not working #54256
So this isn't working for me, the guidance for this focuser is to set 0 when the tube is fully retracted and then adjust the max for max tube focuser extension - problem I have is that the steps are 0 to 10000, so if I set the tube fully in and set that as 0, the motor direction is wrong if I command a move to say 2000. If the motor reverse was working, then that would move the tube out rather than in.

I've managed to get the focuser working as it's relative at the end of the day if you dont worry about the 0 position though this of course means that positioning without a 0 reference point that is repeatable is not useful!

Any idea when this fix in the nightly will make it to the Astroberry version of Ekos?

Please Log in or Create an account to join the conversation.

4 months 2 days ago
jiberjaber
Junior Boarder
Junior Boarder
Posts: 38
More
ZWO EAF: Reverse Motion not working #54471

knro wrote: Please update to the latest INDI nightly/stable and it should be resolved.


OK - I've downloaded the 3rd party drivers from github and compiled the ASI driver, I then ran sudo make install

astroberry@astroberry:~/Projects/indi-3rdparty/indi-asi $ sudo make install
[sudo] password for astroberry:
[ 25%] Built target indi_asi_wheel
[ 50%] Built target indi_asi_ccd
[ 75%] Built target indi_asi_st4
[100%] Built target indi_asi_focuser
Install the project...
-- Install configuration: ""
-- Up-to-date: /usr/bin/indi_asi_ccd
-- Up-to-date: /usr/bin/indi_asi_wheel
-- Up-to-date: /usr/bin/indi_asi_st4
-- Up-to-date: /usr/bin/indi_asi_focuser
-- Up-to-date: /usr/share/indi/indi_asi.xml




BUT... I still have no motor reverse behaviour - if I set direction FOCUS IN and set Relative position to 1000 steps I expect the focus tube to move IN but it actually moves OUT. If I toggle Reverse Motion, I get the same behaviour.

In Ekos, the driver reports as indi_asi_focuser, Version 1.0, Interface 8 and firmware is 3.1.9

Is there something specific to Astroberry that I am missing here?
Do I need to fully build indiserver rather than the installed version ( INDI Library: 1.8.5 Code v1.8.4-93-g6a13bd11. Protocol 1.7.)

Please Log in or Create an account to join the conversation.

4 months 2 days ago
jiberjaber
Junior Boarder
Junior Boarder
Posts: 38
More
ZWO EAF: Reverse Motion not working #54473
OK so on the chance that if it didn't work out I would have to wipe and start again I decided to download and build the indiserver from git hub...

I am now watching my focus move in when commanded in and out when commanded out. Reverse Motion works now. So both the 3rd party drivers and indiserver require building to work I think.

Please Log in or Create an account to join the conversation.

4 months 10 hours ago
adonf
Junior Boarder
Junior Boarder
Posts: 32
More
ZWO EAF: Reverse Motion not working #54626
I had the same problem while going from version 1.8.1 to version 1.8.5 (bleeding under Fedora).
The "reverse" button no longer worked and the focuser used the direction opposite to that requested.
It was not EKOS (Kstars) which was in question since I had the same problem through PyIndi.
The recompiled version 1.8.5 also didn't work.

However, yesterday's git version works again.
I would not have had the idea if I had not seen this post.
Thank you very much !
The following user(s) said Thank You jiberjaber

Please Log in or Create an account to join the conversation.

3 months 3 weeks ago 3 months 3 weeks ago by jongreif. Reason: Update.
jongreif
Fresh Boarder
Fresh Boarder
Posts: 1
More
ZWO EAF: Reverse Motion not working #54940
Hi. I'm having same issue, and it's just in the last 24 hours. I, too, don't remember doing an update, but one may have occurred without my knowing. I read the manual and some of the drivers, including ASCOM, have a software means for reversing the motor, and, I think that would be a fix. I'll be watching carefully for other possible fixes (I run EKOS on an RPi and my other computer is a MAC, so ASCOM is not an easy option for me). Thanks for starting this thread and looking forward to a fix.
Jon

Update: After updating Lib to v1.8.5 and updating Ekos, including all drivers, ZWO EAF is working perfectly, again. Can't say for sure which update fixed the problem, but happy to be back in business. Thanks, all.
Jon

Please Log in or Create an account to join the conversation.

Time to create page: 0.778 seconds