×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Starizona Microtouch focuser & Stellarmate problem

  • Posts: 3
  • Thank you received: 0
Hi team,
 

File Attachment:

File Name: 2021-05-12.bz2
File Size:17 KB
Is anyone successfully using their Microtouch focuser with Stellarmate?

I'm having a world of pain with mine! Research online unfortunately shows previous problems with this combination.

Mount is Tak Temma NJP, Camera is QSI 6162, Guider is SX and the focuser is Microtouch by Starizona.

To recap, on a clear night this week. I ran a test sequence - platesolve, guide, capture, flip, solve, guide, capture ok without problems. (no logging unfortunately).
So I then ran a second sequence (with logging - see attachment 

Attachment not found

 

Attachment not found

 

File Attachment:

File Name: 2021-05-12...5-18.bz2
File Size:17 KB
) enabling the focuser - which platesolved ok, focused ok, guided ok, filter changed ok - all good until meridian flip.
Meridian flip then performed ok, plate solved again ok, guiding resumed ok, but the focus appeared to fail/stall out, on filter change post flip/plate solve, preventing capture.
This has unfortunately happened many times now, with every version of the software I've tried so far -  I'm currently using version 3:5:3 stable but have tried previous beta & stable versions at Jasem's suggestions.

Also, a serial port issue remains unresolved. I can plug everything in & start up Ekos ok, and the mount/focuser/camera & guider all connect first time.
However when the focuser eventually fails, Ekos cannot find the focuser again (usually says either Port not found or Port in use by the mount) unless I physically disconnect/reconnect it, and I usually have to reboot the Raspberry pi as well.  
I have already physically mapped the ports using the Serial Port Assistant. It's a USB controller, why does it require a serial port anyway?

I'm 100% certain that these two issues are related. Has anyone successfully tested this software using a Microtouch focuser?
Seems to be the ongoing cause of all my troubles.  I'd prefer not to have to replace it or use Voyager or SGP if this software glitch is curable, and I welcome your expert opinions.

Kind regards
Andy
 
Last edit: 1 year 1 month ago by AstroNerd.
1 year 1 month ago #71391
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 358
  • Thank you received: 26
Andy,

Yes, although I no longer use my original Microtouch controller as I buggered it up. I am currently using a replacement where I wrote the firmware to emulate the original controller.

One thing to bear in mind is that the focuser can slip, which can make finding the best position challenging. I have found that choosing Iterative works best.

I have found unrelated issues with it losing a perfectly good star when it gets too small and find it chooses a poor star when in automatic - i.e. two close together or in a cluster and it tries to focus multiple stars.

Paul
Losmandy G11 with Gemini 2 controller
QSI 583/683 monochrome camera with filter wheel
Starlight Xpress Lodestar X2 guide camera
Microtouch Focuser controlled using Arduino UNO emulating Feathertouch controller
Raspberry Pi 2GB with Raspberry Pi OS 32bit
The following user(s) said Thank You: Andy Campbell
1 year 1 month ago #71418

Please Log in or Create an account to join the conversation.

Time to create page: 0.490 seconds