×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

New All Sky camera management software: indi-allsky

  • Posts: 17
  • Thank you received: 0
Camera seems to be ok. Connected to my Windows 10 system i got picture with SharpCap.
5 months 3 weeks ago #83536

Please Log in or Create an account to join the conversation.

  • Posts: 74
  • Thank you received: 10
Laszlo,
If this is the USB 2 type ASI 120 MC model it will no longer work with Linux operating systems. You will need one of the newer USB3, ASI120 MC-S cameras or USB C, ASI120 mini for it to work.

Hope this helps

Alan
Raspberry Pi4B,ASI120MM -S Usb3, ASI385MC, Atik 428CCD, Canon 600D, NEQ6, EQMod, EQ5, AstroEQ, EQMod, Equinox ED80, ASI533MC, RedCat 51 ASI 120MM Mini.
5 months 3 weeks ago #83538

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 0

Until today at 13h it was working. I have the ASI 120 MC (black USB connector on the side).
5 months 3 weeks ago #83539

Please Log in or Create an account to join the conversation.

  • Posts: 74
  • Thank you received: 10
Laszlo,

Yes it will sort of work, especially if you have got the compatible firmware "asi120mm-compatible.iic" installed it will show some sort of image, but it will be mainly broken & distorted and the exposure controls don't fully work, There are a few threads about this subject on the forum. It would be worth a search through and have a read up on it.

Regards

Alan
Raspberry Pi4B,ASI120MM -S Usb3, ASI385MC, Atik 428CCD, Canon 600D, NEQ6, EQMod, EQ5, AstroEQ, EQMod, Equinox ED80, ASI533MC, RedCat 51 ASI 120MM Mini.
5 months 3 weeks ago #83540

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 0
Is it possible to use an IMX-291 camera from those sold on Aliexpress? I'm trying to make one work but I think the driver I chose in the installation ( 24 indi_sony_ccd) is a wrong option.
5 months 3 weeks ago #83561
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 88
  • Thank you received: 28

I think you would use the indi_v4l2_ccd server.
-
Aaron W Morris

indi-allsky - All Sky camera management software that supports any INDI capable camera
5 months 3 weeks ago #83583

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 0
Thanks. I will try your suggestion.
5 months 3 weeks ago #83598

Please Log in or Create an account to join the conversation.

  • Posts: 74
  • Thank you received: 8
Aaron,
I appreciate all the hard work you have done to create this package! I just installed Indi AllSky on an Astroberry server running on a Raspberry PI 4. The installed seemed to go just fine. It was a clean install of Astroberry and Allsky. I started the service just as described in the install section of the readme file, no errors. Where things go off the rail is when I try to access the application with the Raspberry PI using raspberrypi.local/ I get the Astroberry log on page. what am I doing wrong??
5 months 2 weeks ago #83670

Please Log in or Create an account to join the conversation.

  • Posts: 2151
  • Thank you received: 205
Unable to install this tool on an Odroid C4 running Ubuntu 20.04LTS

heidenrod@heidenrod-obs:~/indi-allsky$ ./setup.sh
###############################################
### Welcome to the indi-allsky setup script ###
###############################################


Distribution: Ubuntu
Release: 20.04
Arch: aarch64

INDI_DRIVER_PATH: /usr/bin
INDISERVER_SERVICE_NAME: indiserver
ALLSKY_SERVICE_NAME: indi-allsky
GUNICORN_SERVICE_NAME: gunicorn-indi-allsky
ALLSKY_ETC: /etc/indi-allsky
HTDOCS_FOLDER: /var/www/html/allsky
DB_FOLDER: /var/lib/indi-allsky
DB_FILE: /var/lib/indi-allsky/indi-allsky.sqlite
INSTALL_INDI: true
HTTP_PORT: 80
HTTPS_PORT: 443

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
fcitx-frontend-qt5 : Depends: libqt5gui5 (>= 5.9.0~beta) but it is not going to be installed or
libqt5gui5-gles (>= 5.9.0~beta) but it is not going to be installed
fcitx5-module-quickphrase-editor : Depends: libqt5gui5 (>= 5.7.0) but it is not going to be installed or
libqt5gui5-gles (>= 5.7.0) but it is not going to be installed
libfcitx-qt5-1 : Depends: libqt5gui5 (>= 5.7.0) but it is not going to be installed or
libqt5gui5-gles (>= 5.7.0) but it is not going to be installed
libqt5svg5 : Depends: libqt5gui5 (>= 5.12.8+dfsg~) but it is not going to be installed or
libqt5gui5-gles (>= 5.12.8+dfsg~) but it is not going to be installed
libqt5widgets5 : Depends: libqt5gui5 (>= 5.12.5) but it is not going to be installed or
libqt5gui5-gles (>= 5.12.5) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.


The script exited abnormally, please try to run again...
Kstars Mac osx
Odroid C4 / WO Redcat51 / CEM25p / ZWO533MC / QHY5L-II-M (OAG)
Last edit: 5 months 2 weeks ago by Gonzothegreat.
5 months 2 weeks ago #83682

Please Log in or Create an account to join the conversation.

  • Posts: 2151
  • Thank you received: 205
looks like the following fixed it:
# apt remove fcitx-frontend-qt5 fcitx5-module-quickphrase-editor libfcitx-qt5-1 libqt5svg5 libqt5widgets5
I had to remove them first...
Kstars Mac osx
Odroid C4 / WO Redcat51 / CEM25p / ZWO533MC / QHY5L-II-M (OAG)
5 months 2 weeks ago #83683

Please Log in or Create an account to join the conversation.

  • Posts: 2151
  • Thank you received: 205
I see that the tool uses Apache, it might be a good idea to also provide an Nginx version.
Kstars Mac osx
Odroid C4 / WO Redcat51 / CEM25p / ZWO533MC / QHY5L-II-M (OAG)
5 months 2 weeks ago #83684

Please Log in or Create an account to join the conversation.

  • Posts: 2151
  • Thank you received: 205
Different issue:

elect an INDI driver: 20
**** Setting up indiserver service ****
**** Setting up indi-allsky service ****
**** Setting up gunicorn ****
**** Enabling services ****
Failed to connect to bus: Permission denied


The script exited abnormally, please try to run again...
Kstars Mac osx
Odroid C4 / WO Redcat51 / CEM25p / ZWO533MC / QHY5L-II-M (OAG)
5 months 2 weeks ago #83686

Please Log in or Create an account to join the conversation.

Time to create page: 0.444 seconds