×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Indi Support for Bullseye 64 bit RPI4

  • Posts: 12
  • Thank you received: 0
Hi Richard,

RE: your post #80320 above, this section:

$ ~/Projects/build/libasi $ mkdir -p ~/Projects/build/indi-asi
$ ~/Projects/build/libasi $ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Debug ~/Projects/indi-3rdparty/indi-asi
CMake Error: The source "/home/pi/Projects/indi-3rdparty/indi-asi/CMakeLists.txt" does not match the source "/home/pi/Projects/indi-3rdparty/libasi/CMakeLists.txt" used to generate cache. Re-run cmake with a different source directory.

It seems you are trying to use the build directory you used (successfully...) for libasi to also make indi-asi.  Did you neglect to 'cd ~/Projects/build/indi-asi' after you created the directory in the first command, there?
9 months 3 weeks ago #80453

Please Log in or Create an account to join the conversation.

  • Posts: 203
  • Thank you received: 45
I downloaded this image downloads.raspberrypi.org/raspios_arm64/...s-bullseye-arm64.zip
Then run my scripts install-dependencies.sh and then build-soft-stable.sh from gitea.nouspiro.space/nou/astro-soft-build and got working INDI and KStars.
So try start clean by writing that image again to SD card and just download my scripts and try to run them. Don't add additional PPA my scripts should install whole INDI and KStars.
The following user(s) said Thank You: Alan Archer, Bernd Limburg, Rafa Barberá, Val Chevalier
Last edit: 9 months 3 weeks ago by nou.
9 months 3 weeks ago #80465

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 4
Thanks to both Tim and Nou.

I may have failed to change to the correct build directory. I tried again and this time got build errors relating to various properties not being defined or declared. I have the whole output if anyone is interested.

Then looked inside the repository, found indi-asi folder and the readme.md inside it which gave instructions for building the driver by itself. Tried these, they gave the same / similar errors.

So now I will try the scripts to which Nou refers, however, I will not be doing this on a clean image, because I have a pile of other things installed including CdCiel/CCDCiel, ASTAP (thanks to HAN who has recompiled this to work with Raspberry64 - see his Sourceforge page) and so forth.

Will get back here when I have tried this.

Best

R
9 months 3 weeks ago #80470

Please Log in or Create an account to join the conversation.

  • Posts: 44
  • Thank you received: 4
Nou,

Many thanks..  I just did a fresh 64 bit build last night and am at the latest (with updates) from the Raspberry Pi site.. Will try running the scripts today.  Which is "better". Stable or latest?  The Latest mentions auto-detect of cores?  Will let everyone know how it goes.  SkyX and SkyX LTI 64 bit are already installed..

Jay S.
9 months 3 weeks ago #80471

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 4
I haven't met an html bash script before. I have downloaded the scripts and attempted to run with ./ from the download location.

How do I do this on the pi? My researches only find links advising how to place html links on a web-server. I have Firefox installed but no objection to installing Chromium.

Tks

R
9 months 3 weeks ago #80480

Please Log in or Create an account to join the conversation.

  • Posts: 44
  • Thank you received: 4
Richard...

Did running the script from the command line in terminal not work?  I was just getting ready to try ./ as well..

Jay S.
9 months 3 weeks ago #80481

Please Log in or Create an account to join the conversation.

  • Posts: 203
  • Thank you received: 45
Best way to get them is clone that repository by running
git clone https://gitea.nouspiro.space/nou/astro-soft-build.git
That text is just last commit message that modified file. Both script automatically use number of cores. Stable script build last released version of INDI and KStars. I update it regullary to reflect this. You can get latest version of script by running
git pull origin
in directory with scripts.
Latest script build latest code from git repositories. This can fail as sometimes there are code error that prevent compilation or they can be unstable so use it only if you need to test really latest code.
If you just download script then you need add excutable permission to script by running
chmod +x install-dependencies.sh build-soft-latest.sh
The following user(s) said Thank You: Rafa Barberá
Last edit: 9 months 3 weeks ago by nou.
9 months 3 weeks ago #80484

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 4
Hello Nou ..

When I run
$ ./install-dependencies.sh

I get:
...
./install-dependencies.sh: line1: syntax error near unexpected token 'newline'
,/install-dependencies.sh line 1: '<!DOCTYPE html>'
...
I don'f feel that cloning the repo would have any different effect than downloading the script.

And your post seems to suggest that we should run the cloned script in that way.

The problem seems to be that bash doesn't like the "looks-like-might be-html" script ... but as I said above I have never come across this before so I'm guessing.

Tks

R
9 months 3 weeks ago #80488

Please Log in or Create an account to join the conversation.

  • Posts: 44
  • Thank you received: 4
Nou...

Didn't seem to work.. I did the GIT to being in the files and create the scripts. Got presumably near to the very end and got this message:

C++: fatal error: Killed signal terminated program cc1plus
compilation terminated.
make[2]: *** [kstars/CMakeFiles/KStarsLib.dir/build.make:864: kstars/CMakeFiles/KStarsLib.dir/KStarsLib_autogen/mocs_compilation.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [CMakeFiles/Makefile2:1184: kstars/CMakeFiles/KStarsLib.dir/all] Error 2
make: *** [Makefile:149: all] Error 2
KStars failed
9 months 3 weeks ago #80489

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 4
Hope this may be encouraging .. I downloaded the repository and ran the scripts without a hitch.

All is now working.

With many thanks

R
9 months 3 weeks ago #80493

Please Log in or Create an account to join the conversation.

  • Posts: 376
  • Thank you received: 55
You might try running it again, and lower the number of concurrent jobs
JOBS=$(grep -c ^processor /proc/cpuinfo)
to
 
JOBS=2
or
JOBS=expr $(grep -c ^processor /proc/cpuinfo ) - 1
 
120 MM Skywatcher Esprit + Celestron CGX, ZWO ASI 224MC guiding, Pegasus FocusCube+PPBA
Nikon Z7 8256 x 5504 4.34 um. Triad Ultra Quad NB Filter
1) MeLE Quieter3C 8G Ubuntu-mate 22.04.1 2) Odroid-N2. 3) StellarMate RPI4 8G
The good, the bad, the ugly at sciencedowneast.no-ip.ca/zenphoto/
Last edit: 9 months 3 weeks ago by Jerry Black.
9 months 3 weeks ago #80496

Please Log in or Create an account to join the conversation.

  • Posts: 44
  • Thank you received: 4
Jerry..

Thanks.  May delete the directory ands try over with the downloaded version like Richard..  What does the JOBS reduction do (other than lower the number I mean). I have nothing else running that I'm aware of at the time.  Is this a "memory" constraint type issue, etc..

Thanks!!!

Jay S.
9 months 3 weeks ago #80497

Please Log in or Create an account to join the conversation.

Time to create page: 1.271 seconds