×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Does Kstars work ok on M1 Macs yet?

  • Posts: 678
  • Thank you received: 82
Someone asked me, but I didn't have an answer.  Hoping someone here can answer if the new M1 Macs will run KStars/INDI ok.

iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD
William Optics Star71
ASI 1600Mm Pro, ASI 462MC
Moonlight motorfocus & Esatto focuser
LodeStar X2 and ZWO OAG
DewBuster
NANO PC-T4
4 months 1 day ago #79704

Please Log in or Create an account to join the conversation.

  • Posts: 295
  • Thank you received: 55
I don't do capture with my macs, but I did install kstars on my M1 MacBook Air just to see what happened. It appears to run just fine. I didn't actually try to connect any physical equipment, just ran with simulators.
4 months 1 day ago #79707

Please Log in or Create an account to join the conversation.

  • Posts: 2706
  • Thank you received: 742
Yes, it works fine, but it is all running under Rosetta for now.  We have tried to build for M1 natively a number of times, but QT actually isn't supporting M1 natively just yet, so we have to wait.  But it works the same as it does on Intel as far as I understand.
4 months 23 hours ago #79745

Please Log in or Create an account to join the conversation.

  • Posts: 331
  • Thank you received: 48
Is this older link relevant? www.qt.io/blog/qt-on-apple-silicon or are there still issues?


I'm having issues trying to compile kstars on my intel iMac using QT Creator 6.0.1
   Based on Qt 6.2.2 (Clang 12.0 (Apple), 64 bit)
   Built on Dec 15 2021 08:50:39
but I'm confident that it's just me somehow, as would be the norm.
120 MM Skywatcher Esprit on Celestron CGX, ZWO ASI 224MC guiding, Pegasus FocusCube v2+PPBA
Nikon Z7 8256 x 5504, 35.9 x 23.9mm 4.34 um. Triad Ultra Quad NB Filter
1) Odroid-N2 Ubuntu-mate 20.04 2) StellarMate RPI4 8G
The good, the bad, the ugly at sciencedowneast.no-ip.ca/zenphoto/
Last edit: 3 months 4 weeks ago by Jerry Black.
3 months 4 weeks ago #79789

Please Log in or Create an account to join the conversation.

  • Posts: 2706
  • Thank you received: 742
Hi Jerry, I don’t know since I haven’t tried to do anything in QT 6 yet.  Right now I think craft is using qt 5.15.2 if I am not mistaken.  It is probably good to test qt6 out of course, but right now it’s probably best to use the same version as craft does officially.  For building on m1 macs using Rosetta there are a couple of articles out there on how to do it.   I don’t have an m1 Mac myself so I can’t try.  It sounds like it’s fairly simple and there is more than one way to do it.  
3 months 4 weeks ago #79793

Please Log in or Create an account to join the conversation.

  • Posts: 331
  • Thank you received: 48
So I finally found and installed qt 5.15.2 at download.qt.io/official_releases/qtcreator/5.0/5.0.3/

With an up-to-date kstars via git pull and ~/Projects/kstars-on-osx-craft/build-kstars.sh -d, 

QTCreator gives me the following during a build (pointing to the craft QT  ~/Astroroot/craft-root/bin/qmake).

17:33:41: Running steps for project kstars...
17:33:41: Starting: "/Users/user/AstroRoot/craft-root/dev-utils/bin/cmake" --build /Users/user/AstroRoot/craft-root/download/git/kde/applications/build-kstars-Craft_Kit-Debug --target all
[1/10 95.7/sec] Generating KSTARS_APP_SRCS.iconset/icon_32x32@2x.png
[2/10 190.4/sec] Generating KSTARS_APP_SRCS.iconset/icon_32x32.png
[3/10 284.9/sec] Generating KSTARS_APP_SRCS.iconset/icon_128x128.png
[4/10 131.2/sec] Generating index.cache.bz2
FAILED: doc/index.cache.bz2
cd /Users/user/AstroRoot/craft-root/download/git/kde/applications/kstars/doc && /Users/user/AstroRoot/craft-root/bin/meinproc5 --check --cache /Users/user/AstroRoot/craft-root/download/git/kde/applications/build-kstars-Craft_Kit-Debug/doc//index.cache.bz2 index.docbook
kf.doctools.core: Error: Could not find kdoctools catalogs
[5/10 146.9/sec] Generating KSTARS_APP_SRCS.icns
ninja: build stopped: subcommand failed.
17:33:42: The process "/Users/user/AstroRoot/craft-root/dev-utils/bin/cmake" exited with code 1.

Is this the correct place to record this issue, or should I add it to github.com/rlancaste/kstars-on-osx-craft as an issue?
120 MM Skywatcher Esprit on Celestron CGX, ZWO ASI 224MC guiding, Pegasus FocusCube v2+PPBA
Nikon Z7 8256 x 5504, 35.9 x 23.9mm 4.34 um. Triad Ultra Quad NB Filter
1) Odroid-N2 Ubuntu-mate 20.04 2) StellarMate RPI4 8G
The good, the bad, the ugly at sciencedowneast.no-ip.ca/zenphoto/
Last edit: 3 months 4 weeks ago by Jerry Black.
3 months 4 weeks ago #79829

Please Log in or Create an account to join the conversation.

  • Posts: 2706
  • Thank you received: 742
Craft by default uses its own QT, not the one you downloaded.  A few years ago, we were using the downloaded QT but then craft started bundling QT along with it.  You shouldn't need another QT to use craft to build KStars.  If you want to edit code separately in QT Creator, it can be very nice to have your own QT, but you don't need it to use my script to build kstars.

Did you use an old craft installation when doing this build?  In the last couple of weeks, I did a lot of work to integrate my own recipes with craft's recipes and get them up on the actual craft server instead of maintaining a separate repo of recipes.  So a lot was actually changed, enough that I would probably recommend completely replacing the AstroRoot directory.  Sorry about that, but there could easily be issues with packages that were built with the old recipes mixing with ones from the new recipes.  But I have tested it many times and it should work fine now.  If you try this and then get the same issue again, please let me know and we can check it out.

The upshot is that in fact today for the very first time, we have a fully working KStars build on the binary-factory!  binary-factory.kde.org/view/MacOS/job/KStars_Release_macos/
No guarantee that it is perfect yet, but I did do a bunch of testing today and I only found one issue so far.  It was an issue with the packaging of the libgphoto driver.  I put in a pull request for a fix and I am hoping that tomorrow it gets accepted and tomorrow's build has a working gphoto DSLR driver. After I do a little more testing I will post it in the forum as a new post.  But you can try it out now if you like.

Thanks,

Rob
3 months 4 weeks ago #79831

Please Log in or Create an account to join the conversation.

  • Posts: 331
  • Thank you received: 48
The binary-factory version appears (simulator) to work well!  Excellent work!
120 MM Skywatcher Esprit on Celestron CGX, ZWO ASI 224MC guiding, Pegasus FocusCube v2+PPBA
Nikon Z7 8256 x 5504, 35.9 x 23.9mm 4.34 um. Triad Ultra Quad NB Filter
1) Odroid-N2 Ubuntu-mate 20.04 2) StellarMate RPI4 8G
The good, the bad, the ugly at sciencedowneast.no-ip.ca/zenphoto/
Last edit: 3 months 3 weeks ago by Jerry Black.
3 months 4 weeks ago #79851

Please Log in or Create an account to join the conversation.

Time to create page: 0.228 seconds