×

INDI Library v2.0.6 is Released (02 Feb 2024)

Bi-monthly release with minor bug fixes and improvements

Is INDI ready for Ubuntu 22.04?

  • Posts: 116
  • Thank you received: 2
I have just installed Ubuntu 22.04. Now i'm trying to install INDI/EKOS/Kstars but it resulting in errrors
like:E: Unable to locate package gsc while running sudo apt-get install indi-full gsc

Is all prepared for Ubuntu 22.04 or is het best to be waiting for a few months?
Last edit: 1 year 10 months ago by Joshua R.
1 year 10 months ago #82277

Please Log in or Create an account to join the conversation.

  • Posts: 215
  • Thank you received: 41
Hi Josh,

As far as I am aware Ubuntu 22.04 is not released yet (I think due on 21st April), so what you have is a pre-release daily build beta version. The KStars/EKOS/indi repositories will not be populated with Jammy Jellyfish versions yet. It can take a few weeks after the official release before all the repositories catch up. I tend to wait at least a month before trying to upgrade. This makes for a smoother transition.

Cheers

Mike
1 year 10 months ago #82287

Please Log in or Create an account to join the conversation.

  • Posts: 116
  • Thank you received: 2
Due tthe errors i have goneback to earlier version.
1 year 10 months ago #82302

Please Log in or Create an account to join the conversation.

All packages are indeed built for 22.04 already. For GSC, I rebuilt that for 22.04. What else is missing?
The following user(s) said Thank You: Spartacus
1 year 10 months ago #82310

Please Log in or Create an account to join the conversation.

  • Posts: 116
  • Thank you received: 2
This weekend i'll try again with 22.04. I keep you posted.
1 year 10 months ago #82319

Please Log in or Create an account to join the conversation.

  • Posts: 215
  • Thank you received: 41
I can confirm that KStars will install using sudo apt-get install indi-bin kstars-bleeding rather than indi-full. This contains less drivers but will be enough for most common equipment.

Cheers
1 year 10 months ago #82340

Please Log in or Create an account to join the conversation.

  • Posts: 215
  • Thank you received: 41
Hi

Here is a list of the current unmet dependencies in indi-full regarding the new Ubuntu 22.04 Jammy Jelly fish distro.

The following packages have unmet dependencies:
indi-aagcloudwatcher-ng : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
indi-apogee : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
indi-armadillo-platypus : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
indi-astromechfoc : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
indi-avalon : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
indi-bresserexos2 : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
indi-celestronaux : Depends: libindialignmentdriver1 (>= 1.9.4+dfsg) but it is not installable
Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
indi-dreamfocuser : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
indi-dsi : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
indi-eqmod : Depends: libindialignmentdriver1 (>= 1.9.4+dfsg) but it is not installable
Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
indi-ffmv : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
indi-fli : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
indi-gpsd : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
indi-gpsnmea : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
indi-maxdomeii : Depends: libindidriver1 (>= 1.9.3+dfsg) but it is not installable
indi-mgen : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
indi-nexdome : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
indi-nightscape : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
indi-shelyak : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
indi-starbook : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
indi-starbook-ten : Depends: libindidriver1 (>= 1.9.3+dfsg) but it is not installable
indi-sx : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
indi-talon6 : Depends: libindidriver1 (>= 1.9.4+dfsg) but it is not installable
E: Unable to correct problems, you have held broken packages.
As of 24th April

Cheers

Mike
1 year 10 months ago #82502

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 2
Hello

Remove previous installe with :
Sudo apt remove kstars
Sudo apt autoremove

And installe from official repository :
sudo apt-add-repository ppa:mutlaqja/ppa
sudo apt update
Sudo apt installe kstars-bleeding

I just started to test tommorow but they are some display bugs
The following user(s) said Thank You: R Dan Nafe
1 year 10 months ago #82504

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
Hello I can confirm that kstars can be installed using the official repository and this command
sudo apt install inbi-bin kstars-bleeding


But...

It's still asking for some indi lib that are missing such as indi-eqmod or indi-asi-ccd

indi-full is uninstallable
1 year 10 months ago #82534

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
I confirm thas kstars can be installed using official repo and with this command:
sudo apt install indi-bin kstars-bleeding

but...

kstars is still asking for som indi libraries such as indi-eqmod ans indi-asi-ccd
1 year 10 months ago #82535

Please Log in or Create an account to join the conversation.

On Kubuntu, they're building all the INDI packages. This poses a problem with the PPA and there is conflict. This is not the issue with standard Ubuntu, just Kubuntu. I changed the names of all packages so that they supercede the Kubuntu packages next we I trigger a build. Will do that for next stable INDI release.
The following user(s) said Thank You: Spartacus
1 year 10 months ago #82538

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
Thanks for this information,
So what is the correct repo and correct command to have everything functionnal (with asi camera, eqmod...)

I tried this (with the nightly build repo)
sudo apt install indi-full
this answer that indi-full is not availlable
1 year 10 months ago #82549

Please Log in or Create an account to join the conversation.

Time to create page: 1.518 seconds