×

INDI Library v1.9.7 Released (29 Jul 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Is INDI ready for Ubuntu 22.04?

  • Posts: 7
  • Thank you received: 2
Same here. Not only indi_eqmod_telescope but also indi_canon_cdd cannot be found. I tried also to compile indi lib from source but can get any improvements: compilation was fine but some pieces (i.e. indi_eqmod) were not compiled at all. Any possible work-around for my PC with ubuntu 22.04? I do not have any RPi or other stuff like that.
Thanks
EQ6-R Pro, TecnoSky 70/420, Canon 700D, Svbony 30mm guide scope, QHY 5LII guide camera
The following user(s) said Thank You: R Dan Nafe
3 months 4 days ago #82852

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 2
News from here. I recompile from source both indi-lib and indi-3rd-party on my Ubuntu 22.04 PC. Everything (almost) went smooth. So in this respect problem solved.
EQ6-R Pro, TecnoSky 70/420, Canon 700D, Svbony 30mm guide scope, QHY 5LII guide camera
3 months 3 days ago #82857

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 1
just some supplementary info to help guide people like me (basic linux users) with sorting this problem. After messing up my system completely (novice linux user getting ahead of himself) I reinstated it from a backup and carried on playing around and I've learned a few things...

If you are running a rpi at the mount and connecting to that remotely from your pc all is not lost, there's good news... you should be fine until you upgrade the rpi to run on 22.04. :-)

If you install gsc and then kstars bleeding from jasem's ppa on a clean install of 22.04LTS... it will install without any conflicts or dependency problems at all. This does only install indi-bin though. All you then need to do is setup a new equipment profile in kstars (on the upgraded 22.04 computer) identical to your usual one. You then select the equipment as you normally would but you'll notice that the driver names have a little icon next to them. These are the remote drivers that are running on your rpi. If your equipment is not connected to your pc... your pc does not need the drivers itself. It just needs to connect to the indi server that is connected to the equipment. This is how I'm working around the issue until I decide to poke about under the hood and inevitably break linux again....probably this afternoon ;-)

If you are connecting your equipment directly to your pc then you're gonna be doing some compiling soon if you want indi-full I'm afraid. Compiling does work as long as you've got the patience to deal with the couple of dependency issues that will arise until libindi1 is updated. These clever chaps who write all this software for us will figure out the issue pretty soon I suspect.

btw...when you clone the indi-allsky project from github there is a build_indi.sh script in the misc folder. It's a lazy way to get indi-full but it worked for me until I bricked my system.
The following user(s) said Thank You: R Dan Nafe
3 months 3 days ago #82859

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 1
Any news on when indi-full will be ready to install?
Indi-bin doesn’t seem to have all the drivers?

I figured all would be ready for 22.04 if I left it a month?

Or should I just go back to 21.10?

It definitely does not install properly on Ubuntu mate 22.04
It keeps saying it’s missing libindidriver1
3 months 3 days ago #82866

Please Log in or Create an account to join the conversation.

I believe these issue should be resolved by next INDI release where we will rebuild all packages and override the OS packages.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Davy HUBERT, Spartacus, Darren
3 months 3 days ago #82868

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 1
Hi, any idea as to when this will happen? Thanks!
2 months 3 weeks ago #82969

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 4
The bug is not fixed in 1.9.6
2 months 3 weeks ago #83000

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 4
I'm installing a new Ubuntu Mate 22.04 on a X86. This bug is still there on 1.9.6
I'm going to setup this machine before July (must).
Should I rollback to 20.4 or waiting for a patch? Or build from source?
2 months 3 weeks ago #83001

Please Log in or Create an account to join the conversation.

I'm building all the drivers now, it usually takes two days to finish since launchpad is pretty slow.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 months 3 weeks ago #83003

Please Log in or Create an account to join the conversation.

More bad news. Canonical Launchpad is having networking issues now so there is more down time :(
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 months 3 weeks ago #83007

Please Log in or Create an account to join the conversation.

  • Posts: 38
  • Thank you received: 3
Hi !

I used pinning and I was able to install indi-sx and indi-eqmod. Some conflicts still remains and I couldn't install indi-full but at least it works for my setup...
To do so, I created a file /etc/apt/preferences.d/indi with this content :
Package: *
Pin: release o=LP-PPA-mutlaqja
Pin-Priority: 800

Hope it helps.

Regards
Davy Hubert
Setup : 102/715 APO refractor; Orion Atlas Eq-G mount; Trius-SX694 CCD; SX-Lodestar X2 guide cam; SX FilterWheel; Moonlite Focuser
Last edit: 2 months 3 weeks ago by Davy HUBERT.
2 months 3 weeks ago #83008

Please Log in or Create an account to join the conversation.

  • Posts: 201
  • Thank you received: 17
On Lubuntu 22.04, the installation gone well but Kstars is not launching at all.

From Terminal :
kstars: symbol lookup error: kstars: undefined symbol: _ZN7SSolver10Parameters14convertFromMapE4QMapI7QString8QVariantE
Last edit: 2 months 3 weeks ago by Euripides.
2 months 3 weeks ago #83037

Please Log in or Create an account to join the conversation.

Time to create page: 0.717 seconds